aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-04-11 03:04:19 +0800
committermarino <marino@FreeBSD.org>2015-04-11 03:04:19 +0800
commit94dc76cd69217b9257602092c1b83d9189b1c00a (patch)
tree06a641c9a5c34f159616bdc9d331dbee9985118e
parentf66f5483408764aac4da421638e94c80a0aaaa61 (diff)
downloadfreebsd-ports-gnome-94dc76cd69217b9257602092c1b83d9189b1c00a.tar.gz
freebsd-ports-gnome-94dc76cd69217b9257602092c1b83d9189b1c00a.tar.zst
freebsd-ports-gnome-94dc76cd69217b9257602092c1b83d9189b1c00a.zip
Unbreak five wxgtk30-based ports by adding -std=c++11 to cxxflags
The breakage was a result of moving wxgtk30 to c++11 from c++01
-rw-r--r--games/megaglest/Makefile1
-rw-r--r--graphics/delaboratory/Makefile1
-rw-r--r--graphics/gtimelapse/Makefile1
-rw-r--r--graphics/wxsvg/Makefile3
-rw-r--r--math/gambit/Makefile1
5 files changed, 6 insertions, 1 deletions
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index 258154c2e436..8b3a654d65f8 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -27,6 +27,7 @@ USES= cmake compiler:c++11-lib display:build dos2unix lua openal:al,alut pkgcon
USE_GL= glew gl glu
USE_SDL= yes
USE_WX= 3.0
+USE_CXXSTD= c++11
WX_UNICODE= yes
CFLAGS+= -I${LOCALBASE}/include
diff --git a/graphics/delaboratory/Makefile b/graphics/delaboratory/Makefile
index 1821056382af..db15dfcfaa4c 100644
--- a/graphics/delaboratory/Makefile
+++ b/graphics/delaboratory/Makefile
@@ -15,6 +15,7 @@ LICENSE= GPLv3
USES= gmake
MAKE_ARGS= CXX="${CXX}" WXCONFIG="${WX_CONFIG}"
USE_WX= 3.0
+USE_CXXSTD= c++11
WX_UNICODE= yes
PLIST_FILES= bin/${PORTNAME}
diff --git a/graphics/gtimelapse/Makefile b/graphics/gtimelapse/Makefile
index cb9a9583c8ab..b2aff4dfc766 100644
--- a/graphics/gtimelapse/Makefile
+++ b/graphics/gtimelapse/Makefile
@@ -18,6 +18,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USES= pkgconfig
USE_WX= 3.0
+USE_CXXSTD= c++11
WX_UNICODE= yes
WX_CONF_ARGS= absolute
USE_AUTOTOOLS= libtoolize aclocal automake autoconf
diff --git a/graphics/wxsvg/Makefile b/graphics/wxsvg/Makefile
index 92d8b161f0f1..4fc9c099a937 100644
--- a/graphics/wxsvg/Makefile
+++ b/graphics/wxsvg/Makefile
@@ -20,7 +20,8 @@ WX_UNICODE= yes
WX_CONF_ARGS= absolute
USE_GNOME= cairo
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBAV_CFLAGS="${LIBAV_CFLAGS}" LIBAV_LIBS="${LIBAV_LIBS}"
+CONFIGURE_ENV= LIBAV_CFLAGS="${LIBAV_CFLAGS}" LIBAV_LIBS="${LIBAV_LIBS}" \
+ CXXFLAGS="${CXXFLAGS} -std=c++11"
MAKE_ENV= AM_CPPFLAGS="${LIBAV_CFLAGS}"
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/math/gambit/Makefile b/math/gambit/Makefile
index 0a7ac062fcd6..5894b003ecd0 100644
--- a/math/gambit/Makefile
+++ b/math/gambit/Makefile
@@ -14,6 +14,7 @@ LICENSE= GPLv2
USES= compiler:c++11-lib
USE_GNOME= gtk20
USE_WX= 3.0
+USE_CXXSTD= c+=11
WX_CONF_ARGS= absolute
WX_UNICODE= yes
GNU_CONFIGURE= yes