aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-07-15 13:13:49 +0800
committermiwi <miwi@FreeBSD.org>2010-07-15 13:13:49 +0800
commit9b436485b46ccba80cba1f79f304861b3c3e144b (patch)
treeaf9634f1e880431040821fc08db3848226b545ab
parenteecbd6e2eaf7f0649e70d41c00264310cd9b9f6c (diff)
downloadfreebsd-ports-gnome-9b436485b46ccba80cba1f79f304861b3c3e144b.tar.gz
freebsd-ports-gnome-9b436485b46ccba80cba1f79f304861b3c3e144b.tar.zst
freebsd-ports-gnome-9b436485b46ccba80cba1f79f304861b3c3e144b.zip
- Update to 2.4.5
PR: 148551 Submitted by: Port Fury
-rw-r--r--emulators/bochs/Makefile134
-rw-r--r--emulators/bochs/distinfo6
2 files changed, 13 insertions, 127 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 3feb277c09b3..b57e1d6a4c02 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bochs
-PORTVERSION= 2.4
+PORTVERSION= 2.4.5
PORTEPOCH= 2
CATEGORIES= emulators
MASTER_SITES= SF
@@ -19,17 +19,13 @@ USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-docbook
-OPTIONS= 1G_PAGES "Enable support for 1G pages in long mode" off \
- A20_PIN "Enable support for A20 pin" on \
+OPTIONS= A20_PIN "Enable support for A20 pin" on \
ACPI "Enable ACPI emulation" off \
- AES "Enable support of AES CPU extensions" off \
ALIGN_CHECK "Enable alignment check support" on \
- APIC "Enable APIC support" off \
ASSERT_CHECK "Enable BX_ASSERT checks" off \
CDROM "Enable CDROM support" on \
CLGD54XX "Enable Cirrus Logic GD54xx video card" off \
CONF_MSRS "Enable configurable MSR registers support" on \
- DAZ "Enable demornals-are-zeros support" off \
DEBUGGER "Enable debugger support" off \
DEBUGGER_X86 "Enable x86 hardware debugger" off \
DISASM "Enable disassemler support " on \
@@ -37,24 +33,17 @@ OPTIONS= 1G_PAGES "Enable support for 1G pages in long mode" off \
FPU "Enable FPU emulator" on \
GAMEPORT "Enable standard PC gameport support" off \
GDB_STUB "Enable GDB stub support" off \
- GLOBAL_PAGES "Enable support for global pages in PDE/PTE" off \
IDLE_HACK "Keep Bochs from using all CPU time" off \
- IGNORE_BADMSR "Ignore unknown MSR references (don't panic)" on \
INSTRUMENT "Enable support for instrumentation" off \
IODEBUG "Enable I/O interface to debugger" off \
- LARGE_PAGES "Enable support for large (2M/4M) pages" on \
LOGGING "Enable logging" on \
LONG_PHY_ADDR "Enable support for physical address >= 32bit" off \
- MTRR "Enable MTRR emulation (CPU level >= 6)" off \
MISALIGNEDSSE "Enable misaligned SSE support" off \
- MOVBE "Enable MOVBE intel Atom(R) instruction support" off \
MWAIT "Enable experimental MONITOR/MWAIT support" off \
NE2000 "Enable limited ne2000 support" on \
NEW_PIT "Enable use of the new PIT model" on \
OPTIMIZATIONS "Enable all safe speeed optimizations" on \
- PAE "Enable support for Physical Address Extensions" off \
PCI "Enable limited i440FX PCI support" on \
- POPCNT "Enable support for POPCNT instruction" off \
PLUGINS "Enable building dynamic loadable plugins" off \
PNIC "Enable PCI pseudo NIC (network card) support" off \
RAW_SERIAL "Use raw serial port access" off \
@@ -63,23 +52,19 @@ OPTIONS= 1G_PAGES "Enable support for 1G pages in long mode" off \
RFB "Enable VNC server support in display" off \
SB16 "Enable Sound Blaster 16 emulation" on \
SDL "Enable SDL display interface" off \
- SEP "Enable SYSENTER/SYSEXIT support" off \
SHOW_IPS "Enable logging of measured IPS" off \
SMP "Enable SMP simulation support (CPU level 6)" off \
- SSE4 "Enable emulation of SSE4.2 instruction set" off \
SVGA "Enable SVGAlib support" off \
TCACHE "Enable trace cache" on \
TERM "Use text only, console based interface" off \
USB "Enable limited USB UHCI support" off \
USB_OHCI "Enable limited USB OHCI support" off \
VBE "Enable VGA BIOS Extensions" on \
- VME "Enable Virtual 8086 mode extensions" on \
VMX "Enable Virtialization extensions" off \
WX "Use WxWidgets display interface" off \
X11 "Use X11 display interface" on \
X86_64 "Enable AMD x86-64 support" off \
- XPM "Enable XPM library support" off \
- XSAVE "Enable support of XSAVE/XRSTOR CPU extensions" off
+ XPM "Enable XPM library support" off
CFLAGS+= -fno-exceptions -fomit-frame-pointer
CXXFLAGS+= -fno-rtti
@@ -98,12 +83,6 @@ SUB_FILES= pkg-message
CONFIGURE_ARGS+=--with-nogui
.endif
-.if defined(WITH_1G_PAGES) && defined(WITH_X86_64)
-CONFIGURE_ARGS+=--enable-1g-pages
-.else
-CONFIGURE_ARGS+=--disable-1g-pages
-.endif
-
.if !defined(WITH_A20_PIN)
CONFIGURE_ARGS+=--disable-a20-pin
.else
@@ -116,24 +95,12 @@ CONFIGURE_ARGS+=--enable-acpi
CONFIGURE_ARGS+=--disable-acpi
.endif
-.if defined(WITH_AES)
-CONFIGURE_ARGS+=--enable-aes
-.else
-CONFIGURE_ARGS+=--disable-aes
-.endif
-
.if !defined(WITH_ALIGN_CHECK)
CONFIGURE_ARGS+=--disable-alignment-check
.else
CONFIGURE_ARGS+=--enable-alignment-check
.endif
-.if defined(WITH_APIC)
-CONFIGURE_ARGS+=--enable-apic
-.else
-CONFIGURE_ARGS+=--disable-apic
-.endif
-
.if defined(WITH_ASSERT_CHECK)
CONFIGURE_ARGS+=--enable-assert-checks
.else
@@ -158,12 +125,6 @@ CONFIGURE_ARGS+=--disable-configurable-msrs
CONFIGURE_ARGS+=--enable-configurable-msrs
.endif
-.if defined(WITH_DAZ)
-CONFIGURE_ARGS+=--enable-daz
-.else
-CONFIGURE_ARGS+=--disable-daz
-.endif
-
.if defined(WITH_DEBUGGER)
CONFIGURE_ARGS+=--enable-debugger
.else
@@ -206,24 +167,12 @@ CONFIGURE_ARGS+=--enable-gdb-stub
CONFIGURE_ARGS+=--disable-gdb-stub
.endif
-.if defined(WITH_GLOBAL_PAGES)
-CONFIGURE_ARGS+=--enable-global-pages
-.else
-CONFIGURE_ARGS+=--disable-global-pages
-.endif
-
.if defined(WITH_IDLE_HACK)
CONFIGURE_ARGS+=--enable-idle-hack
.else
CONFIGURE_ARGS+=--disable-idle-hack
.endif
-.if !defined(WITH_IGNORE_BADMSR)
-CONFIGURE_ARGS+=--disable-ignore-bad-msr
-.else
-CONFIGURE_ARGS+=--enable-ignore-bad-msr
-.endif
-
.if defined(WITH_INSTRUMENT)
CONFIGURE_ARGS+=--enable-instrumentation
.else
@@ -236,12 +185,6 @@ CONFIGURE_ARGS+=--enable-iodebug
CONFIGURE_ARGS+=--disable-iodebug
.endif
-.if !defined(WITH_LARGE_PAGES)
-CONFIGURE_ARGS+=--disable-large-pages
-.else
-CONFIGURE_ARGS+=--enable-large-pages
-.endif
-
.if !defined(WITH_LOGGING)
CONFIGURE_ARGS+=--disable-logging
.else
@@ -254,24 +197,12 @@ CONFIGURE_ARGS+=--enable-long-phy-address
CONFIGURE_ARGS+=--disable-long-phy-address
.endif
-.if defined(WITH_MTRR)
-CONFIGURE_ARGS+=--enable-mtrr
-.else
-CONFIGURE_ARGS+=--disable-mtrr
-.endif
-
.if defined(WITH_MISALIGNDSSE)
CONFIGURE_ARGS+=--enable-misaligned-sse
.else
CONFIGURE_ARGS+=--disable-misaligned-sse
.endif
-.if defined(WITH_MOVBE)
-CONFIGURE_ARGS+=--enable-movbe
-.else
-CONFIGURE_ARGS+=--disable-movbe
-.endif
-
.if defined(WITH_MWAIT)
CONFIGURE_ARGS+=--enable-monitor-mwait
.else
@@ -296,24 +227,12 @@ CONFIGURE_ARGS+=--enable-all-optimizations
CONFIGURE_ARGS+=--disable-all-optimizations
.endif
-.if defined(WITH_PAE)
-CONFIGURE_ARGS+=--enable-pae
-.else
-CONFIGURE_ARGS+=--disable-pae
-.endif
-
.if defined(WITH_PCI)
CONFIGURE_ARGS+=--enable-pci
.else
CONFIGURE_ARGS+=--disable-pci
.endif
-.if defined(WITH_POPCNT)
-CONFIGURE_ARGS+=--enable-popcnt
-.else
-CONFIGURE_ARGS+=--disable-popcnt
-.endif
-
.if defined(WITH_PLUGINS)
CONFIGURE_ARGS+=--enable-plugins
.else
@@ -359,12 +278,6 @@ USE_SDL= sdl
CONFIGURE_ARGS+=--with-sdl
.endif
-.if defined(WITH_SEP)
-CONFIGURE_ARGS+=--enable-sep
-.else
-CONFIGURE_ARGS+=--disable-sep
-.endif
-
.if defined(WITH_SHOW_IPS)
CONFIGURE_ARGS+=--enable-show-ips
.else
@@ -376,11 +289,6 @@ CONFIGURE_ARGS+=--enable-smp
WITH_CPU_LEVEL= 6
.endif
-.if defined(WITH_SSE4) || defined(WITH_AES) || defined(WITH_XSAVE)
-CONFIGURE_ARGS+=--enable-sse=4 --enable-sse-extension
-WITH_CPU_LEVEL= 6
-.endif
-
.if defined(WITH_SVGA)
LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
CONFIGURE_ARGS+=--with-svga
@@ -414,20 +322,16 @@ CONFIGURE_ARGS+=--disable-vbe
CONFIGURE_ARGS+=--enable-vbe
.endif
-.if !defined(WITH_VME)
-CONFIGURE_ARGS+=--disable-vme
-.else
-CONFIGURE_ARGS+=--enable-vme
-.endif
-
.if defined(WITH_VMX)
CONFIGURE_ARGS+=--enable-vmx
+WITH_CPU_LEVEL= 6
.else
CONFIGURE_ARGS+=--disable-vmx
.endif
.if defined(WITH_WX)
-USE_WX= 2.4-2.6
+USE_WX= 2.4+
+CONFIGURE_ENV= WX_CONFIG="${WX_CONFIG}"
CONFIGURE_ARGS+=--with-wx
.else
CONFIGURE_ARGS+=--disable-debugger-gui
@@ -451,28 +355,11 @@ CONFIGURE_ARGS+=--enable-xpm
CONFIGURE_ARGS+=--disable-xpm
.endif
-.if defined(WITH_XSAVE)
-CONFIGURE_ARGS+=--enable-xsave
-.else
-CONFIGURE_ARGS+=--disable-xsave
-.endif
-
.if defined(WITH_CPU_LEVEL)
.if ${WITH_CPU_LEVEL} < 3 || ${WITH_CPU_LEVEL} > 6
IGNORE= can not install: WITH_CPU_LEVEL must be an integer value between 3 and 6
.endif
CONFIGURE_ARGS+=--enable-cpu-level=${WITH_CPU_LEVEL}
-.if ${WITH_CPU_LEVEL} < 5
-CONFIGURE_ARGS+=--disable-mmx
-.endif
-.endif
-
-.if defined(WITH_SSE_LEVEL)
-.if ${WITH_SSE_LEVEL} >= 1 && ${WITH_SSE_LEVEL} <= 3
-CONFIGURE_ARGS+=--enable-sse=${WITH_SSE_LEVEL}
-.else
-IGNORE= can not install: WITH_SSE_LEVEL must be an integer value between 1 and 3
-.endif
.endif
pre-everything::
@@ -480,9 +367,6 @@ pre-everything::
.if !defined(WITH_CPU_LEVEL)
@${ECHO_CMD} "If you want to change the processor level to emulate (default is 5, aka Pentium), set WITH_CPU_LEVEL to the desired value. Choices are 3, 4, 5 and 6 which mean target 386, 486, Pentium or Pentium Pro emulation." | ${FMT}
.endif
-.if !defined(WITH_SSE_LEVEL)
- @${ECHO_CMD} "If you want to enable SSE you have to set WITH_SSE_LEVEL to 1, 2 or 3." | ${FMT}
-.endif
@${ECHO_CMD}
post-patch:
@@ -504,8 +388,10 @@ post-patch:
${WRKSRC}/doc/docbook/user/user.dbk ${WRKSRC}/doc/man/*.[15]
@${REINPLACE_CMD} -Ee 's|/usr/(include/vga\.h)|${LOCALBASE}/\1|' \
${WRKSRC}/gui/svga.cc
- @${REINPLACE_CMD} -Ee 's|(^LOCAL_CXXFLAGS.+=)|\1 @CPPFLAGS@|' \
- ${WRKSRC}/gui/Makefile.in
+ @${REINPLACE_CMD} -Ee \
+ 's|(^LOCAL_CXXFLAGS.+=)|\1 @CPPFLAGS@|; \
+ s|(-lvgagl)$$|\1 @LDFLAGS@|' \
+ ${WRKSRC}/gui/Makefile.in
post-install:
.if defined(WITH_PLUGINS)
diff --git a/emulators/bochs/distinfo b/emulators/bochs/distinfo
index 91203d062ab9..d2aea2d6bbb5 100644
--- a/emulators/bochs/distinfo
+++ b/emulators/bochs/distinfo
@@ -1,3 +1,3 @@
-MD5 (bochs-2.4.tar.gz) = 45d19285bf68687772537c3eaeeb657f
-SHA256 (bochs-2.4.tar.gz) = 998d81c3cd8c022d2913c8d9d3bef4b9f171e2f685d5c8b5a5eb3b2cd92e4695
-SIZE (bochs-2.4.tar.gz) = 4041139
+MD5 (bochs-2.4.5.tar.gz) = fda7eadcd9590934d2901f8439631463
+SHA256 (bochs-2.4.5.tar.gz) = b948622a364c2e7da4221a6a4640ba2efa68422e1411ac377c69d37f46f67616
+SIZE (bochs-2.4.5.tar.gz) = 4059598