aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-05-03 14:32:09 +0800
committermarcus <marcus@FreeBSD.org>2003-05-03 14:32:09 +0800
commit9ddc7f1308662f6048cc522ffaed58287929510a (patch)
tree2041b521c3a74d1d872ae9651bc0de85c5e29af2
parentbde38595fb897edce53e9c28d4ed189ce8967e42 (diff)
downloadfreebsd-ports-gnome-9ddc7f1308662f6048cc522ffaed58287929510a.tar.gz
freebsd-ports-gnome-9ddc7f1308662f6048cc522ffaed58287929510a.tar.zst
freebsd-ports-gnome-9ddc7f1308662f6048cc522ffaed58287929510a.zip
Disable thread support by default. This was interfering with ports
such as mod_php4 with DOMXML support. It also has the potential of affecting other ports on -STABLE that rely on libxml2 to build shared libraries. I have filed a bug with the libxml2 developers to see if we can rectify this situation moving forward. More details can be found at: http://bugzilla.gnome.org/show_bug.cgi?id=112144
-rw-r--r--textproc/libxml2/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 8d8bb15ee49e..482efbd2ae0d 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libxml2
PORTVERSION= 2.5.7
+PORTREVISION= 1
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.5
@@ -22,7 +23,7 @@ RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
USE_BZIP2= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
-USE_GNOME= gnomehack
+USE_GNOME= gnomehack gnometarget
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
CONFIGURE_ARGS= --with-iconv=${LOCALBASE} \
@@ -42,7 +43,9 @@ PLIST_SUB+= PYTHON:="@comment "
PKGNAMESUFFIX= -nopython
.endif
-.if defined(LIBXML_WITHOUT_THREADS)
+.if defined(WITH_THREADS)
+CONFIGURE_ARGS+= --with-threads
+.else
CONFIGURE_ARGS+= --without-threads
.endif
@@ -67,7 +70,7 @@ pre-everything::
@${ECHO_MSG} "libxml2 has the following tunables:"
@${ECHO_MSG} ""
@${ECHO_MSG} " WITHOUT_PYTHON=yes Turns off Python support"
- @${ECHO_MSG} " LIBXML_WITHOUT_THREADS=yes Turns off pthread support"
+ @${ECHO_MSG} " WITHOUT_THREADS=yes Turns off pthread support"
@${ECHO_MSG} " WITH_SCHEMA=yes Turns on XML Schema support"
@${ECHO_MSG} " WITH_MEM_DEBUG=yes Turns on memory debugging"
@${ECHO_MSG} " WITH_XMLLINT_HIST=yes Turns on history for xmllint"