aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2012-10-13 07:15:35 +0800
committermadpilot <madpilot@FreeBSD.org>2012-10-13 07:15:35 +0800
commit9ebd1978872d7f713a0cc517bb6015d1ef9dd4fb (patch)
tree7dfbf45e6d6de46274f455b714cd6a072105eb2f
parent1e2bce76fc6c8008355c9e9697581366e81aa7d0 (diff)
downloadfreebsd-ports-gnome-9ebd1978872d7f713a0cc517bb6015d1ef9dd4fb.tar.gz
freebsd-ports-gnome-9ebd1978872d7f713a0cc517bb6015d1ef9dd4fb.tar.zst
freebsd-ports-gnome-9ebd1978872d7f713a0cc517bb6015d1ef9dd4fb.zip
- Add patch to fix compilation with gcc46.
Submitted by: Andriy Gapon <avg@FreeBSD.org> Feature safe: yes
-rw-r--r--multimedia/libva/Makefile1
-rw-r--r--multimedia/libva/files/patch-test-v4l_h264-encode-capture.cpp14
2 files changed, 12 insertions, 3 deletions
diff --git a/multimedia/libva/Makefile b/multimedia/libva/Makefile
index 723aa396f414..11b10932c386 100644
--- a/multimedia/libva/Makefile
+++ b/multimedia/libva/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libva
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://cgit.freedesktop.org/${PORTNAME}/snapshot/
diff --git a/multimedia/libva/files/patch-test-v4l_h264-encode-capture.cpp b/multimedia/libva/files/patch-test-v4l_h264-encode-capture.cpp
index cfea87dc01bc..d257cb10a9e8 100644
--- a/multimedia/libva/files/patch-test-v4l_h264-encode-capture.cpp
+++ b/multimedia/libva/files/patch-test-v4l_h264-encode-capture.cpp
@@ -1,6 +1,14 @@
--- test/v4l_h264/encode/capture.cpp.orig 2012-10-04 15:30:51.000000000 +0200
-+++ test/v4l_h264/encode/capture.cpp 2012-10-08 22:31:01.067189237 +0200
-@@ -37,7 +37,11 @@
++++ test/v4l_h264/encode/capture.cpp 2012-10-11 17:57:55.361081933 +0200
+@@ -30,6 +30,7 @@
+ */
+
+ #include <cstdlib> /* EXIT_FAILURE, EXIT_SUCCESS */
++#include <cstdio> /* printf */
+ #include <string>
+ #include <cstring> /* strerror() */
+ #include <cassert>
+@@ -37,7 +38,11 @@
#include <fcntl.h> /* low-level i/o */
#include <errno.h>
#include <unistd.h>
@@ -12,7 +20,7 @@
#include <sys/stat.h>
#include <sys/mman.h>
#include <sys/ioctl.h>
-@@ -451,10 +455,15 @@
+@@ -451,10 +456,15 @@
}
for (n_buffers = 0; n_buffers < 4; ++n_buffers) {
buffers[n_buffers].length = buffer_size;