aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2011-12-09 03:41:25 +0800
committernox <nox@FreeBSD.org>2011-12-09 03:41:25 +0800
commita703e7f42bb455a4eb5c70511a946b5c830e11b5 (patch)
treec59ffa27e744f890874603944903c5bd31b6d7ba
parent06e4dfee007b003a881a4109ee13ba66ce0ec18c (diff)
downloadfreebsd-ports-gnome-a703e7f42bb455a4eb5c70511a946b5c830e11b5.tar.gz
freebsd-ports-gnome-a703e7f42bb455a4eb5c70511a946b5c830e11b5.tar.zst
freebsd-ports-gnome-a703e7f42bb455a4eb5c70511a946b5c830e11b5.zip
- Fix random vdr-sxfe xvdr+tcp:// reconnect failures. (I shall update
this and the other vdr ports to newer versions later.) - Bump PORTREVISION. Feature safe: yes
-rw-r--r--multimedia/vdr-plugin-xineliboutput/Makefile2
-rw-r--r--multimedia/vdr-plugin-xineliboutput/files/patch-xine_input_vdr.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/multimedia/vdr-plugin-xineliboutput/Makefile b/multimedia/vdr-plugin-xineliboutput/Makefile
index 47d60364067d..8eb54816a9fa 100644
--- a/multimedia/vdr-plugin-xineliboutput/Makefile
+++ b/multimedia/vdr-plugin-xineliboutput/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vdr-plugin-xineliboutput
PORTVERSION= 1.0.90s20110308.2305
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= multimedia
MASTER_SITES= SF:release \
LOCAL:snapshot
diff --git a/multimedia/vdr-plugin-xineliboutput/files/patch-xine_input_vdr.c b/multimedia/vdr-plugin-xineliboutput/files/patch-xine_input_vdr.c
new file mode 100644
index 000000000000..bc1410a041ac
--- /dev/null
+++ b/multimedia/vdr-plugin-xineliboutput/files/patch-xine_input_vdr.c
@@ -0,0 +1,11 @@
+--- a/xine_input_vdr.c
++++ b/xine_input_vdr.c
+@@ -5526,7 +5526,7 @@ static int connect_tcp_data_stream(vdr_i
+ LOGERR("Data stream write error (TCP)");
+ } else if( XIO_READY != io_select_rd(fd_data)) {
+ LOGERR("Data stream poll failed (TCP)");
+- } else if((n=read(fd_data, tmpbuf, sizeof(tmpbuf))) <= 0) {
++ } else if((n=read(fd_data, tmpbuf, sizeof("DATA\r\n") - 1)) <= 0) {
+ LOGERR("Data stream read failed (TCP)");
+ } else if(n<6 || strncmp(tmpbuf, "DATA\r\n", 6)) {
+ tmpbuf[n] = 0;