aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2013-10-21 03:37:16 +0800
committermm <mm@FreeBSD.org>2013-10-21 03:37:16 +0800
commitb4cd81e3b32523d8192f5cbaef09ee885a2f9fa2 (patch)
tree4f1b72962d3e1c14923a6149496b6be1537cc2c6
parent5b29c02a35752e4a8c03bfc991ba702492329c2f (diff)
downloadfreebsd-ports-gnome-b4cd81e3b32523d8192f5cbaef09ee885a2f9fa2.tar.gz
freebsd-ports-gnome-b4cd81e3b32523d8192f5cbaef09ee885a2f9fa2.tar.zst
freebsd-ports-gnome-b4cd81e3b32523d8192f5cbaef09ee885a2f9fa2.zip
Compile wkhtmltopdf under FreeBSD 10.x by dependig on gcc
TODO: backport patches from www/qt4-webkit
-rw-r--r--converters/wkhtmltopdf/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/converters/wkhtmltopdf/Makefile b/converters/wkhtmltopdf/Makefile
index 087885749e46..2023116a52c1 100644
--- a/converters/wkhtmltopdf/Makefile
+++ b/converters/wkhtmltopdf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wkhtmltopdf
DISTVERSION= 0.11.0_rc1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= converters
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}:wkhtmltopdf \
${MASTER_SITE_LOCAL}
@@ -25,6 +25,7 @@ USE_XORG= x11 xext xrender
USE_PERL5= build
USE_LDCONFIG= yes
HAS_CONFIGURE= yes
+USE_GCC= yes
OPTIONS_DEFINE= BUNDLED_LIBS
BUNDLED_LIBS_DESC= Use Qt-bundled jpeg, mng, png and tiff
@@ -76,6 +77,8 @@ post-patch:
-e 's|/usr/X11R6/include|${LOCALBASE}/include/X11|g' \
-e 's|/usr/X11R6/lib|${LOCALBASE}/lib|g' \
${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+ @${REINPLACE_CMD} -e "s|gcc|${CC}|g" -e "s|g++|${CXX}|g" \
+ ${WRKSRC}/mkspecs/common/g++-base.conf
post-build:
@cd ${WRKSRC} && \