aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2003-07-26 06:08:27 +0800
committeroliver <oliver@FreeBSD.org>2003-07-26 06:08:27 +0800
commitb4fc134bb65c92fa782dfc326646aecdc30830dd (patch)
tree614d49d2168bc51243352e68c5506c08f3f86bfc
parent12cdb28c804a4485ec2119283f09ea953737d219 (diff)
downloadfreebsd-ports-gnome-b4fc134bb65c92fa782dfc326646aecdc30830dd.tar.gz
freebsd-ports-gnome-b4fc134bb65c92fa782dfc326646aecdc30830dd.tar.zst
freebsd-ports-gnome-b4fc134bb65c92fa782dfc326646aecdc30830dd.zip
Add sysmon 0.91.19,
a network tool designed for high performance and accurate monitoring. PR: 47402 Submitted by: Manuel Kreutz <mk@nomtec.net>
-rw-r--r--net-mgmt/sysmon/Makefile40
-rw-r--r--net-mgmt/sysmon/distinfo1
-rw-r--r--net-mgmt/sysmon/pkg-descr12
-rw-r--r--net-mgmt/sysmon/pkg-plist14
-rw-r--r--net/Makefile1
-rw-r--r--net/sysmon/Makefile40
-rw-r--r--net/sysmon/distinfo1
-rw-r--r--net/sysmon/pkg-descr12
-rw-r--r--net/sysmon/pkg-plist14
9 files changed, 135 insertions, 0 deletions
diff --git a/net-mgmt/sysmon/Makefile b/net-mgmt/sysmon/Makefile
new file mode 100644
index 000000000000..16d255c921d1
--- /dev/null
+++ b/net-mgmt/sysmon/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: net/sysmon
+# Date created: 23 January 2003
+# Whom: Manuel Kreutz <mk@nomtec.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sysmon
+PORTVERSION= 0.91.19
+CATEGORIES= net
+MASTER_SITES= ftp://puck.nether.net/pub/jared/
+
+MAINTAINER= mk@nomtec.net
+COMMENT= A network tool designed for high performance and accurate monitoring
+
+DOCS= Changes.html binaries.html config.html docs.html index.html \
+ jclient.jpg net-example.png sysmon.conf.man.html sysmon.jpg \
+ sysmon.man.html
+MAN8= sysmon.man.8 sysmon.conf.man.8
+
+GNU_CONFIGURE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/sysmon ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/sysmond ${PREFIX}/bin
+ ${INSTALL_DATA} \
+ ${WRKSRC}/examples/sysmon.conf.dist ${PREFIX}/etc/sysmon.conf.sample
+
+.for man in ${MAN8}
+ ${INSTALL_MAN} ${WRKSRC}/docs/${man:S/.8//} ${MANPREFIX}/man/man8/${man}
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for doc in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/docs/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/sysmon/distinfo b/net-mgmt/sysmon/distinfo
new file mode 100644
index 000000000000..36ec60633871
--- /dev/null
+++ b/net-mgmt/sysmon/distinfo
@@ -0,0 +1 @@
+MD5 (sysmon-0.91.19.tar.gz) = ee2b1ddee87d95615a98f3ad0539c44a
diff --git a/net-mgmt/sysmon/pkg-descr b/net-mgmt/sysmon/pkg-descr
new file mode 100644
index 000000000000..1587cff38ed0
--- /dev/null
+++ b/net-mgmt/sysmon/pkg-descr
@@ -0,0 +1,12 @@
+Sysmon is a network monitoring tool designed to provide high
+performance and accurate network monitoring.
+
+This tool is available in the public domain for anyone to use
+it that is interested. It provides better performance and
+checking capabilities than other tools such as Rover, Nocmon
+(not this: Nocmonitor),Whatsup, Big Brother, and other such tools.
+
+Currently supported protocols include SMTP, IMAP, HTTP,TCP,
+UDP, NNTP, and PING tests.
+
+WWW: http://www.sysmon.org/
diff --git a/net-mgmt/sysmon/pkg-plist b/net-mgmt/sysmon/pkg-plist
new file mode 100644
index 000000000000..964603db3ed6
--- /dev/null
+++ b/net-mgmt/sysmon/pkg-plist
@@ -0,0 +1,14 @@
+bin/sysmond
+bin/sysmon
+etc/sysmon.conf.sample
+%%PORTDOCS%%%%DOCSDIR%%/Changes.html
+%%PORTDOCS%%%%DOCSDIR%%/binaries.html
+%%PORTDOCS%%%%DOCSDIR%%/config.html
+%%PORTDOCS%%%%DOCSDIR%%/docs.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/jclient.jpg
+%%PORTDOCS%%%%DOCSDIR%%/net-example.png
+%%PORTDOCS%%%%DOCSDIR%%/sysmon.conf.man.html
+%%PORTDOCS%%%%DOCSDIR%%/sysmon.jpg
+%%PORTDOCS%%%%DOCSDIR%%/sysmon.man.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/net/Makefile b/net/Makefile
index d5476a578292..ad50c15d8c19 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -654,6 +654,7 @@
SUBDIR += suckblow
SUBDIR += sup
SUBDIR += svnc
+ SUBDIR += sysmon
SUBDIR += tac_plus-libradius
SUBDIR += tac_plus4
SUBDIR += tacshell
diff --git a/net/sysmon/Makefile b/net/sysmon/Makefile
new file mode 100644
index 000000000000..16d255c921d1
--- /dev/null
+++ b/net/sysmon/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: net/sysmon
+# Date created: 23 January 2003
+# Whom: Manuel Kreutz <mk@nomtec.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sysmon
+PORTVERSION= 0.91.19
+CATEGORIES= net
+MASTER_SITES= ftp://puck.nether.net/pub/jared/
+
+MAINTAINER= mk@nomtec.net
+COMMENT= A network tool designed for high performance and accurate monitoring
+
+DOCS= Changes.html binaries.html config.html docs.html index.html \
+ jclient.jpg net-example.png sysmon.conf.man.html sysmon.jpg \
+ sysmon.man.html
+MAN8= sysmon.man.8 sysmon.conf.man.8
+
+GNU_CONFIGURE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/sysmon ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/sysmond ${PREFIX}/bin
+ ${INSTALL_DATA} \
+ ${WRKSRC}/examples/sysmon.conf.dist ${PREFIX}/etc/sysmon.conf.sample
+
+.for man in ${MAN8}
+ ${INSTALL_MAN} ${WRKSRC}/docs/${man:S/.8//} ${MANPREFIX}/man/man8/${man}
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for doc in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/docs/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/sysmon/distinfo b/net/sysmon/distinfo
new file mode 100644
index 000000000000..36ec60633871
--- /dev/null
+++ b/net/sysmon/distinfo
@@ -0,0 +1 @@
+MD5 (sysmon-0.91.19.tar.gz) = ee2b1ddee87d95615a98f3ad0539c44a
diff --git a/net/sysmon/pkg-descr b/net/sysmon/pkg-descr
new file mode 100644
index 000000000000..1587cff38ed0
--- /dev/null
+++ b/net/sysmon/pkg-descr
@@ -0,0 +1,12 @@
+Sysmon is a network monitoring tool designed to provide high
+performance and accurate network monitoring.
+
+This tool is available in the public domain for anyone to use
+it that is interested. It provides better performance and
+checking capabilities than other tools such as Rover, Nocmon
+(not this: Nocmonitor),Whatsup, Big Brother, and other such tools.
+
+Currently supported protocols include SMTP, IMAP, HTTP,TCP,
+UDP, NNTP, and PING tests.
+
+WWW: http://www.sysmon.org/
diff --git a/net/sysmon/pkg-plist b/net/sysmon/pkg-plist
new file mode 100644
index 000000000000..964603db3ed6
--- /dev/null
+++ b/net/sysmon/pkg-plist
@@ -0,0 +1,14 @@
+bin/sysmond
+bin/sysmon
+etc/sysmon.conf.sample
+%%PORTDOCS%%%%DOCSDIR%%/Changes.html
+%%PORTDOCS%%%%DOCSDIR%%/binaries.html
+%%PORTDOCS%%%%DOCSDIR%%/config.html
+%%PORTDOCS%%%%DOCSDIR%%/docs.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/jclient.jpg
+%%PORTDOCS%%%%DOCSDIR%%/net-example.png
+%%PORTDOCS%%%%DOCSDIR%%/sysmon.conf.man.html
+%%PORTDOCS%%%%DOCSDIR%%/sysmon.jpg
+%%PORTDOCS%%%%DOCSDIR%%/sysmon.man.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%