aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-11-27 18:27:20 +0800
committerbapt <bapt@FreeBSD.org>2011-11-27 18:27:20 +0800
commitb9642ff7051f70b3e3a1f7a8864ba05c9c93150f (patch)
treef42f54d5ed9c97a8d95247798c06d8886ae9d4a6
parent21ba1deb38f88c2a401f83281e75d0a8b86adb65 (diff)
downloadfreebsd-ports-gnome-b9642ff7051f70b3e3a1f7a8864ba05c9c93150f.tar.gz
freebsd-ports-gnome-b9642ff7051f70b3e3a1f7a8864ba05c9c93150f.tar.zst
freebsd-ports-gnome-b9642ff7051f70b3e3a1f7a8864ba05c9c93150f.zip
Upgrade yajl to 2.0.1 (mirror it my self as upstream still not provide real static distfiles)
Take back maintainership chase library bump Feature safe: yes
-rw-r--r--devel/yajl/Makefile8
-rw-r--r--devel/yajl/distinfo4
-rw-r--r--devel/yajl/files/patch-src__CMakeLists.txt10
-rw-r--r--devel/yajl/files/patch-test__run_tests.sh82
-rw-r--r--devel/yajl/pkg-plist3
-rw-r--r--textproc/raptor2/Makefile3
-rw-r--r--x11-wm/i3/Makefile3
7 files changed, 12 insertions, 101 deletions
diff --git a/devel/yajl/Makefile b/devel/yajl/Makefile
index 912b668ff413..dd6d36f594e1 100644
--- a/devel/yajl/Makefile
+++ b/devel/yajl/Makefile
@@ -6,16 +6,16 @@
#
PORTNAME= yajl
-PORTVERSION= 1.0.11
+PORTVERSION= 2.0.1
CATEGORIES= devel
MASTER_SITES= LOCAL/bapt \
http://files.etoilebsd.net/yajl/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bapt@FreeBSD.org
COMMENT= A Portable JSON parsing and serialization library in ANSI C
-GITREF= f4baae0
-DISTNAME= lloyd-${PORTNAME}-${PORTVERSION}-0-g${GITREF}
+GITREF= f4b2b1a
+DISTNAME= lloyd-${PORTNAME}-${PORTVERSION}-${GITREF}
WRKSRC= ${WRKDIR}/lloyd-${PORTNAME}-${GITREF}
PLIST_SUB= VERSION=${PORTVERSION}
diff --git a/devel/yajl/distinfo b/devel/yajl/distinfo
index dd92019f9b2a..0bd8796e6da4 100644
--- a/devel/yajl/distinfo
+++ b/devel/yajl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lloyd-yajl-1.0.11-0-gf4baae0.tar.gz) = 1e98e03b927a8ec466baea527647f5e243f56f71bdec48cdab1c875f0f8b96a9
-SIZE (lloyd-yajl-1.0.11-0-gf4baae0.tar.gz) = 53705
+SHA256 (lloyd-yajl-2.0.1-f4b2b1a.tar.gz) = c2d9096ba1ebc9a368347c7c695cfbbc72690571a5f7955ce226eedbea5b4721
+SIZE (lloyd-yajl-2.0.1-f4b2b1a.tar.gz) = 82102
diff --git a/devel/yajl/files/patch-src__CMakeLists.txt b/devel/yajl/files/patch-src__CMakeLists.txt
deleted file mode 100644
index a6e2851dd54b..000000000000
--- a/devel/yajl/files/patch-src__CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/CMakeLists.txt.orig 2010-07-22 00:12:15.000000000 +0200
-+++ ./src/CMakeLists.txt 2011-02-08 14:32:53.832389559 +0100
-@@ -86,5 +86,6 @@
- # 64-bit systems which use 'lib64'
- INSTALL(TARGETS yajl LIBRARY DESTINATION lib${LIB_SUFFIX})
- INSTALL(TARGETS yajl_s ARCHIVE DESTINATION lib${LIB_SUFFIX})
-- INSTALL(DIRECTORY api/ DESTINATION include/yajl)
-+ INSTALL(FILES ${PUB_HDRS} DESTINATION include/yajl)
-+ INSTALL(FILES ${incDir}/yajl_version.h DESTINATION include/yajl)
- ENDIF()
diff --git a/devel/yajl/files/patch-test__run_tests.sh b/devel/yajl/files/patch-test__run_tests.sh
deleted file mode 100644
index 23ee5d5b62e1..000000000000
--- a/devel/yajl/files/patch-test__run_tests.sh
+++ /dev/null
@@ -1,82 +0,0 @@
---- ./test/run_tests.sh.orig 2010-01-08 18:05:11.000000000 +0100
-+++ ./test/run_tests.sh 2010-03-29 19:19:09.218500262 +0200
-@@ -1,7 +1,7 @@
--#!/usr/bin/env bash
-+#!/bin/sh
-
- DIFF_FLAGS="-u"
--if [[ `uname` == *W32* ]] ; then
-+if [ `uname` = "*W32*" ] ; then
- DIFF_FLAGS="-wu"
- fi
-
-@@ -9,9 +9,9 @@
- # particular test binary (useful for non-cmake build systems).
- if [ -z "$testBin" ]; then
- testBin="../build/test/Debug/yajl_test.exe"
-- if [[ ! -x $testBin ]] ; then
-+ if [ ! -x $testBin ] ; then
- testBin="../build/test/yajl_test"
-- if [[ ! -x $testBin ]] ; then
-+ if [ ! -x $testBin ] ; then
- echo "cannot execute test binary: '$testBin'"
- exit 1;
- fi
-@@ -20,41 +20,44 @@
-
- echo "using test binary: $testBin"
-
--let testsSucceeded=0
--let testsTotal=0
-+testsSucceeded=0
-+testsTotal=0
-
- for file in cases/*.json ; do
- allowComments="-c"
-
- # if the filename starts with dc_, we disallow comments for this test
-- if [[ $(basename $file) == dc_* ]] ; then
-- allowComments=""
-- fi
-+ case $(basename $file) in
-+ dc_*)
-+ allowComments=""
-+ ;;
-+ esac
- echo -n " test case: '$file': "
-- let iter=1
-+ iter=1
- success="success"
-
-+ echo "$testBin $allowComments -b $iter < $file > ${file}.test "
- # parse with a read buffer size ranging from 1-31 to stress stream parsing
-- while (( $iter < 32 )) && [ $success == "success" ] ; do
-+ while [ $iter -lt 32 ] && [ $success = "success" ] ; do
- $testBin $allowComments -b $iter < $file > ${file}.test 2>&1
- diff ${DIFF_FLAGS} ${file}.gold ${file}.test
-- if [[ $? == 0 ]] ; then
-- if (( $iter == 31 )) ; then let testsSucceeded+=1 ; fi
-+ if [ $? -eq 0 ] ; then
-+ if [ $iter -eq 31 ] ; then : $(( testsSucceeded += 1)) ; fi
- else
- success="FAILURE"
-- let iter=32
-+ iter=32
- fi
-- let iter+=1
-+ : $(( iter += 1 ))
- rm ${file}.test
- done
-
- echo $success
-- let testsTotal+=1
-+ : $(( testsTotal += 1 ))
- done
-
- echo $testsSucceeded/$testsTotal tests successful
-
--if [[ $testsSucceeded != $testsTotal ]] ; then
-+if [ $testsSucceeded != $testsTotal ] ; then
- exit 1
- fi
-
diff --git a/devel/yajl/pkg-plist b/devel/yajl/pkg-plist
index 28268944aa63..aad7d88e0e42 100644
--- a/devel/yajl/pkg-plist
+++ b/devel/yajl/pkg-plist
@@ -4,8 +4,9 @@ include/yajl/yajl_version.h
include/yajl/yajl_common.h
include/yajl/yajl_gen.h
include/yajl/yajl_parse.h
+include/yajl/yajl_tree.h
lib/libyajl.so
-lib/libyajl.so.1
+lib/libyajl.so.2
lib/libyajl.so.%%VERSION%%
lib/libyajl_s.a
@dirrm include/yajl
diff --git a/textproc/raptor2/Makefile b/textproc/raptor2/Makefile
index 9509d75ffcbf..44faa371393b 100644
--- a/textproc/raptor2/Makefile
+++ b/textproc/raptor2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= raptor2
PORTVERSION= 2.0.4
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://download.librdf.org/source/ \
SF/librdf/${PORTNAME}/${PORTVERSION}
@@ -15,7 +16,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= RDF Parser Toolkit for Redland
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
- yajl.1:${PORTSDIR}/devel/yajl
+ yajl.2:${PORTSDIR}/devel/yajl
CONFLICTS= raptor-1.4.1[0-9]* raptor-1.4.21
diff --git a/x11-wm/i3/Makefile b/x11-wm/i3/Makefile
index e97741d16b82..8cc872081729 100644
--- a/x11-wm/i3/Makefile
+++ b/x11-wm/i3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= i3
DISTVERSION= 4.1
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= http://i3wm.org/downloads/ \
${MASTER_SITE_LOCAL}
@@ -21,7 +22,7 @@ LIB_DEPENDS= xcb.2:${PORTSDIR}/x11/libxcb \
startup-notification-1.0:${PORTSDIR}/x11/startup-notification \
xcb-event.1:${PORTSDIR}/x11/xcb-util \
ev.4:${PORTSDIR}/devel/libev \
- yajl.1:${PORTSDIR}/devel/yajl
+ yajl.2:${PORTSDIR}/devel/yajl
USE_XORG= x11
USE_BISON= build