aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2017-01-22 18:30:31 +0800
committerbapt <bapt@FreeBSD.org>2017-01-22 18:30:31 +0800
commitbd384c3a8deff415a0f4f5da7e0117b3ab730cbb (patch)
treed3ec158623972c3161121c85552fd74f547ef683
parent6c1e55158cb18ae1b2213a452b9f1bd861b14944 (diff)
downloadfreebsd-ports-gnome-bd384c3a8deff415a0f4f5da7e0117b3ab730cbb.tar.gz
freebsd-ports-gnome-bd384c3a8deff415a0f4f5da7e0117b3ab730cbb.tar.zst
freebsd-ports-gnome-bd384c3a8deff415a0f4f5da7e0117b3ab730cbb.zip
Actually apply the proper patch
-rw-r--r--devel/pkgconf/Makefile2
-rw-r--r--devel/pkgconf/files/patch-libpkgconf_pkg.c27
2 files changed, 22 insertions, 7 deletions
diff --git a/devel/pkgconf/Makefile b/devel/pkgconf/Makefile
index 51368adf3dff..839fd5b28755 100644
--- a/devel/pkgconf/Makefile
+++ b/devel/pkgconf/Makefile
@@ -2,7 +2,7 @@
PORTNAME= pkgconf
PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= https://distfiles.dereferenced.org/pkgconf/ \
http://files.etoilebsd.net/pkgconf/
diff --git a/devel/pkgconf/files/patch-libpkgconf_pkg.c b/devel/pkgconf/files/patch-libpkgconf_pkg.c
index eb2f31099057..7a8a3fdf4e9a 100644
--- a/devel/pkgconf/files/patch-libpkgconf_pkg.c
+++ b/devel/pkgconf/files/patch-libpkgconf_pkg.c
@@ -1,11 +1,26 @@
--- libpkgconf/pkg.c.orig 2017-01-20 02:01:30 UTC
+++ libpkgconf/pkg.c
-@@ -1341,7 +1341,7 @@ pkgconf_pkg_traverse(pkgconf_client_t *c
- if (maxdepth == 0)
- return eflags;
+@@ -1336,6 +1336,7 @@ pkgconf_pkg_traverse(pkgconf_client_t *c
+ void *data,
+ int maxdepth)
+ {
++ unsigned int saved_flags = client->flags;
+ unsigned int eflags = PKGCONF_PKG_ERRF_OK;
-- if ((root->flags & PKGCONF_PKG_PROPF_VIRTUAL) != PKGCONF_PKG_PROPF_VIRTUAL || (client->flags & PKGCONF_PKG_PKGF_SKIP_ROOT_VIRTUAL) != PKGCONF_PKG_PKGF_SKIP_ROOT_VIRTUAL)
-+ if ((root->flags & PKGCONF_PKG_PROPF_VIRTUAL) != PKGCONF_PKG_PROPF_VIRTUAL || (client->flags & ~PKGCONF_PKG_PKGF_SKIP_ROOT_VIRTUAL) != PKGCONF_PKG_PKGF_SKIP_ROOT_VIRTUAL)
- {
+ if (maxdepth == 0)
+@@ -1346,6 +1347,7 @@ pkgconf_pkg_traverse(pkgconf_client_t *c
if (func != NULL)
func(client, root, data);
+ }
++ client->flags &= ~PKGCONF_PKG_PKGF_SKIP_ROOT_VIRTUAL;
+
+ if (!(client->flags & PKGCONF_PKG_PKGF_SKIP_CONFLICTS))
+ {
+@@ -1368,6 +1370,7 @@ pkgconf_pkg_traverse(pkgconf_client_t *c
+ if (eflags != PKGCONF_PKG_ERRF_OK)
+ return eflags;
+ }
++ client->flags = saved_flags;
+
+ return eflags;
+ }