aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2011-08-18 14:22:18 +0800
committerbeech <beech@FreeBSD.org>2011-08-18 14:22:18 +0800
commitc418ec59bd58b0b9db6e564f1c82e3062fce2633 (patch)
treef56a809f9636cface2845e7dc3e356a62359896d
parent616e2ce4b308fd6ac26656637407284ea7bb4d83 (diff)
downloadfreebsd-ports-gnome-c418ec59bd58b0b9db6e564f1c82e3062fce2633.tar.gz
freebsd-ports-gnome-c418ec59bd58b0b9db6e564f1c82e3062fce2633.tar.zst
freebsd-ports-gnome-c418ec59bd58b0b9db6e564f1c82e3062fce2633.zip
- Update to 20110817
- Add LICENSE section - Change default for BACKTRACE option to On PR: ports/159850 Submitted by: Jase Thew <freebsd@beardz.net> (maintainer)
-rw-r--r--irc/weechat-devel/Makefile12
-rw-r--r--irc/weechat-devel/distinfo4
-rw-r--r--irc/weechat-devel/files/patch-src-gui-curses-CMakeLists_txt11
-rw-r--r--irc/weechat-devel/files/patch-src-gui-curses-gui_curses_h12
-rw-r--r--irc/weechat-devel/files/patch-src-gui-curses-gui_curses_term_c11
5 files changed, 44 insertions, 6 deletions
diff --git a/irc/weechat-devel/Makefile b/irc/weechat-devel/Makefile
index d47d7cce3163..d2681287fe70 100644
--- a/irc/weechat-devel/Makefile
+++ b/irc/weechat-devel/Makefile
@@ -6,19 +6,23 @@
#
PORTNAME= weechat
-PORTVERSION= 20110714
+PORTVERSION= 20110817
CATEGORIES= irc
MASTER_SITES= http://perturb.me.uk/distfiles/
PKGNAMESUFFIX= -devel
-DISTNAME= weechat-devel-35a3df0a7a09f00863be917f8181d5363c0a8302
+DISTNAME= weechat-devel-885e0d93742e647ae58964a1d2cebcaaaaccd609
MAINTAINER= freebsd@beardz.net
COMMENT= A lightweight and user friendly ncurse based IRC client
+LICENSE= GPLv3
+
CONFLICTS= weechat-0.3*
USE_ICONV= yes
USE_LDCONFIG= yes
+USE_NCURSES= yes
+WITH_NCURSES_BASE= yes
USE_CMAKE= yes
CMAKE_USE_PTHREAD= yes
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
@@ -30,14 +34,14 @@ OPTIONS= RUBY "Ruby scripting support." Off \
TCL "TCL scripting support." Off \
LUA "Lua scripting support." Off \
CHARSET "Charset support." On \
- BACKTRACE "Backtraces." Off \
+ BACKTRACE "Backtraces." On \
DEBUG "Debugging." On \
ASPELL "Spell checking." Off \
GNUTLS "GNU TLS." Off \
NLS "NLS support." On \
DOCUMENTATION "Build documentation." Off
-WRKSRC= ${WRKDIR}/${PORTNAME}-35a3df0
+WRKSRC= ${WRKDIR}/${PORTNAME}-885e0d9
.include <bsd.port.options.mk>
diff --git a/irc/weechat-devel/distinfo b/irc/weechat-devel/distinfo
index ebef366636d8..b4f06c243b84 100644
--- a/irc/weechat-devel/distinfo
+++ b/irc/weechat-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (weechat-devel-35a3df0a7a09f00863be917f8181d5363c0a8302.tar.gz) = ca52872388cfffac7426ea2bba177a5051719e9209e4f4300318a91bbeeb6229
-SIZE (weechat-devel-35a3df0a7a09f00863be917f8181d5363c0a8302.tar.gz) = 1839915
+SHA256 (weechat-devel-885e0d93742e647ae58964a1d2cebcaaaaccd609.tar.gz) = d17085673b32504322634f0fa5f227c68667cea4c399d7ce6f77c3d30f8f4325
+SIZE (weechat-devel-885e0d93742e647ae58964a1d2cebcaaaaccd609.tar.gz) = 1912719
diff --git a/irc/weechat-devel/files/patch-src-gui-curses-CMakeLists_txt b/irc/weechat-devel/files/patch-src-gui-curses-CMakeLists_txt
new file mode 100644
index 000000000000..0ba9c2e07910
--- /dev/null
+++ b/irc/weechat-devel/files/patch-src-gui-curses-CMakeLists_txt
@@ -0,0 +1,11 @@
+--- src/gui/curses/CMakeLists.txt.orig 2011-08-18 04:19:10.997333389 +0100
++++ src/gui/curses/CMakeLists.txt 2011-08-18 04:19:56.348074585 +0100
+@@ -38,7 +38,7 @@
+
+ FIND_PACKAGE(Ncurses)
+ IF(NCURSES_FOUND)
+- CHECK_INCLUDE_FILES(ncursesw/ncurses.h NCURSESW_HEADERS)
++ CHECK_INCLUDE_FILES(ncurses.h NCURSESW_HEADERS)
+ IF(NCURSESW_HEADERS)
+ ADD_DEFINITIONS(-DHAVE_NCURSESW_CURSES_H)
+ ELSE(NCURSESW_HEADERS)
diff --git a/irc/weechat-devel/files/patch-src-gui-curses-gui_curses_h b/irc/weechat-devel/files/patch-src-gui-curses-gui_curses_h
new file mode 100644
index 000000000000..c813607047fc
--- /dev/null
+++ b/irc/weechat-devel/files/patch-src-gui-curses-gui_curses_h
@@ -0,0 +1,12 @@
+--- src/gui/curses/gui-curses.h.orig 2011-08-17 14:08:18.000000000 +0100
++++ src/gui/curses/gui-curses.h 2011-08-18 05:02:47.647960373 +0100
+@@ -23,7 +23,8 @@
+ #include <time.h>
+
+ #ifdef HAVE_NCURSESW_CURSES_H
+-#include <ncursesw/ncurses.h>
++#define _XOPEN_SOURCE_EXTENDED 1
++#include <ncurses.h>
+ #elif HAVE_NCURSES_H
+ #include <ncurses.h>
+ #else
diff --git a/irc/weechat-devel/files/patch-src-gui-curses-gui_curses_term_c b/irc/weechat-devel/files/patch-src-gui-curses-gui_curses_term_c
new file mode 100644
index 000000000000..1d07c9c78616
--- /dev/null
+++ b/irc/weechat-devel/files/patch-src-gui-curses-gui_curses_term_c
@@ -0,0 +1,11 @@
+--- src/gui/curses/gui-curses-term.c.orig 2011-08-18 04:25:40.510233646 +0100
++++ src/gui/curses/gui-curses-term.c 2011-08-18 04:25:55.436405801 +0100
+@@ -26,7 +26,7 @@
+ #endif
+
+ #ifdef HAVE_NCURSESW_CURSES_H
+-#include <ncursesw/term.h>
++#include <term.h>
+ #else
+ #include <term.h>
+ #endif