aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-19 01:26:15 +0800
committerpgj <pgj@FreeBSD.org>2012-02-19 01:26:15 +0800
commitcc1b29f12dc3a562724778973ca4a32ef9f327a8 (patch)
tree12d461b3ed8cd1761d6044219cf20715684dca50
parent0caa5b6603048afa3631f12652adcd5fc941a83e (diff)
downloadfreebsd-ports-gnome-cc1b29f12dc3a562724778973ca4a32ef9f327a8.tar.gz
freebsd-ports-gnome-cc1b29f12dc3a562724778973ca4a32ef9f327a8.tar.zst
freebsd-ports-gnome-cc1b29f12dc3a562724778973ca4a32ef9f327a8.zip
This library provides just the general interface and helper functions.
You must use a specific backend in order to make this useful. WWW: http://www.yesodweb.com/book/persistent Obtained from: FreeBSD Haskell
-rw-r--r--databases/Makefile1
-rw-r--r--databases/hs-persistent-template/Makefile21
-rw-r--r--databases/hs-persistent-template/distinfo2
-rw-r--r--databases/hs-persistent-template/pkg-descr4
-rw-r--r--lang/ghc/bsd.hackage.mk1
5 files changed, 29 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 1deaabdf94fd..c187ffd62dea 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -105,6 +105,7 @@
SUBDIR += hk_classes
SUBDIR += hs-mysql
SUBDIR += hs-persistent
+ SUBDIR += hs-persistent-template
SUBDIR += hsqldb
SUBDIR += hypertable
SUBDIR += innobackup
diff --git a/databases/hs-persistent-template/Makefile b/databases/hs-persistent-template/Makefile
new file mode 100644
index 000000000000..9c4c2a22ef2d
--- /dev/null
+++ b/databases/hs-persistent-template/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hs-persistent-template
+# Date created: December 26, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= persistent-template
+PORTVERSION= 0.6.3.1
+CATEGORIES= databases haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Type-safe, non-relational, multi-backend persistence
+
+LICENSE= BSD
+
+USE_CABAL= monad-control>=0.2 persistent>=0.6.2 text>=0.5 \
+ transformers>=0.2
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/databases/hs-persistent-template/distinfo b/databases/hs-persistent-template/distinfo
new file mode 100644
index 000000000000..a2145278a98f
--- /dev/null
+++ b/databases/hs-persistent-template/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/persistent-template-0.6.3.1.tar.gz) = 2f4325ce9d98d9517c1bc7a711bee125cdd4d0111181bad3ef761d0c50ebf742
+SIZE (cabal/persistent-template-0.6.3.1.tar.gz) = 6543
diff --git a/databases/hs-persistent-template/pkg-descr b/databases/hs-persistent-template/pkg-descr
new file mode 100644
index 000000000000..fe71a91f78e6
--- /dev/null
+++ b/databases/hs-persistent-template/pkg-descr
@@ -0,0 +1,4 @@
+This library provides just the general interface and helper functions.
+You must use a specific backend in order to make this useful.
+
+WWW: http://www.yesodweb.com/book/persistent
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index dc7f3675c8b4..019ee0b82245 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -192,6 +192,7 @@ path-pieces_port= www/hs-path-pieces
pcap_port= net/hs-pcap
pcre-light_port= devel/hs-pcre-light # lib_depends
persistent_port= databases/hs-persistent
+persistent-template_port= databases/hs-persistent-template
polyparse_port= textproc/hs-polyparse
pointed_port= math/hs-pointed
pool_port= devel/hs-pool