aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgreen <green@FreeBSD.org>2004-03-24 01:23:50 +0800
committergreen <green@FreeBSD.org>2004-03-24 01:23:50 +0800
commitcc1fcf82965de0525060e8a255d55f21c3c94596 (patch)
tree39d48e05c49cf79186af9dffd92e418a2b82f268
parentada670d6cf077fe29f220b16e2a48f87e4913fbb (diff)
downloadfreebsd-ports-gnome-cc1fcf82965de0525060e8a255d55f21c3c94596.tar.gz
freebsd-ports-gnome-cc1fcf82965de0525060e8a255d55f21c3c94596.tar.zst
freebsd-ports-gnome-cc1fcf82965de0525060e8a255d55f21c3c94596.zip
Add the ability to install the XMMS plugin (WITH_XMMS option).
-rw-r--r--audio/normalize/Makefile15
-rw-r--r--audio/normalize/pkg-plist1
2 files changed, 14 insertions, 2 deletions
diff --git a/audio/normalize/Makefile b/audio/normalize/Makefile
index e99e1d34506e..d57cacde03be 100644
--- a/audio/normalize/Makefile
+++ b/audio/normalize/Makefile
@@ -7,7 +7,7 @@
PORTNAME= normalize
PORTVERSION= 0.7.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://www1.cs.columbia.edu/~cvaill/normalize/
@@ -16,17 +16,28 @@ COMMENT= A tool for adjusting the volume of wave/MP3 files to a standard level
LIB_DEPENDS= mad.2:${PORTSDIR}/audio/mad
+OPTIONS= XMMS "Build XMMS plugin" off
+.include <bsd.port.pre.mk>
+.if defined(WITH_XMMS)
+LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+.endif
+
USE_BZIP2= yes
USE_GETOPT_LONG= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.if defined(WITH_XMMS)
+PLIST_SUB+= XMMS=""
+.else
CONFIGURE_ARGS= --disable-xmms
+PLIST_SUB+= XMMS="@comment "
+.endif
MAN1= normalize.1 normalize-mp3.1
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/normalize/pkg-plist b/audio/normalize/pkg-plist
index 56c71fd7ec6c..75ac7d7929d3 100644
--- a/audio/normalize/pkg-plist
+++ b/audio/normalize/pkg-plist
@@ -1,5 +1,6 @@
bin/normalize
bin/normalize-mp3
bin/normalize-ogg
+%%XMMS%%lib/xmms/Effect/librva.so
share/locale/en_GB/LC_MESSAGES/normalize.mo
share/locale/fr/LC_MESSAGES/normalize.mo