aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2017-01-22 17:50:45 +0800
committerbapt <bapt@FreeBSD.org>2017-01-22 17:50:45 +0800
commitccb942ea26d144b0b2d8bd59d4d2e56213e1a404 (patch)
treec7f2270a1a1fac2afca2eb5cb693c25892db04ca
parentbac7c93c26fede553d3f61403b4480ba129b655f (diff)
downloadfreebsd-ports-gnome-ccb942ea26d144b0b2d8bd59d4d2e56213e1a404.tar.gz
freebsd-ports-gnome-ccb942ea26d144b0b2d8bd59d4d2e56213e1a404.tar.zst
freebsd-ports-gnome-ccb942ea26d144b0b2d8bd59d4d2e56213e1a404.zip
Fix regression introduced in pkg 1.2.0
pkgconf --variable=pc_path pkg-config was not reporting any thing Reported by: antoine
-rw-r--r--devel/pkgconf/Makefile1
-rw-r--r--devel/pkgconf/files/patch-libpkgconf_pkg.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/devel/pkgconf/Makefile b/devel/pkgconf/Makefile
index f8dd1f3c9d1a..51368adf3dff 100644
--- a/devel/pkgconf/Makefile
+++ b/devel/pkgconf/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pkgconf
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://distfiles.dereferenced.org/pkgconf/ \
http://files.etoilebsd.net/pkgconf/
diff --git a/devel/pkgconf/files/patch-libpkgconf_pkg.c b/devel/pkgconf/files/patch-libpkgconf_pkg.c
new file mode 100644
index 000000000000..eb2f31099057
--- /dev/null
+++ b/devel/pkgconf/files/patch-libpkgconf_pkg.c
@@ -0,0 +1,11 @@
+--- libpkgconf/pkg.c.orig 2017-01-20 02:01:30 UTC
++++ libpkgconf/pkg.c
+@@ -1341,7 +1341,7 @@ pkgconf_pkg_traverse(pkgconf_client_t *c
+ if (maxdepth == 0)
+ return eflags;
+
+- if ((root->flags & PKGCONF_PKG_PROPF_VIRTUAL) != PKGCONF_PKG_PROPF_VIRTUAL || (client->flags & PKGCONF_PKG_PKGF_SKIP_ROOT_VIRTUAL) != PKGCONF_PKG_PKGF_SKIP_ROOT_VIRTUAL)
++ if ((root->flags & PKGCONF_PKG_PROPF_VIRTUAL) != PKGCONF_PKG_PROPF_VIRTUAL || (client->flags & ~PKGCONF_PKG_PKGF_SKIP_ROOT_VIRTUAL) != PKGCONF_PKG_PKGF_SKIP_ROOT_VIRTUAL)
+ {
+ if (func != NULL)
+ func(client, root, data);