aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2018-06-23 06:08:33 +0800
committerrene <rene@FreeBSD.org>2018-06-23 06:08:33 +0800
commitcd5df12866a262d43c4514660243a1123a12a669 (patch)
treeef3149b9509c3530c204a97b06b1d92639b00cc8
parentf752500a7daef850e5959b045c2e54f9dc90e518 (diff)
downloadfreebsd-ports-gnome-cd5df12866a262d43c4514660243a1123a12a669.tar.gz
freebsd-ports-gnome-cd5df12866a262d43c4514660243a1123a12a669.tar.zst
freebsd-ports-gnome-cd5df12866a262d43c4514660243a1123a12a669.zip
Remove www/npapi-vlc, it depends on expired www/libxul.
-rw-r--r--MOVED1
-rw-r--r--www/Makefile1
-rw-r--r--www/npapi-vlc/Makefile29
-rw-r--r--www/npapi-vlc/distinfo2
-rw-r--r--www/npapi-vlc/files/patch-be7ae9d9f73b45decd63c8e90d992800b5a882f892
-rw-r--r--www/npapi-vlc/files/patch-f4a86b5994a797a36d94bb4cc8033efad3e7632b29
-rw-r--r--www/npapi-vlc/pkg-descr2
7 files changed, 1 insertions, 155 deletions
diff --git a/MOVED b/MOVED
index d5ffb5f50416..5a0abc058072 100644
--- a/MOVED
+++ b/MOVED
@@ -10289,3 +10289,4 @@ multimedia/qt5-phonon4-designerplugin|multimedia/phonon-designerplugin@qt5|2018-
multimedia/qt5-phonon4-gstreamer|multimedia/phonon-gstreamer@qt5|2018-06-21|Moved to a flavored version
multimedia/qt5-phonon4-vlc|multimedia/phonon-vlc@qt5|2018-06-21|Moved to a flavored version
net/libproxy-gnome|net/libproxy-gnome2|2018-07-22|Renamed to make slave names consistent
+www/npapi-vlc||2018-06-22|Removed, depends on expired www/libxul
diff --git a/www/Makefile b/www/Makefile
index fa502a4512e2..e8042b070f80 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -530,7 +530,6 @@
SUBDIR += nostromo
SUBDIR += novnc
SUBDIR += novnc-websockify
- SUBDIR += npapi-vlc
SUBDIR += npapi-xine
SUBDIR += npc
SUBDIR += npm
diff --git a/www/npapi-vlc/Makefile b/www/npapi-vlc/Makefile
deleted file mode 100644
index 124cebf0ea29..000000000000
--- a/www/npapi-vlc/Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
-# Created by: Mikhail Teterin <mi@aldan.algebra.com>
-# $FreeBSD$
-
-PORTNAME= npapi-vlc
-PORTVERSION= 2.0.6
-PORTREVISION= 5
-CATEGORIES= www multimedia
-MASTER_SITES= http://download.videolan.org/pub/videolan/vlc-webplugins/${PORTVERSION}/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Embeds vlc-player in web-browsers
-
-LIB_DEPENDS= libvlc.so:multimedia/vlc \
- libxul.so:www/libxul
-
-USES= libtool pkgconfig tar:xz webplugin:native
-USE_GNOME= gtk20
-WEBPLUGIN_NAME= #
-WEBPLUGIN_FILES=libvlcplugin.so
-GNU_CONFIGURE= yes
-PLIST_FILES= ${WEBPLUGIN_DIR:S,^${PREFIX}/,,}${WEBPLUGIN_FILES}
-PATCH_STRIP= -p1
-
-do-install:
- ${MKDIR} ${STAGEDIR}${WEBPLUGIN_DIR}
- ${INSTALL_LIB} ${WRKSRC}/npapi/.libs/libvlcplugin.so \
- ${STAGEDIR}/${WEBPLUGIN_DIR}
-
-.include <bsd.port.mk>
diff --git a/www/npapi-vlc/distinfo b/www/npapi-vlc/distinfo
deleted file mode 100644
index b5ab4527ae2c..000000000000
--- a/www/npapi-vlc/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (npapi-vlc-2.0.6.tar.xz) = 4f03376040491bf5e86af8f7eaf2571b68a8450c51774acb55582e20b2205ae8
-SIZE (npapi-vlc-2.0.6.tar.xz) = 442280
diff --git a/www/npapi-vlc/files/patch-be7ae9d9f73b45decd63c8e90d992800b5a882f8 b/www/npapi-vlc/files/patch-be7ae9d9f73b45decd63c8e90d992800b5a882f8
deleted file mode 100644
index 081d993ba656..000000000000
--- a/www/npapi-vlc/files/patch-be7ae9d9f73b45decd63c8e90d992800b5a882f8
+++ /dev/null
@@ -1,92 +0,0 @@
-From: Felix Paul Kuehne <fkuehne@videolan.org>
-Date: Wed, 12 Feb 2014 12:15:21 +0000 (+0100)
-Subject: nporuntime: move protected definitions to public as they are accessed by out of class...
-X-Git-Url: http://git.videolan.org/?p=npapi-vlc.git;a=commitdiff_plain;h=be7ae9d9f73b45decd63c8e90d992800b5a882f8
-
-nporuntime: move protected definitions to public as they are accessed by out of class selectors
-
-Fix compilation with clang++, part 2
----
-
-diff --git a/npapi/control/nporuntime.h b/npapi/control/nporuntime.h
-index b279ade..6bb89ca 100644
---- a/npapi/control/nporuntime.h
-+++ b/npapi/control/nporuntime.h
-@@ -74,6 +74,31 @@ public:
- static char* stringValue(const NPString &v);
- static char* stringValue(const NPVariant &v);
-
-+ bool isValid()
-+ {
-+ return _instance != NULL;
-+ };
-+
-+ enum InvokeResult
-+ {
-+ INVOKERESULT_NO_ERROR = 0, /* returns no error */
-+ INVOKERESULT_GENERIC_ERROR = 1, /* returns error */
-+ INVOKERESULT_NO_SUCH_METHOD = 2, /* throws method does not exist */
-+ INVOKERESULT_INVALID_ARGS = 3, /* throws invalid arguments */
-+ INVOKERESULT_INVALID_VALUE = 4, /* throws invalid value in assignment */
-+ INVOKERESULT_OUT_OF_MEMORY = 5, /* throws out of memory */
-+ };
-+
-+ virtual InvokeResult getProperty(int index, NPVariant &result);
-+ virtual InvokeResult setProperty(int index, const NPVariant &value);
-+ virtual InvokeResult removeProperty(int index);
-+ virtual InvokeResult invoke(int index, const NPVariant *args, uint32_t argCount, NPVariant &result);
-+ virtual InvokeResult invokeDefault(const NPVariant *args, uint32_t argCount, NPVariant &result);
-+
-+ bool returnInvokeResult(InvokeResult result);
-+
-+ static InvokeResult invokeResultString(const char *,NPVariant &);
-+
- protected:
- void *operator new(size_t n)
- {
-@@ -89,11 +114,6 @@ protected:
- NPN_MemFree(p);
- };
-
-- bool isValid()
-- {
-- return _instance != NULL;
-- };
--
- RuntimeNPObject(NPP instance, const NPClass *aClass) :
- _instance(instance)
- {
-@@ -102,16 +122,6 @@ protected:
- };
- virtual ~RuntimeNPObject() {};
-
-- enum InvokeResult
-- {
-- INVOKERESULT_NO_ERROR = 0, /* returns no error */
-- INVOKERESULT_GENERIC_ERROR = 1, /* returns error */
-- INVOKERESULT_NO_SUCH_METHOD = 2, /* throws method does not exist */
-- INVOKERESULT_INVALID_ARGS = 3, /* throws invalid arguments */
-- INVOKERESULT_INVALID_VALUE = 4, /* throws invalid value in assignment */
-- INVOKERESULT_OUT_OF_MEMORY = 5, /* throws out of memory */
-- };
--
- friend void RuntimeNPClassDeallocate(NPObject *npobj);
- friend void RuntimeNPClassInvalidate(NPObject *npobj);
- template <class RuntimeNPObject> static bool RuntimeNPClassGetProperty(NPObject *npobj, NPIdentifier name, NPVariant *result);
-@@ -125,16 +135,6 @@ protected:
- uint32_t argCount,
- NPVariant *result);
-
-- virtual InvokeResult getProperty(int index, NPVariant &result);
-- virtual InvokeResult setProperty(int index, const NPVariant &value);
-- virtual InvokeResult removeProperty(int index);
-- virtual InvokeResult invoke(int index, const NPVariant *args, uint32_t argCount, NPVariant &result);
-- virtual InvokeResult invokeDefault(const NPVariant *args, uint32_t argCount, NPVariant &result);
--
-- bool returnInvokeResult(InvokeResult result);
--
-- static InvokeResult invokeResultString(const char *,NPVariant &);
--
- bool isPluginRunning()
- {
- return (_instance->pdata != NULL);
diff --git a/www/npapi-vlc/files/patch-f4a86b5994a797a36d94bb4cc8033efad3e7632b b/www/npapi-vlc/files/patch-f4a86b5994a797a36d94bb4cc8033efad3e7632b
deleted file mode 100644
index 7f7b37ae0295..000000000000
--- a/www/npapi-vlc/files/patch-f4a86b5994a797a36d94bb4cc8033efad3e7632b
+++ /dev/null
@@ -1,29 +0,0 @@
-From: Felix Paul Kuehne <fkuehne@videolan.org>
-Date: Wed, 12 Feb 2014 12:12:07 +0000 (+0100)
-Subject: nporuntime: do not mix friend declarations with static implementations
-X-Git-Url: http://git.videolan.org/?p=npapi-vlc.git;a=commitdiff_plain;h=f4a86b5994a797a36d94bb4cc8033efad3e7632b
-
-nporuntime: do not mix friend declarations with static implementations
-
-Fix compilation with clang++, part one
----
-
-diff --git a/npapi/control/nporuntime.h b/npapi/control/nporuntime.h
-index d67ec8c..b279ade 100644
---- a/npapi/control/nporuntime.h
-+++ b/npapi/control/nporuntime.h
-@@ -114,10 +114,10 @@ protected:
-
- friend void RuntimeNPClassDeallocate(NPObject *npobj);
- friend void RuntimeNPClassInvalidate(NPObject *npobj);
-- template <class RuntimeNPObject> friend bool RuntimeNPClassGetProperty(NPObject *npobj, NPIdentifier name, NPVariant *result);
-- template <class RuntimeNPObject> friend bool RuntimeNPClassSetProperty(NPObject *npobj, NPIdentifier name, const NPVariant *value);
-- template <class RuntimeNPObject> friend bool RuntimeNPClassRemoveProperty(NPObject *npobj, NPIdentifier name);
-- template <class RuntimeNPObject> friend bool RuntimeNPClassInvoke(NPObject *npobj, NPIdentifier name,
-+ template <class RuntimeNPObject> static bool RuntimeNPClassGetProperty(NPObject *npobj, NPIdentifier name, NPVariant *result);
-+ template <class RuntimeNPObject> static bool RuntimeNPClassSetProperty(NPObject *npobj, NPIdentifier name, const NPVariant *value);
-+ template <class RuntimeNPObject> static bool RuntimeNPClassRemoveProperty(NPObject *npobj, NPIdentifier name);
-+ template <class RuntimeNPObject> static bool RuntimeNPClassInvoke(NPObject *npobj, NPIdentifier name,
- const NPVariant *args, uint32_t argCount,
- NPVariant *result);
- friend bool RuntimeNPClassInvokeDefault(NPObject *npobj,
diff --git a/www/npapi-vlc/pkg-descr b/www/npapi-vlc/pkg-descr
deleted file mode 100644
index 653044f4b0b3..000000000000
--- a/www/npapi-vlc/pkg-descr
+++ /dev/null
@@ -1,2 +0,0 @@
-Plugin from NPAPI-using browsers (such as Firefox) allowing embedding
-of VideoLAN (vlc) to play back various multimedia sources.