aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2008-01-07 09:31:53 +0800
committermaho <maho@FreeBSD.org>2008-01-07 09:31:53 +0800
commitd3918484002570add6bde1eeae3564caa8930120 (patch)
tree1193e07561ccbaf950806c90dbb4074f0789c021
parentefe80c593d048097f8d28ac2899d3439d1e13a4c (diff)
downloadfreebsd-ports-gnome-d3918484002570add6bde1eeae3564caa8930120.tar.gz
freebsd-ports-gnome-d3918484002570add6bde1eeae3564caa8930120.tar.zst
freebsd-ports-gnome-d3918484002570add6bde1eeae3564caa8930120.zip
Use termios terminal interface, so that COMPAT_43TTY kernel
option can be removed without strange side-effects. Submitted by: Ed Schouten <ed@fxq.nl>
-rw-r--r--math/octave/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 0e5da99b58b2..33a2fe5a0ae9 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -79,7 +79,8 @@ CONFIGURE_ENV+= GPERF="${LOCALBASE}/bin/gperf" \
F77="${FC}" \
FFLAGS="${FFLAGS}" \
CC="${CC}" \
- CXX="${CXX}"
+ CXX="${CXX}" \
+ TERMIOS_H="termios.h"
CONFIGURE_ARGS= --host=${GNU_HOST} \
--with-blas="-L${LOCALBASE}/lib ${BLAS}" \
--with-lapack="${LAPACK}" \