aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2015-04-18 20:58:34 +0800
committertijl <tijl@FreeBSD.org>2015-04-18 20:58:34 +0800
commitd40453cba9bc86d2a6367cebe6d1f030b4b29537 (patch)
tree129f59c831442347e16677b0930fa5747c496c23
parentd59db5f0fd2d82d0819dffb4761dd8252c9fed64 (diff)
downloadfreebsd-ports-gnome-d40453cba9bc86d2a6367cebe6d1f030b4b29537.tar.gz
freebsd-ports-gnome-d40453cba9bc86d2a6367cebe6d1f030b4b29537.tar.zst
freebsd-ports-gnome-d40453cba9bc86d2a6367cebe6d1f030b4b29537.zip
Convert to USES=autoreconf
-rw-r--r--science/minc2/Makefile6
-rw-r--r--science/sigrok-firmware/Makefile6
-rw-r--r--security/barnyard2/Makefile5
-rw-r--r--security/d0_blind_id/Makefile6
-rw-r--r--security/fwbuilder/Makefile4
-rw-r--r--security/libbeid/Makefile6
-rw-r--r--security/opencryptoki/Makefile5
-rw-r--r--security/trousers/Makefile4
-rw-r--r--sysutils/cfengine36/Makefile6
-rw-r--r--textproc/augeas/Makefile6
-rw-r--r--textproc/exmpp/Makefile8
-rw-r--r--textproc/irstlm/Makefile6
-rw-r--r--textproc/liblrdf/Makefile4
-rw-r--r--textproc/libsass/Makefile7
-rw-r--r--textproc/ots/Makefile4
-rw-r--r--textproc/sassc/Makefile11
-rw-r--r--textproc/sdcv/Makefile6
-rw-r--r--www/cherokee/Makefile7
-rw-r--r--www/e2guardian/Makefile7
-rw-r--r--www/mod_auth_openid/Makefile4
-rw-r--r--www/sams2/Makefile8
-rw-r--r--x11/guake/Makefile4
22 files changed, 39 insertions, 91 deletions
diff --git a/science/minc2/Makefile b/science/minc2/Makefile
index 77371f5bd41c..24ec9a4c2c95 100644
--- a/science/minc2/Makefile
+++ b/science/minc2/Makefile
@@ -23,11 +23,9 @@ GH_ACCOUNT= BIC-MNI
GH_TAGNAME= release-${PORTVERSION}
GH_COMMIT= 6f2f5b9
-USES= bison gmake libtool perl5 shebangfix
+USES= autoreconf bison gmake libtool perl5 shebangfix
SHEBANG_FILES= progs/mincview/mincview
-USE_AUTOTOOLS= libtoolize aclocal autoheader automake autoconf
-ACLOCAL_ARGS= -I m4 --automake-acdir=${ACLOCAL_DIR}
-AUTOMAKE_ARGS= --add-missing --copy --force-missing
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared=yes --enable-static=yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
diff --git a/science/sigrok-firmware/Makefile b/science/sigrok-firmware/Makefile
index 416b51e50aba..7db9be83f451 100644
--- a/science/sigrok-firmware/Makefile
+++ b/science/sigrok-firmware/Makefile
@@ -20,11 +20,7 @@ GH_COMMIT= 2632d74
GNU_CONFIGURE=yes
-USE_AUTOTOOLS= libtoolize autoconf autoheader automake aclocal
-
-AUTOMAKE_ARGS= --add-missing
-
-USES= gmake
+USES= autoreconf gmake
FW_FILES= \
LICENSE.Sigma asix-sigma-100.fw asix-sigma-200.fw asix-sigma-50.fw asix-sigma-50sync.fw \
diff --git a/security/barnyard2/Makefile b/security/barnyard2/Makefile
index 8da8dc229ce2..d44bc78f360e 100644
--- a/security/barnyard2/Makefile
+++ b/security/barnyard2/Makefile
@@ -32,10 +32,7 @@ OPTIONS_DESC= Enable tcl support for sguil
OPTIONS_DEFAULT+= TCL
.endif
-USE_AUTOTOOLS= libtoolize aclocal autoheader automake autoconf
-AUTOMAKE_ARGS= --add-missing --copy
-ACLOCAL_ARGS= -I m4 -I ${LOCALBASE}/share/aclocal
-
+USES= autoreconf libtool
USE_RC_SUBR= barnyard2
GNU_CONFIGURE= yes
diff --git a/security/d0_blind_id/Makefile b/security/d0_blind_id/Makefile
index 2029ba291df9..aee7f51a4445 100644
--- a/security/d0_blind_id/Makefile
+++ b/security/d0_blind_id/Makefile
@@ -16,14 +16,12 @@ GH_ACCOUNT= divVerent
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= ff1ce7e
-USES= libtool
+USES= autoreconf libtool
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openssl
USE_LDCONFIG= yes
USE_OPENSSL= yes
-USE_AUTOTOOLS= libtoolize aclocal autoconf automake
-AUTOMAKE_ARGS= --add-missing
-
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lib${PORTNAME}.so.0
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libd0_rijndael.so.0
diff --git a/security/fwbuilder/Makefile b/security/fwbuilder/Makefile
index 13279a16f058..050a6fc68aea 100644
--- a/security/fwbuilder/Makefile
+++ b/security/fwbuilder/Makefile
@@ -48,8 +48,8 @@ USE_QT4= corelib \
QTDIR?= ${QT_PREFIX}
USE_OPENSSL= yes
-USES= gmake libtool
-USE_AUTOTOOLS= libtoolize aclocal autoconf
+USES= autoreconf gmake libtool
+GNU_CONFIGURE= yes
CONFIGURE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
INSTALL_ROOT=${STAGEDIR}
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/security/libbeid/Makefile b/security/libbeid/Makefile
index 85e746b318a4..86c6c3377132 100644
--- a/security/libbeid/Makefile
+++ b/security/libbeid/Makefile
@@ -12,8 +12,7 @@ LICENSE= LGPL3
LIB_DEPENDS= libpcsclite.so:${PORTSDIR}/devel/pcsc-lite
-USES= dos2unix libtool pkgconfig tar:xz
-USE_AUTOTOOLS= autoconf:env automake:env libtoolize:env
+USES= autoreconf dos2unix libtool pkgconfig tar:xz
USE_GNOME= gtk20
DOS2UNIX_FILES= common/src/datafile.cpp common/src/logbase.cpp \
@@ -28,7 +27,4 @@ post-patch:
@${REINPLACE_CMD} -e '/svn_revision/d' -e '/SUBDIRS/s/xpi//' \
${WRKSRC}/Makefile.am ${WRKSRC}/configure.ac
-pre-configure:
- @(cd ${WRKSRC} && ${AUTORECONF} -i -f)
-
.include <bsd.port.mk>
diff --git a/security/opencryptoki/Makefile b/security/opencryptoki/Makefile
index fb98611cbaf0..3fe976e9608a 100644
--- a/security/opencryptoki/Makefile
+++ b/security/opencryptoki/Makefile
@@ -17,11 +17,10 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libtspi.so:${PORTSDIR}/security/trousers
-USES= alias gmake libtool tar:bzip2
+USES= alias autoreconf gmake libtool tar:bzip2
USE_LDCONFIG= ${PREFIX}/lib/opencryptoki
-USE_AUTOTOOLS= libtoolize aclocal autoconf automake
-AUTOMAKE_ARGS= -a -c -f
INSTALL_TARGET= install-strip
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-swtok --enable-tpmtok \
--disable-crtok --disable-aeptok \
--disable-ccatok --disable-bcomtok \
diff --git a/security/trousers/Makefile b/security/trousers/Makefile
index 5a0f54285130..d14826c6adba 100644
--- a/security/trousers/Makefile
+++ b/security/trousers/Makefile
@@ -15,11 +15,9 @@ LICENSE_NAME= Common Public License
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USES= alias gmake iconv libtool pkgconfig
+USES= alias autoreconf gmake iconv libtool pkgconfig
USE_OPENSSL= YES
USE_LDCONFIG= YES
-USE_AUTOTOOLS= libtoolize aclocal autoconf automake
-AUTOMAKE_ARGS= -a -c -f
USE_RC_SUBR= tcsd
INSTALL_TARGET= install-strip
GNU_CONFIGURE= YES
diff --git a/sysutils/cfengine36/Makefile b/sysutils/cfengine36/Makefile
index a780ef732b7e..f9981e862dcb 100644
--- a/sysutils/cfengine36/Makefile
+++ b/sysutils/cfengine36/Makefile
@@ -30,8 +30,7 @@ MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USES= cpe gmake libtool
-USE_AUTOTOOLS= autoconf:env automake:env libtoolize:env
+USES= autoreconf cpe gmake libtool
CFLAGS+= -Wno-return-type
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -64,7 +63,4 @@ MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
LIBVIRT_CONFIGURE_ON= --with-libvirt=${LOCALBASE}
LIBVIRT_LIB_DEPENDS+= libvirt.so:${PORTSDIR}/devel/libvirt
-pre-configure:
- @cd ${WRKSRC}; autoreconf -Wno-portability --force --install -I m4
-
.include <bsd.port.mk>
diff --git a/textproc/augeas/Makefile b/textproc/augeas/Makefile
index 8f8304edad3f..134d2206e05e 100644
--- a/textproc/augeas/Makefile
+++ b/textproc/augeas/Makefile
@@ -15,11 +15,9 @@ LICENSE= LGPL21
TEST_DEPENDS= bash:${PORTSDIR}/shells/bash \
gsed:${PORTSDIR}/textproc/gsed
+GNU_CONFIGURE= yes
+USES= autoreconf gmake libtool pkgconfig readline
USE_GNOME= libxml2
-USES= gmake libtool pkgconfig readline
-USE_AUTOTOOLS= autoconf aclocal autoheader automake libtoolize:env
-ACLOCAL_ARGS= -I . -I gnulib/m4 -I ${LOCALBASE}/share/aclocal
-AUTOMAKE_ARGS= --add-missing
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/textproc/exmpp/Makefile b/textproc/exmpp/Makefile
index 45c47cdc0128..034eeadd6b66 100644
--- a/textproc/exmpp/Makefile
+++ b/textproc/exmpp/Makefile
@@ -34,8 +34,7 @@ CONFIGURE_ARGS+=--enable-static=yes \
--enable-escaping-using-cdata
GNU_CONFIGURE_PREFIX= "${PREFIX}/lib/erlang/lib"
PLIST_SUB= VERSION=${PORTVERSION}
-USE_AUTOTOOLS= autoconf:env automake:env libtoolize:env
-USES= libtool pkgconfig
+USES= autoreconf libtool pkgconfig
USE_OPENSSL= yes
.include <bsd.port.options.mk>
@@ -48,11 +47,8 @@ CONFIGURE_ARGS+= --disable-documentation
MAKE_JOBS_UNSAFE= yes
-pre-configure:
- @cd ${WRKSRC} && ${AUTORECONF} -ivf
-
post-configure:
- ${MAKE} clean -C ${WRKSRC}
+ ${MAKE_CMD} clean -C ${WRKSRC}
post-install:
.for _file in exmpp_xml_expat_legacy.so exmpp_compress_zlib.so \
diff --git a/textproc/irstlm/Makefile b/textproc/irstlm/Makefile
index 53496c06b6f9..5c996b24c9b6 100644
--- a/textproc/irstlm/Makefile
+++ b/textproc/irstlm/Makefile
@@ -3,7 +3,7 @@
PORTNAME= irstlm
PORTVERSION= 5.80.03
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=${PORTNAME}/${PORTNAME}/${PORTNAME}-5.80
@@ -16,9 +16,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
USE_PERL5= run
-USE_AUTOTOOLS= libtoolize aclocal autoconf automake
-AUTOMAKE_ARGS= --add-missing
-USES= shebangfix libtool tar:tgz
+USES= autoreconf libtool perl5 shebangfix tar:tgz
USE_LDCONFIG= yes
SHEBANG_FILES= scripts/add-start-end.sh scripts/lm-stat.pl scripts/sort-lm.pl scripts/build-lm-qsub.sh scripts/mdtsel.sh scripts/split-dict.pl scripts/build-lm.sh scripts/merge-sublm.pl scripts/split-ngt.sh scripts/build-sublm.pl scripts/ngram-split.pl scripts/goograms2ngrams.pl scripts/rm-start-end.sh
diff --git a/textproc/liblrdf/Makefile b/textproc/liblrdf/Makefile
index 7b89f1ae87fa..2c5d154875eb 100644
--- a/textproc/liblrdf/Makefile
+++ b/textproc/liblrdf/Makefile
@@ -16,10 +16,8 @@ LIB_DEPENDS= libicuuc.so:${PORTSDIR}/devel/icu \
libcurl.so:${PORTSDIR}/ftp/curl \
libraptor2.so:${PORTSDIR}/textproc/raptor2
-USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
-AUTOMAKE_ARGS= --add-missing --copy --force
GNU_CONFIGURE= yes
-USES= iconv libtool pathfix pkgconfig
+USES= autoreconf iconv libtool pathfix pkgconfig
USE_GNOME= libxml2 libxslt
USE_LDCONFIG= yes
USE_OPENSSL= yes
diff --git a/textproc/libsass/Makefile b/textproc/libsass/Makefile
index 1c80a236a32c..f5afb2abb0b3 100644
--- a/textproc/libsass/Makefile
+++ b/textproc/libsass/Makefile
@@ -11,18 +11,17 @@ COMMENT= C/C++ implementation of a Sass compiler
LICENSE= MIT
-AUTOMAKE_ARGS= --add-missing
-
GH_ACCOUNT= sass
GH_COMMIT= 0388a62
GH_TAGNAME= v${PORTVERSION}
+GNU_CONFIGURE= yes
+
INSTALL_TARGET= install-strip
PATHFIX_MAKEFILEIN= Makefile.am
-USES= libtool pathfix
-USE_AUTOTOOLS= aclocal autoconf autoheader automake libtoolize
+USES= autoreconf libtool pathfix
USE_GITHUB= yes
USE_LDCONFIG= yes
diff --git a/textproc/ots/Makefile b/textproc/ots/Makefile
index fc79f44a10d1..3c27440c9115 100644
--- a/textproc/ots/Makefile
+++ b/textproc/ots/Makefile
@@ -12,10 +12,8 @@ COMMENT= Open Text Summarizer
LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt
-USES= gettext libtool pathfix pkgconfig
+USES= autoreconf gettext libtool pathfix pkgconfig
PATHFIX_MAKEFILEIN= Makefile.am
-USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
-AUTOMAKE_ARGS= -a -c -f
USE_GNOME= glib20 libxml2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/textproc/sassc/Makefile b/textproc/sassc/Makefile
index 5c2158e2e8ad..767dbfa7d8c4 100644
--- a/textproc/sassc/Makefile
+++ b/textproc/sassc/Makefile
@@ -13,19 +13,16 @@ LICENSE= MIT
LIB_DEPENDS= libsass.so:${PORTSDIR}/textproc/libsass
-AUTOMAKE_ARGS= --add-missing
-
-CPPFLAGS+= -I${LOCALBASE}/include
-
+USE_GITHUB= yes
GH_ACCOUNT= sass
GH_COMMIT= 9451dd7
GH_TAGNAME= v${PORTVERSION}
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+USES= autoreconf libtool
PLIST_FILES= bin/sassc
-USE_AUTOTOOLS= aclocal autoconf autoheader automake libtoolize
-USE_GITHUB= yes
-
.include <bsd.port.mk>
diff --git a/textproc/sdcv/Makefile b/textproc/sdcv/Makefile
index 4bb8e6e81137..5345a2390c39 100644
--- a/textproc/sdcv/Makefile
+++ b/textproc/sdcv/Makefile
@@ -12,11 +12,9 @@ COMMENT= Text-based utility for work with dictionaries in StarDict's format
LICENSE= GPLv2 # (or later)
-USES= gettext pkgconfig readline tar:bzip2
+GNU_CONFIGURE= yes
+USES= autoreconf gettext pkgconfig readline tar:bzip2
USE_GNOME= glib20
-USE_AUTOTOOLS= libtoolize aclocal automake autoconf
-ACLOCAL_ARGS= --automake-acdir=${ACLOCAL_DIR} -I m4
-AUTOMAKE_ARGS= --add-missing --copy
SUB_FILES= pkg-message
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index 4c5d0a492930..6323bbd73b28 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -17,8 +17,8 @@ GH_PROJECT= webserver
GH_TAGNAME= ${PORTVERSION:S/^/v/}
GH_COMMIT= e5583c6
-USES= gettext gmake libtool pathfix pkgconfig python:2,build \
- shebangfix
+USES= autoreconf gettext gmake libtool pathfix pkgconfig \
+ python:2,build shebangfix
SHEBANG_FILES= admin/CTK/CTK-run.pre admin/server.py \
admin/upgrade_config.py cherokee/cherokee-admin-launcher \
cherokee/cherokee-tweak contrib/tracelor.py \
@@ -29,8 +29,7 @@ SHEBANG_FILES= admin/CTK/CTK-run.pre admin/server.py \
python_CMD= ${PYTHON_CMD}
USE_RC_SUBR= cherokee
USE_OPENSSL= yes
-USE_AUTOTOOLS= libtoolize aclocal automake autoheader autoconf
-AUTOMAKE_ARGS= --add-missing --copy --foreign
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-silent-rules \
--disable-static \
--localstatedir=${CHEROKEE_VARDIR} \
diff --git a/www/e2guardian/Makefile b/www/e2guardian/Makefile
index c34d125928d9..1e2c6b6480b9 100644
--- a/www/e2guardian/Makefile
+++ b/www/e2guardian/Makefile
@@ -16,11 +16,8 @@ LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
USE_GITHUB= yes
GH_TAGNAME= ${PORTVERSION:S/^/v/}
-USES= pkgconfig iconv
-HAS_CONFIGURE= yes
-USE_AUTOTOOLS= aclocal libtoolize autoheader automake autoconf
-ACLOCAL_ARGS= -I m4
-AUTOMAKE_ARGS= --add-missing --copy --foreign
+USES= autoreconf iconv pkgconfig
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var \
--with-logdir=/var/log \
--with-piddir=/var/run \
diff --git a/www/mod_auth_openid/Makefile b/www/mod_auth_openid/Makefile
index a1d10e8e94a8..510a21537499 100644
--- a/www/mod_auth_openid/Makefile
+++ b/www/mod_auth_openid/Makefile
@@ -20,9 +20,7 @@ GH_COMMIT= 22d1719
PLIST_FILES= ${APACHEMODDIR}/mod_auth_openid.so
USE_APACHE= 22+
-USES= gmake pkgconfig libtool
-USE_AUTOTOOLS= aclocal libtoolize autoconf automake autoheader
-AUTOMAKE_ARGS= --add-missing
+USES= autoreconf gmake libtool pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-pcre=${LOCALBASE}
diff --git a/www/sams2/Makefile b/www/sams2/Makefile
index c3b47a7e950d..1683e8f599fe 100644
--- a/www/sams2/Makefile
+++ b/www/sams2/Makefile
@@ -14,8 +14,7 @@ LICENSE= BSD4CLAUSE
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
RUN_DEPENDS= ${LOCALBASE}/libexec/mysqld:${PORTSDIR}/${_MYSQL_SERVER}
-USES= gmake libtool tar:bzip2
-USE_AUTOTOOLS= aclocal libtoolize
+USES= autoreconf gmake libtool tar:bzip2
USE_LDCONFIG= yes
USE_PHP= gd mysql zlib
USE_MYSQL= yes
@@ -47,11 +46,6 @@ AP24= ""
. endif
.endif
-do-configure:
- (cd ${WRKSRC} && make -f Makefile.cvs)
- (cd ${WRKSRC} && \
- ${SETENV} ${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS})
-
post-install:
${INSTALL_SCRIPT} ${FILESDIR}/sams2 ${STAGEDIR}${PREFIX}/etc/rc.d/
${INSTALL_DATA} ${WRKDIR}/sams2.conf.sample ${STAGEDIR}${PREFIX}/etc
diff --git a/x11/guake/Makefile b/x11/guake/Makefile
index c31ed593ac27..fc016b1244a4 100644
--- a/x11/guake/Makefile
+++ b/x11/guake/Makefile
@@ -42,8 +42,8 @@ OPTIONS_SUB= NLS
PLIST_SUB+= DESKTOPDIR="${DESKTOPDIR:S,${PREFIX}/,,}"
-USES= desktop-file-utils gettext gmake libtool pkgconfig python:2
-USE_AUTOTOOLS= autoconf:env automake:env libtoolize:env
+USES= autoreconf:build desktop-file-utils gettext gmake libtool \
+ pkgconfig python:2
USE_GITHUB= yes
USE_GNOME= gtk20 pygnome2