aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2003-04-02 02:05:34 +0800
committerskv <skv@FreeBSD.org>2003-04-02 02:05:34 +0800
commitda48f1e3a4ba26fcbf59970622b3671d33e65310 (patch)
treef3073273de96c823b2b1ff5f72f33b965ff54030
parent7c9f40ea3cc86d84bc5b9986938200e1cce9f15d (diff)
downloadfreebsd-ports-gnome-da48f1e3a4ba26fcbf59970622b3671d33e65310.tar.gz
freebsd-ports-gnome-da48f1e3a4ba26fcbf59970622b3671d33e65310.tar.zst
freebsd-ports-gnome-da48f1e3a4ba26fcbf59970622b3671d33e65310.zip
Update to 0.91
PR: 50333
-rw-r--r--www/p5-Apache-DBI/Makefile15
-rw-r--r--www/p5-Apache-DBI/distinfo2
-rw-r--r--www/p5-Apache-DBI/pkg-descr24
-rw-r--r--www/p5-Apache-DBI/pkg-plist8
4 files changed, 27 insertions, 22 deletions
diff --git a/www/p5-Apache-DBI/Makefile b/www/p5-Apache-DBI/Makefile
index ffc362998286..c9226c25b9fc 100644
--- a/www/p5-Apache-DBI/Makefile
+++ b/www/p5-Apache-DBI/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Apache-DBI
-PORTVERSION= 0.89
+PORTVERSION= 0.91
CATEGORIES= www databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Apache
@@ -15,11 +15,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= DBI persistent connection, authentication and authorization
-RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
+ ${SITE_PERL}/${PERL_ARCH}/Bundle/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Apache::DBI.3 Apache::AuthDBI.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Apache-DBI/distinfo b/www/p5-Apache-DBI/distinfo
index 9d3b0bc2efab..f8e0106fab2d 100644
--- a/www/p5-Apache-DBI/distinfo
+++ b/www/p5-Apache-DBI/distinfo
@@ -1 +1 @@
-MD5 (Apache-DBI-0.89.tar.gz) = 0ce3b0a75e96bda6994689c6c16a2ede
+MD5 (Apache-DBI-0.91.tar.gz) = 60f7c9a7cb10bdca88d38276d09e9a72
diff --git a/www/p5-Apache-DBI/pkg-descr b/www/p5-Apache-DBI/pkg-descr
index b3a7746db609..0b4692c02722 100644
--- a/www/p5-Apache-DBI/pkg-descr
+++ b/www/p5-Apache-DBI/pkg-descr
@@ -1,20 +1,18 @@
-From the README file:
-
-These modules are supposed to be used with the Apache server together with
-an embedded perl interpreter like mod_perl. They provide support for basic
-authentication and authorization as well as support for persistent database
-connections via Perl's Database Independent Interface (DBI).
+These modules are supposed to be used with the Apache server together
+with an embedded perl interpreter like mod_perl. They provide support
+for basic authentication and authorization as well as support for
+persistent database connections via Perl's Database Independent
+Interface (DBI).
o AuthDBI.pm provides authentication and authorization:
- - optional shared cache for passwords to minimize database load
- - configurable cleanup-handler deletes outdated entries from the cache
+- optional shared cache for passwords to minimize database load -
+configurable cleanup-handler deletes outdated entries from the cache
o DBI.pm provides persistent database connections:
- - connections can be established during server-startup
- - configurable rollback to ensure data integrity
- - configurable verification of the connections to avoid time-outs.
+- connections can be established during server-startup - configurable
+rollback to ensure data integrity - configurable verification of the
+connections to avoid time-outs.
--- Igor
-igor@zynaps.ru
+WWW: http://search.cpan.org/dist/Apache-DBI/
diff --git a/www/p5-Apache-DBI/pkg-plist b/www/p5-Apache-DBI/pkg-plist
index 94e699ede33c..3f3926e59b21 100644
--- a/www/p5-Apache-DBI/pkg-plist
+++ b/www/p5-Apache-DBI/pkg-plist
@@ -1,4 +1,4 @@
-lib/perl5/site_perl/%%PERL_VER%%/Apache/DBI.pm
-lib/perl5/site_perl/%%PERL_VER%%/Apache/AuthDBI.pm
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/DBI/.packlist
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/DBI
+%%SITE_PERL%%/Apache/DBI.pm
+%%SITE_PERL%%/Apache/AuthDBI.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI