aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-02 23:26:23 +0800
committerbapt <bapt@FreeBSD.org>2013-09-02 23:26:23 +0800
commite1d30c56d8683b1cbbbfac166938d461c936cb0e (patch)
treec58201dfe596662f56821940b522267813007f01
parent0511e7239d40a4e00f460b712435334d766a531a (diff)
downloadfreebsd-ports-gnome-e1d30c56d8683b1cbbbfac166938d461c936cb0e.tar.gz
freebsd-ports-gnome-e1d30c56d8683b1cbbbfac166938d461c936cb0e.tar.zst
freebsd-ports-gnome-e1d30c56d8683b1cbbbfac166938d461c936cb0e.zip
Add an explicit dependency on pkgconf
-rw-r--r--comms/anyremote/Makefile1
-rw-r--r--databases/postgresql-libpqxx3/Makefile8
-rw-r--r--devel/libccid/Makefile8
-rw-r--r--devel/libvirt/Makefile2
-rw-r--r--games/libmt_client/Makefile7
-rw-r--r--graphics/libraw/Makefile7
-rw-r--r--security/razorback-masterNugget/Makefile8
-rw-r--r--x11-toolkits/open-motif/Makefile2
-rw-r--r--x11-wm/fluxbox/Makefile2
-rw-r--r--x11/startup-notification/Makefile4
-rw-r--r--x11/xcb-util-image/Makefile2
-rw-r--r--x11/xcb-util-keysyms/Makefile2
-rw-r--r--x11/xcb-util-renderutil/Makefile2
-rw-r--r--x11/xcb-util-wm/Makefile2
14 files changed, 22 insertions, 35 deletions
diff --git a/comms/anyremote/Makefile b/comms/anyremote/Makefile
index f738269ec6b2..c1ac0111d880 100644
--- a/comms/anyremote/Makefile
+++ b/comms/anyremote/Makefile
@@ -11,6 +11,7 @@ COMMENT= Remote control service over Bluetooth, infrared, or TCP/IP networking
LICENSE= GPLv2
+USES= pkgconfig
USE_GNOME= glib20
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/databases/postgresql-libpqxx3/Makefile b/databases/postgresql-libpqxx3/Makefile
index b98ef72f764a..1715e85eec73 100644
--- a/databases/postgresql-libpqxx3/Makefile
+++ b/databases/postgresql-libpqxx3/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: PostgreSQL Pgaccess
-# Date created: December 1st, 2002
-# Whom: Palle Girgensohn <girgen@pingpong.net>
-#
+# Created by: Palle Girgensohn <girgen@pingpong.net>
# $FreeBSD$
-#
PORTNAME= libpqxx
PORTVERSION= 3.1
@@ -20,7 +16,7 @@ LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}3
PORTSCOUT= limit:^2\.
USE_PGSQL= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
diff --git a/devel/libccid/Makefile b/devel/libccid/Makefile
index 8a3f72d3fc31..b1f24fa2443d 100644
--- a/devel/libccid/Makefile
+++ b/devel/libccid/Makefile
@@ -1,7 +1,4 @@
-# New ports collection Makefile for: libccid
-# Date created: 2005-01-20
-# Whom: arved
-#
+# Created by: arved
# $FreeBSD$
PORTNAME= ccid
@@ -20,8 +17,9 @@ LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
USE_BZIP2= yes
+USES= pkgconfig perl5
GNU_CONFIGURE= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
CONFIGURE_ARGS= --enable-usbdropdir=${PREFIX}/lib/pcsc/drivers \
--enable-ccidtwindir=${PREFIX}/lib/pcsc/drivers/serial
CONFIGURE_ENV= LIBUSB_CFLAGS="-I${LOCALBASE}/include" \
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index 0514c931a48e..a5e6fd1135dc 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -51,7 +51,7 @@ PORTSCOUT= limit:\d+\.\d+\.\d+$$
LDFLAGS+= -L${LOCALBASE}/lib -fstack-protector
-USES= charsetfix pathfix gmake
+USES= charsetfix pathfix gmake pkgconfig
USE_LDCONFIG= yes
USE_PYTHON_BUILD= yes
SHLIB_VER= 1001
diff --git a/games/libmt_client/Makefile b/games/libmt_client/Makefile
index 883e8c0a441c..2e252262741e 100644
--- a/games/libmt_client/Makefile
+++ b/games/libmt_client/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libmt_client
-# Date created: Sun 7 mar 2004
-# Whom: thierry@pompo.net
-#
+# Created by: thierry@pompo.net
# $FreeBSD$
-#
PORTNAME= libmt_client
PORTVERSION= 0.1.98
@@ -17,6 +13,7 @@ COMMENT= Client-side library of MaitreTarot, a Tarot card game
LIB_DEPENDS= maitretarot.0:${PORTSDIR}/games/libmaitretarot
+USES= pkgconfig
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
GNU_CONFIGURE= yes
diff --git a/graphics/libraw/Makefile b/graphics/libraw/Makefile
index b90092dc3c21..b3eb6e6c5c18 100644
--- a/graphics/libraw/Makefile
+++ b/graphics/libraw/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: raw images library
-# Date created: 26 Apr 2008
-# Whom: Sergey A. Osokin <osa@FreeBSD.org>
-#
+# Created by: Sergey A. Osokin <osa@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libraw
PORTVERSION= 0.14.7
@@ -21,6 +17,7 @@ LICENSE_COMB= dual
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
USE_LDCONFIG= yes
+USES= pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-examples --disable-jasper
CFLAGS+= -fPIC
diff --git a/security/razorback-masterNugget/Makefile b/security/razorback-masterNugget/Makefile
index c99e47d46bd1..cd9a8414eeb1 100644
--- a/security/razorback-masterNugget/Makefile
+++ b/security/razorback-masterNugget/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: razorback-masterNugget
-# Date created: 2011/06/8
-# Whom: Tom Judge <tom@tomjudge.com>
-#
+# Created by: Tom Judge <tom@tomjudge.com>
# $FreeBSD$
-#
PORTNAME= masterNugget
PORTVERSION= 0.5.0
@@ -23,6 +19,8 @@ LIB_DEPENDS= razorback_api:${PORTSDIR}/security/razorback-api
OPTIONS_DEFINE= DEBUG ASSERT
ASSERT_DESC= Enable Asserts
+USES= pkgconfig
+
.include <bsd.port.options.mk>
GNU_CONFIGURE= yes
diff --git a/x11-toolkits/open-motif/Makefile b/x11-toolkits/open-motif/Makefile
index 96a9c549fffc..7e8cfec373a2 100644
--- a/x11-toolkits/open-motif/Makefile
+++ b/x11-toolkits/open-motif/Makefile
@@ -23,7 +23,7 @@ CONFLICTS= lesstif-[0-9]*
# WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
WRKSRC= ${WRKDIR}/motif-${PORTVERSION}
-USES= iconv gmake
+USES= iconv gmake pkgconfig
USE_AUTOTOOLS= libtool autoconf:env automake:env
USE_XORG= xaw xbitmaps xft
GNU_CONFIGURE= yes
diff --git a/x11-wm/fluxbox/Makefile b/x11-wm/fluxbox/Makefile
index 5bb2fb7d1dc6..be557abdca42 100644
--- a/x11-wm/fluxbox/Makefile
+++ b/x11-wm/fluxbox/Makefile
@@ -16,7 +16,7 @@ LICENSE= MIT
RUN_DEPENDS= xmessage:${PORTSDIR}/x11/xmessage
USE_XORG= xextproto xft xpm xrandr
-USE_GMAKE= yes
+USES= gmake pkgconfig
WANT_GNOME= yes
GNU_CONFIGURE= yes
diff --git a/x11/startup-notification/Makefile b/x11/startup-notification/Makefile
index 13054f9e35d6..cedaea75997a 100644
--- a/x11/startup-notification/Makefile
+++ b/x11/startup-notification/Makefile
@@ -16,8 +16,8 @@ LIB_DEPENDS= xcb-util:${PORTSDIR}/x11/xcb-util
USE_XORG= x11
USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
-USE_GNOME= gnomehack ltasneededhack
+USES= gmake pathfix pkgconfig
+USE_GNOME= ltasneededhack
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/x11/xcb-util-image/Makefile b/x11/xcb-util-image/Makefile
index 68032558bafd..a8b1ca94c583 100644
--- a/x11/xcb-util-image/Makefile
+++ b/x11/xcb-util-image/Makefile
@@ -11,8 +11,8 @@ COMMENT= A port of Xlib's XImage and XShmImage functions
LIB_DEPENDS= xcb-util:${PORTSDIR}/x11/xcb-util
#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
-USES= gmake
USE_BZIP2= yes
+USES= gmake pkgconfig
USE_LDCONFIG= yes
USE_XORG= xcb xorg-macros
#USE_XORG= xau xdmcp
diff --git a/x11/xcb-util-keysyms/Makefile b/x11/xcb-util-keysyms/Makefile
index 90a56c613efe..caa9bcf795db 100644
--- a/x11/xcb-util-keysyms/Makefile
+++ b/x11/xcb-util-keysyms/Makefile
@@ -11,7 +11,7 @@ COMMENT= Standard X key constants and conversion to/from keycodes
LIB_DEPENDS= xcb-util:${PORTSDIR}/x11/xcb-util
#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
-USES= gmake
+USES= gmake pkgconfig
USE_BZIP2= yes
USE_LDCONFIG= yes
USE_XORG= xcb xorg-macros
diff --git a/x11/xcb-util-renderutil/Makefile b/x11/xcb-util-renderutil/Makefile
index b40b77e958cb..93dbfdaaf769 100644
--- a/x11/xcb-util-renderutil/Makefile
+++ b/x11/xcb-util-renderutil/Makefile
@@ -11,8 +11,8 @@ COMMENT= Convenience functions for the Render extension
LIB_DEPENDS= xcb-util:${PORTSDIR}/x11/xcb-util
#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
-USES= gmake
USE_BZIP2= yes
+USES= gmake pkgconfig
USE_XORG= xcb xorg-macros
USE_LDCONFIG= yes
#USE_XORG= xau xdmcp
diff --git a/x11/xcb-util-wm/Makefile b/x11/xcb-util-wm/Makefile
index 25904f51b721..ea1ee5d31783 100644
--- a/x11/xcb-util-wm/Makefile
+++ b/x11/xcb-util-wm/Makefile
@@ -11,8 +11,8 @@ COMMENT= Framework for window manager implementation
LIB_DEPENDS= xcb-util:${PORTSDIR}/x11/xcb-util
#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
-USES= gmake
USE_BZIP2= yes
+USES= gmake pkgconfig
USE_LDCONFIG= yes
USE_XORG= xcb xorg-macros
#USE_XORG= xau xdmcp