aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-11-05 14:21:04 +0800
committermarcus <marcus@FreeBSD.org>2005-11-05 14:21:04 +0800
commite27c0d0d9d9671efab586876c36ef51591b53479 (patch)
treea4f97b4d0407471dac942f3beb7c15635ed48185
parent0621275b1d01e8cb9ff81b2bbc70593eeaec7dc5 (diff)
downloadfreebsd-ports-gnome-e27c0d0d9d9671efab586876c36ef51591b53479.tar.gz
freebsd-ports-gnome-e27c0d0d9d9671efab586876c36ef51591b53479.tar.zst
freebsd-ports-gnome-e27c0d0d9d9671efab586876c36ef51591b53479.zip
* Chase the glib20 shared lib version
* Disable cairo support as the new cairo API does not work with mozilla
-rw-r--r--www/mozilla-devel/Makefile56
-rw-r--r--www/mozilla-devel/files/patch-build_unix_run-mozilla.sh2
-rw-r--r--www/mozilla/Makefile39
-rw-r--r--www/mozilla/files/patch-build_unix_run-mozilla.sh2
-rw-r--r--www/mozilla/pkg-deinstall.in1
-rw-r--r--www/mozilla/pkg-install.in1
-rw-r--r--www/seamonkey/Makefile56
-rw-r--r--www/seamonkey/files/patch-build_unix_run-mozilla.sh2
-rw-r--r--www/seamonkey2/Makefile56
-rw-r--r--www/seamonkey2/files/patch-build_unix_run-mozilla.sh2
10 files changed, 109 insertions, 108 deletions
diff --git a/www/mozilla-devel/Makefile b/www/mozilla-devel/Makefile
index 5947dc3804af..f07c7a743f6d 100644
--- a/www/mozilla-devel/Makefile
+++ b/www/mozilla-devel/Makefile
@@ -3,11 +3,12 @@
# Whom: eivind/dima/jseger
#
# $FreeBSD$
+# $MCom: ports/www/mozilla-devel/Makefile,v 1.10 2005/10/27 00:08:39 marcus Exp $
#
PORTNAME?= mozilla
PORTVERSION= 1.8.b1
-PORTREVISION?= 6
+PORTREVISION?= 7
PORTEPOCH?= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -92,21 +93,22 @@ JPI_LIST?=\
${LOCALBASE}/jdk1.5.0/jre/plugin/${ARCH}/ns7/libjavaplugin_oji.so \
${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so
-OPTIONS=MAILNEWS "Enable Mail and News modules" on \
+OPTIONS=CALENDAR "Enable the Calendar module" off \
+ MAILNEWS "Enable Mail and News modules" on \
COMPOSER "Enable the HTML Composer module" on \
DEBUG "Enable debugging (i.e. gdb) support" off \
LDAP "Enable LDAP support for Mailnews" on \
CHATZILLA "Enable the Chatzilla IRC module" on \
JAVASCRIPT_DEBUGGER "Enable DTD and JavaScript debuggers" off \
OPTIMIZED_CFLAGS "Enable -O2 optimizations" off \
- CAIRO_RENDER "Enable SVG rendering with Cairo" off \
- CAIRO "Enable Cairo-specific Canvas features" off \
SMB "Enable smb:// URI support via gnomevfs" off
+# CAIRO_RENDER "Enable SVG rendering with Cairo" off \
+# CAIRO "Enable Cairo-specific Canvas features" off \
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "alpha"
-BROKEN= Does not compile on ${ARCH}
+BROKEN= "Does not compile on ${ARCH}"
.endif
.if ${ARCH} == "alpha" && ${OSVERSION} < 500035
@@ -114,38 +116,38 @@ IGNORE= core dumps on ${ARCH} during post-build
.endif
.if exists(${X11BASE}/lib/X11/fonts/mozilla/fonts.dir)
-BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
- illegibly. Please remove the mozilla-fonts package
+BROKEN= "Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
+ illegibly. Please remove the mozilla-fonts package"
.endif
-#.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
-# defined(WITHOUT_COMPOSER))
-#BROKEN= Calendar requires Composer and Mailnews support.
-#.endif
+.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
+ defined(WITHOUT_COMPOSER))
+BROKEN= "Calendar requires Composer and Mailnews support."
+.endif
.if ${OSVERSION} < 500000
USE_GCC= 3.4
.endif
.if defined(WITH_CAIRO_RENDER) || defined(WITH_CAIRO)
-LIB_DEPENDS+= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo
+#LIB_DEPENDS+= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo
.endif
-.if defined(WITH_CAIRO_RENDER)
-CONFIGURE_ARGS+= --enable-svg-renderer-cairo \
- --disable-svg-renderer-libart
-CONFIGURE_ENV+= MOZ_SVG_RENDERER_CAIRO=1
-.else
+#.if defined(WITH_CAIRO_RENDER)
+#CONFIGURE_ARGS+= --enable-svg-renderer-cairo \
+# --disable-svg-renderer-libart
+#CONFIGURE_ENV+= MOZ_SVG_RENDERER_CAIRO=1
+#.else
CONFIGURE_ARGS+= --enable-svg-renderer-libart \
--disable-svg-renderer-cairo
CONFIGURE_ENV+= MOZ_INTERNAL_LIBART_LGPL=1
MAKE_ENV+= MOZ_INTERNAL_LIBART_LGPL=1
-.endif
+#.endif
-.if defined(WITH_CAIRO)
-CONFIGURE_ARGS+= --enable-cairo
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include/cairo"
-.endif
+#.if defined(WITH_CAIRO)
+#CONFIGURE_ARGS+= --enable-cairo
+#CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include/cairo"
+#.endif
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug \
@@ -179,9 +181,9 @@ CONFIGURE_ARGS+= --disable-jsd \
--disable-dtd-debug
.endif
-#.if defined(WITH_CALENDAR)
-#CONFIGURE_ARGS+= --enable-calendar
-#.endif
+.if defined(WITH_CALENDAR)
+CONFIGURE_ARGS+= --enable-calendar
+.endif
.if defined(WITHOUT_COMPOSER)
CONFIGURE_ARGS+= --disable-composer
@@ -261,7 +263,7 @@ pre-install:
${RM} -rf ${PLIST} ${FAKEDIR}
${TOUCH} -f ${PLIST}
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
- Makefile ${MAKE_ARGS} install
+ Makefile ${MAKE_ARGS} ${INSTALL_TARGET}
${MKDIR} ${SCRIPTS_DIR} ${MOZ_PIS_DIR}
${REINPLACE_CMD} -e 's|${FAKEDIR}|${PREFIX}|g' \
${FAKEDIR}/bin/mozilla \
@@ -311,7 +313,7 @@ pre-install:
&& ${FIND} -d * -type d | \
${SED} -e 's:^:@dirrm share/idl/${MOZILLA}/:' >> ${PLIST}
${ECHO_CMD} "@dirrm share/idl/${MOZILLA}" >> ${PLIST}
- ${ECHO_CMD} "@unexec rmdir %D/share/idl 2>/dev/null || true" >> ${PLIST}
+ ${ECHO_CMD} "@unexec ${RMDIR} %D/share/idl 2>/dev/null || true" >> ${PLIST}
do-install:
${MKDIR} ${PREFIX}/lib/${MOZILLA}
diff --git a/www/mozilla-devel/files/patch-build_unix_run-mozilla.sh b/www/mozilla-devel/files/patch-build_unix_run-mozilla.sh
index f93248fd107b..ee99123b3978 100644
--- a/www/mozilla-devel/files/patch-build_unix_run-mozilla.sh
+++ b/www/mozilla-devel/files/patch-build_unix_run-mozilla.sh
@@ -1,5 +1,3 @@
-$FreeBSD$
-
--- build/unix/run-mozilla.sh.orig Mon Dec 15 12:27:28 2003
+++ build/unix/run-mozilla.sh Wed Feb 11 14:24:17 2004
@@ -355,7 +355,7 @@
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index 2dd54d7ebc81..1e97fdab459d 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -3,11 +3,12 @@
# Whom: eivind/dima/jseger
#
# $FreeBSD$
+# $MCom: ports/www/mozilla/Makefile,v 1.23 2005/10/27 00:08:39 marcus Exp $
#
PORTNAME= mozilla
PORTVERSION= 1.7.12
-PORTREVISION?= 0
+PORTREVISION?= 1
PORTEPOCH= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
@@ -99,38 +100,38 @@ OPTIONS=XFT "Enable Xft font anti-aliasing" on \
XMLTERM "Enable the XMLTerm module" on \
JAVASCRIPT_DEBUGGER "Enable DTD and JavaScript debuggers" off \
OPTIMIZED_CFLAGS "Enable -O2 optimizations" off \
- CAIRO_RENDER "Enable SVG rendering with Cairo" off \
SMB "Enable smb:// URI support via gnomevfs" off
+# CAIRO_RENDER "Enable SVG rendering with Cairo" off
.include <bsd.port.pre.mk>
-.if !defined(WITH_CAIRO_RENDER)
+#.if !defined(WITH_CAIRO_RENDER)
DISTFILES+= libart_lgpl-1${EXTRACT_SUFX}:local
-.endif
+#.endif
.if ${ARCH} == "alpha" && ${OSVERSION} < 500035
IGNORE= core dumps on ${ARCH} during post-build
.endif
.if exists(${LOCALBASE}/include/freetype/freetype.h)
-BROKEN= You must upgrade your freetype port to 1.3.1_2 or higher before \
+BROKEN= "You must upgrade your freetype port to 1.3.1_2 or higher before \
installing Mozilla. If you have 1.3.1_2 installed, please remove \
- ${LOCALBASE}/include/freetype, then build Mozilla
+ ${LOCALBASE}/include/freetype, then build Mozilla"
.endif
.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
defined(WITHOUT_COMPOSER))
-BROKEN= Calendar requires Composer and Mailnews support.
+BROKEN= "Calendar requires Composer and Mailnews support."
.endif
-.if defined(WITH_CAIRO_RENDER)
-LIB_DEPENDS+= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo
-BUILD_DEPENDS+= ${LOCALBASE}/include/cairo/cairo-xlib.h:${PORTSDIR}/graphics/cairo
+#.if defined(WITH_CAIRO_RENDER)
+#LIB_DEPENDS+= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo
+#BUILD_DEPENDS+= ${LOCALBASE}/include/cairo/cairo-xlib.h:${PORTSDIR}/graphics/cairo
-CONFIGURE_ARGS+= --enable-svg-renderer-cairo \
- --disable-svg-renderer-libart
-CONFIGURE_ENV+= MOZ_SVG_RENDERER_CAIRO=1
-.else
+#CONFIGURE_ARGS+= --enable-svg-renderer-cairo \
+# --disable-svg-renderer-libart
+#CONFIGURE_ENV+= MOZ_SVG_RENDERER_CAIRO=1
+#.else
CONFIGURE_ARGS+= --enable-svg-renderer-libart \
--disable-svg-renderer-cairo
CONFIGURE_ENV+= MOZ_INTERNAL_LIBART_LGPL=1
@@ -140,14 +141,14 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-nsSVGLibartGlyphMetricsFT.cpp
.else
EXTRA_PATCHES+= ${FILESDIR}/extra-patch2-nsSVGLibartGlyphMetricsFT.cpp
.endif
-.endif
+#.endif
.if !defined(WITHOUT_XFT)
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
CONFIGURE_ARGS+=--enable-xft
.if exists(${X11BASE}/lib/X11/fonts/mozilla/fonts.dir)
-BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
- illegibly. Please remove the mozilla-fonts package.
+BROKEN= "Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
+ illegibly. Please remove the mozilla-fonts package."
.endif
.else
CONFIGURE_ARGS+=--disable-xft
@@ -273,7 +274,7 @@ pre-install:
${RM} -rf ${FAKEDIR} ${PLIST}
${TOUCH} -f ${PLIST}
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
- Makefile ${MAKE_ARGS} install
+ Makefile ${MAKE_ARGS} ${INSTALL_TARGET}
${MKDIR} ${MOZ_PIS_DIR}
${REINPLACE_CMD} -e 's|${FAKEDIR}|${PREFIX}|g' \
${FAKEDIR}/bin/mozilla \
@@ -325,7 +326,7 @@ pre-install:
&& ${FIND} -d * -type d | \
${SED} -e 's:^:@dirrm share/idl/${MOZILLA}/:' >> ${PLIST}
${ECHO_CMD} "@dirrm share/idl/${MOZILLA}" >> ${PLIST}
- ${ECHO_CMD} "@unexec rmdir %D/share/idl 2>/dev/null || true" >> ${PLIST}
+ ${ECHO_CMD} "@unexec ${RMDIR} %D/share/idl 2>/dev/null || true" >> ${PLIST}
do-install:
${MKDIR} ${PREFIX}/lib/${MOZILLA}
diff --git a/www/mozilla/files/patch-build_unix_run-mozilla.sh b/www/mozilla/files/patch-build_unix_run-mozilla.sh
index f93248fd107b..ee99123b3978 100644
--- a/www/mozilla/files/patch-build_unix_run-mozilla.sh
+++ b/www/mozilla/files/patch-build_unix_run-mozilla.sh
@@ -1,5 +1,3 @@
-$FreeBSD$
-
--- build/unix/run-mozilla.sh.orig Mon Dec 15 12:27:28 2003
+++ build/unix/run-mozilla.sh Wed Feb 11 14:24:17 2004
@@ -355,7 +355,7 @@
diff --git a/www/mozilla/pkg-deinstall.in b/www/mozilla/pkg-deinstall.in
index 329a58b212d6..b9457eff010c 100644
--- a/www/mozilla/pkg-deinstall.in
+++ b/www/mozilla/pkg-deinstall.in
@@ -1,6 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
+# $MCom: ports/www/mozilla/pkg-deinstall.in,v 1.7 2005/07/13 08:45:47 ahze Exp $
#
# Date created: Mon Nov 29, 2003
# Whom: Thierry Thomas (<thierry@pompo.net>)
diff --git a/www/mozilla/pkg-install.in b/www/mozilla/pkg-install.in
index 79a65c81189a..2b196acaf42c 100644
--- a/www/mozilla/pkg-install.in
+++ b/www/mozilla/pkg-install.in
@@ -1,6 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
+# $MCom: ports/www/mozilla/pkg-install.in,v 1.7 2005/07/13 08:45:47 ahze Exp $
#
# Date created: Mon Nov 29, 2003
# Whom: Thierry Thomas (<thierry@pompo.net>)
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 5947dc3804af..f07c7a743f6d 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -3,11 +3,12 @@
# Whom: eivind/dima/jseger
#
# $FreeBSD$
+# $MCom: ports/www/mozilla-devel/Makefile,v 1.10 2005/10/27 00:08:39 marcus Exp $
#
PORTNAME?= mozilla
PORTVERSION= 1.8.b1
-PORTREVISION?= 6
+PORTREVISION?= 7
PORTEPOCH?= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -92,21 +93,22 @@ JPI_LIST?=\
${LOCALBASE}/jdk1.5.0/jre/plugin/${ARCH}/ns7/libjavaplugin_oji.so \
${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so
-OPTIONS=MAILNEWS "Enable Mail and News modules" on \
+OPTIONS=CALENDAR "Enable the Calendar module" off \
+ MAILNEWS "Enable Mail and News modules" on \
COMPOSER "Enable the HTML Composer module" on \
DEBUG "Enable debugging (i.e. gdb) support" off \
LDAP "Enable LDAP support for Mailnews" on \
CHATZILLA "Enable the Chatzilla IRC module" on \
JAVASCRIPT_DEBUGGER "Enable DTD and JavaScript debuggers" off \
OPTIMIZED_CFLAGS "Enable -O2 optimizations" off \
- CAIRO_RENDER "Enable SVG rendering with Cairo" off \
- CAIRO "Enable Cairo-specific Canvas features" off \
SMB "Enable smb:// URI support via gnomevfs" off
+# CAIRO_RENDER "Enable SVG rendering with Cairo" off \
+# CAIRO "Enable Cairo-specific Canvas features" off \
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "alpha"
-BROKEN= Does not compile on ${ARCH}
+BROKEN= "Does not compile on ${ARCH}"
.endif
.if ${ARCH} == "alpha" && ${OSVERSION} < 500035
@@ -114,38 +116,38 @@ IGNORE= core dumps on ${ARCH} during post-build
.endif
.if exists(${X11BASE}/lib/X11/fonts/mozilla/fonts.dir)
-BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
- illegibly. Please remove the mozilla-fonts package
+BROKEN= "Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
+ illegibly. Please remove the mozilla-fonts package"
.endif
-#.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
-# defined(WITHOUT_COMPOSER))
-#BROKEN= Calendar requires Composer and Mailnews support.
-#.endif
+.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
+ defined(WITHOUT_COMPOSER))
+BROKEN= "Calendar requires Composer and Mailnews support."
+.endif
.if ${OSVERSION} < 500000
USE_GCC= 3.4
.endif
.if defined(WITH_CAIRO_RENDER) || defined(WITH_CAIRO)
-LIB_DEPENDS+= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo
+#LIB_DEPENDS+= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo
.endif
-.if defined(WITH_CAIRO_RENDER)
-CONFIGURE_ARGS+= --enable-svg-renderer-cairo \
- --disable-svg-renderer-libart
-CONFIGURE_ENV+= MOZ_SVG_RENDERER_CAIRO=1
-.else
+#.if defined(WITH_CAIRO_RENDER)
+#CONFIGURE_ARGS+= --enable-svg-renderer-cairo \
+# --disable-svg-renderer-libart
+#CONFIGURE_ENV+= MOZ_SVG_RENDERER_CAIRO=1
+#.else
CONFIGURE_ARGS+= --enable-svg-renderer-libart \
--disable-svg-renderer-cairo
CONFIGURE_ENV+= MOZ_INTERNAL_LIBART_LGPL=1
MAKE_ENV+= MOZ_INTERNAL_LIBART_LGPL=1
-.endif
+#.endif
-.if defined(WITH_CAIRO)
-CONFIGURE_ARGS+= --enable-cairo
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include/cairo"
-.endif
+#.if defined(WITH_CAIRO)
+#CONFIGURE_ARGS+= --enable-cairo
+#CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include/cairo"
+#.endif
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug \
@@ -179,9 +181,9 @@ CONFIGURE_ARGS+= --disable-jsd \
--disable-dtd-debug
.endif
-#.if defined(WITH_CALENDAR)
-#CONFIGURE_ARGS+= --enable-calendar
-#.endif
+.if defined(WITH_CALENDAR)
+CONFIGURE_ARGS+= --enable-calendar
+.endif
.if defined(WITHOUT_COMPOSER)
CONFIGURE_ARGS+= --disable-composer
@@ -261,7 +263,7 @@ pre-install:
${RM} -rf ${PLIST} ${FAKEDIR}
${TOUCH} -f ${PLIST}
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
- Makefile ${MAKE_ARGS} install
+ Makefile ${MAKE_ARGS} ${INSTALL_TARGET}
${MKDIR} ${SCRIPTS_DIR} ${MOZ_PIS_DIR}
${REINPLACE_CMD} -e 's|${FAKEDIR}|${PREFIX}|g' \
${FAKEDIR}/bin/mozilla \
@@ -311,7 +313,7 @@ pre-install:
&& ${FIND} -d * -type d | \
${SED} -e 's:^:@dirrm share/idl/${MOZILLA}/:' >> ${PLIST}
${ECHO_CMD} "@dirrm share/idl/${MOZILLA}" >> ${PLIST}
- ${ECHO_CMD} "@unexec rmdir %D/share/idl 2>/dev/null || true" >> ${PLIST}
+ ${ECHO_CMD} "@unexec ${RMDIR} %D/share/idl 2>/dev/null || true" >> ${PLIST}
do-install:
${MKDIR} ${PREFIX}/lib/${MOZILLA}
diff --git a/www/seamonkey/files/patch-build_unix_run-mozilla.sh b/www/seamonkey/files/patch-build_unix_run-mozilla.sh
index f93248fd107b..ee99123b3978 100644
--- a/www/seamonkey/files/patch-build_unix_run-mozilla.sh
+++ b/www/seamonkey/files/patch-build_unix_run-mozilla.sh
@@ -1,5 +1,3 @@
-$FreeBSD$
-
--- build/unix/run-mozilla.sh.orig Mon Dec 15 12:27:28 2003
+++ build/unix/run-mozilla.sh Wed Feb 11 14:24:17 2004
@@ -355,7 +355,7 @@
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index 5947dc3804af..f07c7a743f6d 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -3,11 +3,12 @@
# Whom: eivind/dima/jseger
#
# $FreeBSD$
+# $MCom: ports/www/mozilla-devel/Makefile,v 1.10 2005/10/27 00:08:39 marcus Exp $
#
PORTNAME?= mozilla
PORTVERSION= 1.8.b1
-PORTREVISION?= 6
+PORTREVISION?= 7
PORTEPOCH?= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -92,21 +93,22 @@ JPI_LIST?=\
${LOCALBASE}/jdk1.5.0/jre/plugin/${ARCH}/ns7/libjavaplugin_oji.so \
${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so
-OPTIONS=MAILNEWS "Enable Mail and News modules" on \
+OPTIONS=CALENDAR "Enable the Calendar module" off \
+ MAILNEWS "Enable Mail and News modules" on \
COMPOSER "Enable the HTML Composer module" on \
DEBUG "Enable debugging (i.e. gdb) support" off \
LDAP "Enable LDAP support for Mailnews" on \
CHATZILLA "Enable the Chatzilla IRC module" on \
JAVASCRIPT_DEBUGGER "Enable DTD and JavaScript debuggers" off \
OPTIMIZED_CFLAGS "Enable -O2 optimizations" off \
- CAIRO_RENDER "Enable SVG rendering with Cairo" off \
- CAIRO "Enable Cairo-specific Canvas features" off \
SMB "Enable smb:// URI support via gnomevfs" off
+# CAIRO_RENDER "Enable SVG rendering with Cairo" off \
+# CAIRO "Enable Cairo-specific Canvas features" off \
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "alpha"
-BROKEN= Does not compile on ${ARCH}
+BROKEN= "Does not compile on ${ARCH}"
.endif
.if ${ARCH} == "alpha" && ${OSVERSION} < 500035
@@ -114,38 +116,38 @@ IGNORE= core dumps on ${ARCH} during post-build
.endif
.if exists(${X11BASE}/lib/X11/fonts/mozilla/fonts.dir)
-BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
- illegibly. Please remove the mozilla-fonts package
+BROKEN= "Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
+ illegibly. Please remove the mozilla-fonts package"
.endif
-#.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
-# defined(WITHOUT_COMPOSER))
-#BROKEN= Calendar requires Composer and Mailnews support.
-#.endif
+.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
+ defined(WITHOUT_COMPOSER))
+BROKEN= "Calendar requires Composer and Mailnews support."
+.endif
.if ${OSVERSION} < 500000
USE_GCC= 3.4
.endif
.if defined(WITH_CAIRO_RENDER) || defined(WITH_CAIRO)
-LIB_DEPENDS+= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo
+#LIB_DEPENDS+= svg-cairo.1:${PORTSDIR}/graphics/libsvg-cairo
.endif
-.if defined(WITH_CAIRO_RENDER)
-CONFIGURE_ARGS+= --enable-svg-renderer-cairo \
- --disable-svg-renderer-libart
-CONFIGURE_ENV+= MOZ_SVG_RENDERER_CAIRO=1
-.else
+#.if defined(WITH_CAIRO_RENDER)
+#CONFIGURE_ARGS+= --enable-svg-renderer-cairo \
+# --disable-svg-renderer-libart
+#CONFIGURE_ENV+= MOZ_SVG_RENDERER_CAIRO=1
+#.else
CONFIGURE_ARGS+= --enable-svg-renderer-libart \
--disable-svg-renderer-cairo
CONFIGURE_ENV+= MOZ_INTERNAL_LIBART_LGPL=1
MAKE_ENV+= MOZ_INTERNAL_LIBART_LGPL=1
-.endif
+#.endif
-.if defined(WITH_CAIRO)
-CONFIGURE_ARGS+= --enable-cairo
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include/cairo"
-.endif
+#.if defined(WITH_CAIRO)
+#CONFIGURE_ARGS+= --enable-cairo
+#CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include/cairo"
+#.endif
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug \
@@ -179,9 +181,9 @@ CONFIGURE_ARGS+= --disable-jsd \
--disable-dtd-debug
.endif
-#.if defined(WITH_CALENDAR)
-#CONFIGURE_ARGS+= --enable-calendar
-#.endif
+.if defined(WITH_CALENDAR)
+CONFIGURE_ARGS+= --enable-calendar
+.endif
.if defined(WITHOUT_COMPOSER)
CONFIGURE_ARGS+= --disable-composer
@@ -261,7 +263,7 @@ pre-install:
${RM} -rf ${PLIST} ${FAKEDIR}
${TOUCH} -f ${PLIST}
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
- Makefile ${MAKE_ARGS} install
+ Makefile ${MAKE_ARGS} ${INSTALL_TARGET}
${MKDIR} ${SCRIPTS_DIR} ${MOZ_PIS_DIR}
${REINPLACE_CMD} -e 's|${FAKEDIR}|${PREFIX}|g' \
${FAKEDIR}/bin/mozilla \
@@ -311,7 +313,7 @@ pre-install:
&& ${FIND} -d * -type d | \
${SED} -e 's:^:@dirrm share/idl/${MOZILLA}/:' >> ${PLIST}
${ECHO_CMD} "@dirrm share/idl/${MOZILLA}" >> ${PLIST}
- ${ECHO_CMD} "@unexec rmdir %D/share/idl 2>/dev/null || true" >> ${PLIST}
+ ${ECHO_CMD} "@unexec ${RMDIR} %D/share/idl 2>/dev/null || true" >> ${PLIST}
do-install:
${MKDIR} ${PREFIX}/lib/${MOZILLA}
diff --git a/www/seamonkey2/files/patch-build_unix_run-mozilla.sh b/www/seamonkey2/files/patch-build_unix_run-mozilla.sh
index f93248fd107b..ee99123b3978 100644
--- a/www/seamonkey2/files/patch-build_unix_run-mozilla.sh
+++ b/www/seamonkey2/files/patch-build_unix_run-mozilla.sh
@@ -1,5 +1,3 @@
-$FreeBSD$
-
--- build/unix/run-mozilla.sh.orig Mon Dec 15 12:27:28 2003
+++ build/unix/run-mozilla.sh Wed Feb 11 14:24:17 2004
@@ -355,7 +355,7 @@