aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2003-02-21 17:32:27 +0800
committerdougb <dougb@FreeBSD.org>2003-02-21 17:32:27 +0800
commite3c6d7b1912ca71fc98960cddad94048dc4075ea (patch)
tree203e29f6690927e82bd6f9dc73de429f443e4b6e
parent94eb9494e441b9d095ac2ee2382bd1b696254f47 (diff)
downloadfreebsd-ports-gnome-e3c6d7b1912ca71fc98960cddad94048dc4075ea.tar.gz
freebsd-ports-gnome-e3c6d7b1912ca71fc98960cddad94048dc4075ea.tar.zst
freebsd-ports-gnome-e3c6d7b1912ca71fc98960cddad94048dc4075ea.zip
The PodParser update is only needed if we're not working with Perl
5.6.1 or later. PR: ports/48349 Submitted by: Yen-Ming Lee <leeym@utopia.leeym.com>
-rw-r--r--mail/p5-Mail-SpamAssassin/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/mail/p5-Mail-SpamAssassin/Makefile b/mail/p5-Mail-SpamAssassin/Makefile
index bdd6e911353d..1ed2b2e4579c 100644
--- a/mail/p5-Mail-SpamAssassin/Makefile
+++ b/mail/p5-Mail-SpamAssassin/Makefile
@@ -23,9 +23,13 @@ RUN_DEPENDS= ${BUILD_DEPENDS} \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
razor-client:${PORTSDIR}/mail/razor-agents
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
PODPARSER= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser
RUN_DEPENDS+= ${PODPARSER}
BUILD_DEPENDS+= ${PODPARSER}
+.endif
PERL_CONFIGURE= yes
CONFIGURE_ARGS+= SYSCONFDIR="${PREFIX}/etc" \
@@ -56,4 +60,4 @@ post-install:
@${SED} -e 's#PREFIX#/usr/local#' pkg-message
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>