aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-06-04 16:09:20 +0800
committerpav <pav@FreeBSD.org>2010-06-04 16:09:20 +0800
commite7f0a8b3c17c3b5364b3d27dda111d6817712cfd (patch)
tree77155b7cf2dae561704dbe7239314bd09db1ec8f
parent08466ea7f867fd5df5471a209dfd43d6c6266d3d (diff)
downloadfreebsd-ports-gnome-e7f0a8b3c17c3b5364b3d27dda111d6817712cfd.tar.gz
freebsd-ports-gnome-e7f0a8b3c17c3b5364b3d27dda111d6817712cfd.tar.zst
freebsd-ports-gnome-e7f0a8b3c17c3b5364b3d27dda111d6817712cfd.zip
- Introduce a new USE_XZ knob that handles lzma/xz compressed distfiles
- Convert a bunch of ports to use it PR: ports/146329 Submitted by: mm With hat: portmgr
-rw-r--r--Mk/bsd.commands.mk6
-rw-r--r--Mk/bsd.port.mk12
-rw-r--r--devel/libtool22/Makefile2
-rw-r--r--devel/libtool22/distinfo6
-rw-r--r--devel/libtool24/Makefile2
-rw-r--r--devel/libtool24/distinfo6
-rw-r--r--devel/patch/Makefile1
-rw-r--r--devel/patch/distinfo6
-rw-r--r--dns/dnsmasq/Makefile3
-rw-r--r--dns/dnsmasq/distinfo6
-rw-r--r--ftp/lftp/Makefile3
-rw-r--r--ftp/lftp/distinfo6
-rw-r--r--ftp/wget/Makefile3
-rw-r--r--ftp/wget/distinfo6
-rw-r--r--graphics/ImageMagick/Makefile5
-rw-r--r--graphics/ImageMagick/distinfo6
-rw-r--r--graphics/png/Makefile2
-rw-r--r--graphics/png/distinfo6
-rw-r--r--japanese/font-ume/Makefile12
-rw-r--r--math/mpfr/Makefile2
-rw-r--r--math/mpfr/distinfo6
-rw-r--r--misc/mc/Makefile3
-rw-r--r--misc/mc/distinfo6
-rw-r--r--print/ghostscript8/Makefile1
-rw-r--r--print/ghostscript8/distinfo6
-rw-r--r--sysutils/coreutils/Makefile1
-rw-r--r--sysutils/coreutils/distinfo6
-rw-r--r--textproc/gnugrep/Makefile2
-rw-r--r--textproc/gnugrep/distinfo6
29 files changed, 80 insertions, 58 deletions
diff --git a/Mk/bsd.commands.mk b/Mk/bsd.commands.mk
index 2320597ee130..60095228516f 100644
--- a/Mk/bsd.commands.mk
+++ b/Mk/bsd.commands.mk
@@ -93,6 +93,12 @@ XARGS?= /usr/bin/xargs
XMKMF?= ${LOCALBASE}/bin/xmkmf -a
YACC?= /usr/bin/yacc
+.if exists(/usr/bin/xz)
+XZ_CMD?= /usr/bin/xz
+.else
+XZ_CMD?= ${LOCALBASE}/bin/xz
+.endif
+
.if exists(/sbin/md5)
MD5?= /sbin/md5
.else
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 0cdfd8c3ad94..6735b933403e 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -94,7 +94,8 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# EXTRACT_SUFX - Suffix for archive names
# You never have to set both DISTFILES and EXTRACT_SUFX.
# Default: .tar.bz2 if USE_BZIP2 is set, .zip if USE_ZIP is
-# set, .run if USE_MAKESELF is set, .tar.gz otherwise).
+# set, .tar.xz if USE_XZ is set, .run if USE_MAKESELF is set,
+# .tar.gz otherwise).
# MASTER_SITES - Primary location(s) for distribution files if not found
# locally. See bsd.sites.mk for common choices for
# MASTER_SITES.
@@ -296,6 +297,8 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
#
# USE_BZIP2 - If set, this port tarballs use bzip2, not gzip, for
# compression.
+# USE_XZ - If set, this port tarballs use xz (or lzma)
+# for compression
# USE_ZIP - If set, this port distfile uses zip, not tar w/[bg]zip
# for compression.
# USE_MAKESELF - If set, this port distfile uses makeself, not tar w/[bg]zip
@@ -1413,6 +1416,8 @@ IGNORE= cannot be installed: bad X_WINDOW_SYSTEM setting; valid value is 'xorg'
EXTRACT_SUFX?= .tar.bz2
.elif defined(USE_ZIP)
EXTRACT_SUFX?= .zip
+.elif defined(USE_XZ)
+EXTRACT_SUFX?= .tar.xz
.elif defined(USE_MAKESELF)
EXTRACT_SUFX?= .run
.else
@@ -1731,6 +1736,9 @@ PLIST_SUB+= LIB32DIR=${LIB32DIR}
.if defined(USE_ZIP)
EXTRACT_DEPENDS+= ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip
.endif
+.if defined(USE_XZ) && ( (${OSVERSION} >= 900000 && ${OSVERSION} < 900012) || ${OSVERSION} < 800505 )
+EXTRACT_DEPENDS+= ${LOCALBASE}/bin/xz:${PORTSDIR}/archivers/xz
+.endif
.if defined(USE_MAKESELF)
EXTRACT_DEPENDS+= unmakeself:${PORTSDIR}/archivers/unmakeself
.endif
@@ -2370,6 +2378,8 @@ EXTRACT_AFTER_ARGS?= | ${TAR} -xf - --no-same-owner --no-same-permissions
.endif
.if defined(USE_BZIP2)
EXTRACT_CMD?= ${BZIP2_CMD}
+.elif defined(USE_XZ)
+EXTRACT_CMD?= ${XZ_CMD}
.else
EXTRACT_CMD?= ${GZIP_CMD}
.endif
diff --git a/devel/libtool22/Makefile b/devel/libtool22/Makefile
index c4c264cb170d..6bc23f393c68 100644
--- a/devel/libtool22/Makefile
+++ b/devel/libtool22/Makefile
@@ -11,11 +11,13 @@ CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= libtool
DISTNAME= libtool-${PORTVERSION}
+EXTRACT_SUFX= .tar.lzma
MAINTAINER= kwm@FreeBSD.org
COMMENT?= Generic shared library support script
WRKSRC= ${WRKDIR}/libtool-${PORTVERSION:S|a||}
+USE_XZ= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS?= --disable-ltdl-install
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
diff --git a/devel/libtool22/distinfo b/devel/libtool22/distinfo
index 6b3f7e260e76..8e297af87bff 100644
--- a/devel/libtool22/distinfo
+++ b/devel/libtool22/distinfo
@@ -1,3 +1,3 @@
-MD5 (libtool-2.2.6b.tar.gz) = 07da460450490148c6d2df0f21481a25
-SHA256 (libtool-2.2.6b.tar.gz) = efe133e1014bca96998536f2e565a14fe0fde20cc83ff67135451e4e4e64ad57
-SIZE (libtool-2.2.6b.tar.gz) = 2347317
+MD5 (libtool-2.2.6b.tar.lzma) = a4b36980765003b47dd75ac9429f4f11
+SHA256 (libtool-2.2.6b.tar.lzma) = 66ebad3c02e5cb6672bfbda1183fb6fc919d33d676eb8be4b7834aa7c3b8b7ae
+SIZE (libtool-2.2.6b.tar.lzma) = 739089
diff --git a/devel/libtool24/Makefile b/devel/libtool24/Makefile
index c4c264cb170d..6bc23f393c68 100644
--- a/devel/libtool24/Makefile
+++ b/devel/libtool24/Makefile
@@ -11,11 +11,13 @@ CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= libtool
DISTNAME= libtool-${PORTVERSION}
+EXTRACT_SUFX= .tar.lzma
MAINTAINER= kwm@FreeBSD.org
COMMENT?= Generic shared library support script
WRKSRC= ${WRKDIR}/libtool-${PORTVERSION:S|a||}
+USE_XZ= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS?= --disable-ltdl-install
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
diff --git a/devel/libtool24/distinfo b/devel/libtool24/distinfo
index 6b3f7e260e76..8e297af87bff 100644
--- a/devel/libtool24/distinfo
+++ b/devel/libtool24/distinfo
@@ -1,3 +1,3 @@
-MD5 (libtool-2.2.6b.tar.gz) = 07da460450490148c6d2df0f21481a25
-SHA256 (libtool-2.2.6b.tar.gz) = efe133e1014bca96998536f2e565a14fe0fde20cc83ff67135451e4e4e64ad57
-SIZE (libtool-2.2.6b.tar.gz) = 2347317
+MD5 (libtool-2.2.6b.tar.lzma) = a4b36980765003b47dd75ac9429f4f11
+SHA256 (libtool-2.2.6b.tar.lzma) = 66ebad3c02e5cb6672bfbda1183fb6fc919d33d676eb8be4b7834aa7c3b8b7ae
+SIZE (libtool-2.2.6b.tar.lzma) = 739089
diff --git a/devel/patch/Makefile b/devel/patch/Makefile
index 451c6e4d16ef..70b2210e38db 100644
--- a/devel/patch/Makefile
+++ b/devel/patch/Makefile
@@ -17,6 +17,7 @@ COMMENT= GNU patch utility
USE_AUTOTOOLS= autoconf:262 aclocal:110
CONFIGURE_ARGS= --program-prefix=g
USE_GMAKE= yes
+USE_XZ= yes
MAN1= gpatch.1
PLIST_FILES= bin/gpatch
diff --git a/devel/patch/distinfo b/devel/patch/distinfo
index 85aa063972a4..11dbc983f30a 100644
--- a/devel/patch/distinfo
+++ b/devel/patch/distinfo
@@ -1,3 +1,3 @@
-MD5 (patch-2.6.1.tar.gz) = d758eb96d3f75047efc004a720d33daf
-SHA256 (patch-2.6.1.tar.gz) = d1563731e9cffed11cc5f011b2b8e074c325e86a383a91889b5c5b80b09781b9
-SIZE (patch-2.6.1.tar.gz) = 303692
+MD5 (patch-2.6.1.tar.xz) = 057d78436e858c3ed086a544f5e1fe7e
+SHA256 (patch-2.6.1.tar.xz) = f8da42cd777e49c4c29092d8595b36daf24cd93a38dca97f3489f1a4fb1301a0
+SIZE (patch-2.6.1.tar.xz) = 239408
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
index 46d1a4e3b4b2..6c3ca05d2cc9 100644
--- a/dns/dnsmasq/Makefile
+++ b/dns/dnsmasq/Makefile
@@ -12,10 +12,13 @@ PORTEPOCH= 1
CATEGORIES= dns ipv6
MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/ \
http://homepages.uni-paderborn.de/mandree/
+EXTRACT_SUFX= .tar.lzma
MAINTAINER= mandree@FreeBSD.org
COMMENT= Lightweight DNS forwarder, DHCP and TFTP server
+USE_XZ= yes
+
MAN8= dnsmasq.8
PORTDOCS= CHANGELOG CHANGELOG.archive FAQ doc.html setup.html
diff --git a/dns/dnsmasq/distinfo b/dns/dnsmasq/distinfo
index a259cf8f7304..7312de50edcd 100644
--- a/dns/dnsmasq/distinfo
+++ b/dns/dnsmasq/distinfo
@@ -1,3 +1,3 @@
-MD5 (dnsmasq-2.52.tar.gz) = 1bb32fffdb4f977ead607802b5d701d0
-SHA256 (dnsmasq-2.52.tar.gz) = a3724f875d0d30c0e2612a32926ad2b6c0a49fff7e224e737689e4c7e8b323d9
-SIZE (dnsmasq-2.52.tar.gz) = 416466
+MD5 (dnsmasq-2.52.tar.lzma) = 2d156f322564fdd71ad238040cd607ac
+SHA256 (dnsmasq-2.52.tar.lzma) = 1f7834618181ef2a2feadb65a8a71e6fb75f5dfa07759df295726c2db765cca0
+SIZE (dnsmasq-2.52.tar.lzma) = 304860
diff --git a/ftp/lftp/Makefile b/ftp/lftp/Makefile
index 63da903db63c..f8bd83c1319f 100644
--- a/ftp/lftp/Makefile
+++ b/ftp/lftp/Makefile
@@ -18,6 +18,7 @@ MASTER_SITES= ftp://ftp.st.ryukoku.ac.jp/pub/network/ftp/lftp/ \
ftp://ftp.wiretapped.net/pub/mirrors/lftp/old/ \
ftp://ftp.yars.free.net/pub/source/lftp/ \
ftp://ftp.yars.free.net/pub/source/lftp/old/
+EXTRACT_SUFX= .tar.lzma
MAINTAINER= ganael.laplanche@martymac.com
COMMENT= Shell-like command line ftp client
@@ -25,7 +26,7 @@ COMMENT= Shell-like command line ftp client
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
USE_ICONV= yes
-USE_BZIP2= yes
+USE_XZ= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
diff --git a/ftp/lftp/distinfo b/ftp/lftp/distinfo
index 72de04af20e4..3212c33ebdf2 100644
--- a/ftp/lftp/distinfo
+++ b/ftp/lftp/distinfo
@@ -1,3 +1,3 @@
-MD5 (lftp-4.0.5.tar.bz2) = 5400cad5f91e131ac2ded7c24aea594c
-SHA256 (lftp-4.0.5.tar.bz2) = 5c1f94f5780ed3cb51fe00439fbfa4e8b4bd28564c3248cb21f6ee9fd794c473
-SIZE (lftp-4.0.5.tar.bz2) = 1604028
+MD5 (lftp-4.0.5.tar.lzma) = 07803bc69f5f78538e2534a484af174f
+SHA256 (lftp-4.0.5.tar.lzma) = 6492bcc546e16f8fdef92733fddbcde67dc7397b660e26b5168753bb05d15f26
+SIZE (lftp-4.0.5.tar.lzma) = 1239821
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index 58b4f4593c08..3e9184ef2b9e 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -11,11 +11,12 @@ PORTREVISION= 1
CATEGORIES= ftp www ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= wget
+EXTRACT_SUFX= .tar.lzma
MAINTAINER= vd@FreeBSD.org
COMMENT= Retrieve files from the Net via HTTP(S) and FTP
-USE_BZIP2= yes
+USE_XZ= yes
USE_GMAKE= yes
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
diff --git a/ftp/wget/distinfo b/ftp/wget/distinfo
index 96e81f2dae7e..30e92b255932 100644
--- a/ftp/wget/distinfo
+++ b/ftp/wget/distinfo
@@ -1,3 +1,3 @@
-MD5 (wget-1.12.tar.bz2) = 308a5476fc096a8a525d07279a6f6aa3
-SHA256 (wget-1.12.tar.bz2) = c823d938e2f849305a101c0860229b123d7564c26470fdac9118d85e3c7dba9a
-SIZE (wget-1.12.tar.bz2) = 1609032
+MD5 (wget-1.12.tar.lzma) = e6ee1f02df61c6fb8a076be66983090a
+SHA256 (wget-1.12.tar.lzma) = 7426a8c7092f1df1b6b0990c9c049388128fc0ad403752929f972616bfae2715
+SIZE (wget-1.12.tar.lzma) = 1200752
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index e375c2336f25..97fc1e0e2fb8 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -10,15 +10,14 @@ DISTVERSION= 6.6.1-10
CATEGORIES= graphics perl5
MASTER_SITES= ftp://ftp.imagemagick.org/pub/ImageMagick/ \
ftp://ftp.nluug.nl/pub/ImageMagick/ \
- ftp://gd.tuwien.ac.at/pub/graphics/ImageMagick/ \
- SF/${PORTNAME:L}/${PORTNAME}/6.5 \
+ ftp://gd.tuwien.ac.at/pub/graphics/ImageMagick/
MAINTAINER= mm@FreeBSD.org
COMMENT= Image processing tools
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
-USE_BZIP2= yes
+USE_XZ= yes
USE_PERL5= yes
USE_GNOME= gnomehack gnometarget pkgconfig
USE_AUTOTOOLS= libltdl:22
diff --git a/graphics/ImageMagick/distinfo b/graphics/ImageMagick/distinfo
index 5a4d95fc6ba2..64ae214e45d8 100644
--- a/graphics/ImageMagick/distinfo
+++ b/graphics/ImageMagick/distinfo
@@ -1,3 +1,3 @@
-MD5 (ImageMagick-6.6.1-10.tar.bz2) = 97cc92d9e8dd418052cbb2e10bcc4136
-SHA256 (ImageMagick-6.6.1-10.tar.bz2) = 13de315d9c8b5a41e24deb45cde2fbf3e6a2524034307faeb5ce31987d6f0c2a
-SIZE (ImageMagick-6.6.1-10.tar.bz2) = 8801478
+MD5 (ImageMagick-6.6.1-10.tar.xz) = d82e1331362f99790548e3e94777eb81
+SHA256 (ImageMagick-6.6.1-10.tar.xz) = 6d6dec27faca658d8f1c4bf16c480f9855772e91015bf31cd40a294d5ede3b86
+SIZE (ImageMagick-6.6.1-10.tar.xz) = 6255328
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index 9bf2b8ce691e..a566060bd7fc 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -22,7 +22,7 @@ MAKE_FLAGS= ccopts="${CFLAGS}" ldopts="${LDFLAGS}" -f
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
SHLIB_VER= 6
-USE_BZIP2= yes
+USE_XZ= yes
MAKE_ENV= SHLIB_VER="${SHLIB_VER}"
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
diff --git a/graphics/png/distinfo b/graphics/png/distinfo
index 3908238c6e01..20f3fe631c90 100644
--- a/graphics/png/distinfo
+++ b/graphics/png/distinfo
@@ -1,6 +1,6 @@
-MD5 (libpng-1.4.1.tar.bz2) = e1767bf290ded9fda9ee05bd23ae4cff
-SHA256 (libpng-1.4.1.tar.bz2) = bc03009c62c07fc08d1d91ba130c39dc99bef68b533cad4e846835d0bfc4ee5e
-SIZE (libpng-1.4.1.tar.bz2) = 643261
+MD5 (libpng-1.4.1.tar.xz) = d4cb0236cce9ce8ff49a22994a01f9e0
+SHA256 (libpng-1.4.1.tar.xz) = 87b97d19f5460c1e31c22df8896ce98fab1532d57a0ae66b58226f08e4475e71
+SIZE (libpng-1.4.1.tar.xz) = 523000
MD5 (libpng-1.4.1-apng.patch) = f7cfe836d963564bb658eeec610d6086
SHA256 (libpng-1.4.1-apng.patch) = 59d7feed7fd87a77cbd395f63b37759007e8c7cc21a21e8c14e0811a6aa9ed91
SIZE (libpng-1.4.1-apng.patch) = 54364
diff --git a/japanese/font-ume/Makefile b/japanese/font-ume/Makefile
index a69d8284597c..7381f3835f72 100644
--- a/japanese/font-ume/Makefile
+++ b/japanese/font-ume/Makefile
@@ -18,6 +18,7 @@ COMMENT= Ume Japanese TrueType fonts
RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
+USE_XZ= yes
NO_BUILD= yes
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-install
@@ -55,13 +56,4 @@ post-install:
${LOCALBASE}/bin/fc-cache -s -f -v ${LOCALBASE}/${X_FONTSDIR}/TTF
${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
-EXTRACT_DEPENDS+= xz:${PORTSDIR}/archivers/xz
-EXTRACT_CMD= ${LOCALBASE}/bin/xz
-.else
-EXTRACT_CMD= /usr/bin/xz
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/mpfr/Makefile b/math/mpfr/Makefile
index 819bab21ee1e..2c48afba6989 100644
--- a/math/mpfr/Makefile
+++ b/math/mpfr/Makefile
@@ -17,7 +17,7 @@ COMMENT= A library for multiple-precision floating-point computations
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
-USE_BZIP2= yes
+USE_XZ= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gmp=${LOCALBASE}
USE_LDCONFIG= yes
diff --git a/math/mpfr/distinfo b/math/mpfr/distinfo
index a435f4924cdd..f4049e1f6da3 100644
--- a/math/mpfr/distinfo
+++ b/math/mpfr/distinfo
@@ -1,3 +1,3 @@
-MD5 (mpfr/mpfr-2.4.2.tar.bz2) = 89e59fe665e2b3ad44a6789f40b059a0
-SHA256 (mpfr/mpfr-2.4.2.tar.bz2) = c7e75a08a8d49d2082e4caee1591a05d11b9d5627514e678f02d66a124bcf2ba
-SIZE (mpfr/mpfr-2.4.2.tar.bz2) = 1077886
+MD5 (mpfr/mpfr-2.4.2.tar.xz) = f61da10945c3de6962749a5eb70dafd3
+SHA256 (mpfr/mpfr-2.4.2.tar.xz) = d7271bbfbc9ddf387d3919df8318cd7192c67b232919bfa1cb3202d07843da1b
+SIZE (mpfr/mpfr-2.4.2.tar.xz) = 951620
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index c43f2e5ed546..bab45e6cca62 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://www.midnight-commander.org/downloads/ \
${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= utils/file/managers/mc
DISTNAME= ${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .tar.lzma
PATCH_SITES= ${MASTER_SITES}
@@ -26,7 +27,7 @@ BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
USE_GMAKE= yes
USE_GNOME= glib20
USE_PERL5= yes
-USE_BZIP2= yes
+USE_XZ= yes
GNU_CONFIGURE= yes
OPTIONS= SLANG "Build with SLang library" on \
diff --git a/misc/mc/distinfo b/misc/mc/distinfo
index ab7bfccfe5bb..4cfd309ef54a 100644
--- a/misc/mc/distinfo
+++ b/misc/mc/distinfo
@@ -1,3 +1,3 @@
-MD5 (mc-4.7.2.tar.bz2) = 82d0f923f686e462eeb739760f8c45bd
-SHA256 (mc-4.7.2.tar.bz2) = 804f3a789ca66cbd82f971588896b603191a738f27b9532355276ae6e4995c0e
-SIZE (mc-4.7.2.tar.bz2) = 2876328
+MD5 (mc-4.7.2.tar.lzma) = 8e0c477b0c55123942b4b60827a44058
+SHA256 (mc-4.7.2.tar.lzma) = e0884aa1454d57b629db549449b4b4eef9376ec39c414e355c8dea4983f784b0
+SIZE (mc-4.7.2.tar.lzma) = 2100210
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index 58424a2538fd..209eb6863e0b 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -29,6 +29,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME:S,8,,}/fonts/a010013l.pfb:${PORTSDIR}
CONFLICTS= gambc-[0-9]* ghostscript7-[0-9]* ghostscript7-*-[0-9]*
+USE_XZ= yes
USE_GMAKE= yes
WANT_GNOME= yes
USE_LDCONFIG= yes
diff --git a/print/ghostscript8/distinfo b/print/ghostscript8/distinfo
index 83f64e26b6cc..0a4921cc24da 100644
--- a/print/ghostscript8/distinfo
+++ b/print/ghostscript8/distinfo
@@ -1,6 +1,6 @@
-MD5 (ghostscript/ghostscript-8.71.tar.gz) = 51a522a5b4818bd3dc7c1c0e9dd22bad
-SHA256 (ghostscript/ghostscript-8.71.tar.gz) = 2a22e61b0172f271ebb270a9f127bde501eb661c67c8b4943eafbad57d855aae
-SIZE (ghostscript/ghostscript-8.71.tar.gz) = 25240801
+MD5 (ghostscript/ghostscript-8.71.tar.xz) = 5005d68f7395c2bfc4b05c1a60d9b6ba
+SHA256 (ghostscript/ghostscript-8.71.tar.xz) = f48f7370a00f24fce174b147074aca3f6bede82154dd2bf93d24430a62e4de73
+SIZE (ghostscript/ghostscript-8.71.tar.xz) = 15698644
MD5 (ghostscript/epag-3.09.tar.gz) = 63304a6afe44842124d2d880bf24dbe3
SHA256 (ghostscript/epag-3.09.tar.gz) = ad10eca44c781a5851d5a8993dcd95b2e2b99392cbf2c8372a5a658f3b991b3b
SIZE (ghostscript/epag-3.09.tar.gz) = 12858
diff --git a/sysutils/coreutils/Makefile b/sysutils/coreutils/Makefile
index e175d801b258..5e51213414d3 100644
--- a/sysutils/coreutils/Makefile
+++ b/sysutils/coreutils/Makefile
@@ -21,6 +21,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-prefix=g
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+USE_XZ= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
#USE_BISON= yes
diff --git a/sysutils/coreutils/distinfo b/sysutils/coreutils/distinfo
index 4b4a63ed019d..91d76073f639 100644
--- a/sysutils/coreutils/distinfo
+++ b/sysutils/coreutils/distinfo
@@ -1,3 +1,3 @@
-MD5 (coreutils-7.5.tar.gz) = 775351410b7d6879767c3e4563354dc6
-SHA256 (coreutils-7.5.tar.gz) = 341f49b9434f83ca9a8b6c2266813092ef08a5fca25f15dcc1a0ba82fc18c3c1
-SIZE (coreutils-7.5.tar.gz) = 9956013
+MD5 (coreutils-7.5.tar.xz) = ca9219c5b7efa533d552f61a3880f458
+SHA256 (coreutils-7.5.tar.xz) = 9590b921559999c483d3db668b9839fb83c1c7a7a7683a8ceea1f1e54b1e63fd
+SIZE (coreutils-7.5.tar.xz) = 4499412
diff --git a/textproc/gnugrep/Makefile b/textproc/gnugrep/Makefile
index 8fd7e687ed07..b83a38d36674 100644
--- a/textproc/gnugrep/Makefile
+++ b/textproc/gnugrep/Makefile
@@ -30,6 +30,8 @@ OPTIONS= PCRE "Compile with Perl-compatible regex support" off
CONFLICTS= bsd-grep-*
+USE_XZ= yes
+
.include <bsd.port.pre.mk>
CONFIGURE_ARGS+= --disable-nls
diff --git a/textproc/gnugrep/distinfo b/textproc/gnugrep/distinfo
index 3cbff7c030ec..8e326d5a0a0c 100644
--- a/textproc/gnugrep/distinfo
+++ b/textproc/gnugrep/distinfo
@@ -1,3 +1,3 @@
-MD5 (grep-2.6.3.tar.gz) = 3095b57837b312f087c0680559de7f13
-SHA256 (grep-2.6.3.tar.gz) = a340e5d1544d9a964072196be627bad3e434ff7a87f3a57ea15aaccbbea4d666
-SIZE (grep-2.6.3.tar.gz) = 1310620
+MD5 (grep-2.6.3.tar.xz) = 69a3bf508a3f14d12369e0e1c7a92763
+SHA256 (grep-2.6.3.tar.xz) = ba745e2ff297ab225bf870740d35593d402a1d92999cf0d7e56840f10218db7c
+SIZE (grep-2.6.3.tar.xz) = 828640