aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormax <max@FreeBSD.org>1997-11-24 01:02:37 +0800
committermax <max@FreeBSD.org>1997-11-24 01:02:37 +0800
commitf49074e42592cb18661669ccf4ecc237a280dc31 (patch)
tree26835a5d316ae1c8c9d7a740a5499dc4b552c996
parent1bfaa576d7862b1e758a95877e5e41f07e5f8bcb (diff)
downloadfreebsd-ports-gnome-f49074e42592cb18661669ccf4ecc237a280dc31.tar.gz
freebsd-ports-gnome-f49074e42592cb18661669ccf4ecc237a280dc31.tar.zst
freebsd-ports-gnome-f49074e42592cb18661669ccf4ecc237a280dc31.zip
In pre-extract:, check if the make was run by root. If so, abort the
extraction/build as it won't go through the sanity tests afterwards. Copy example files in agent/examples into ${PREFIX}/share/examples/mailagent.
-rw-r--r--mail/mailagent/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/mail/mailagent/Makefile b/mail/mailagent/Makefile
index 55af37e82fa2..864c5a54f2cb 100644
--- a/mail/mailagent/Makefile
+++ b/mail/mailagent/Makefile
@@ -3,7 +3,7 @@
# Date created: 23 Sep 1996
# Whom: Masafumi NAKANE <max@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.19 1997/07/13 18:49:23 max Exp $
+# $Id: Makefile,v 1.20 1997/09/16 01:03:26 max Exp $
#
DISTNAME= mailagent-3.0@58
@@ -38,5 +38,12 @@ pre-extract:
echo "Please set umask to 022 before running make,"; \
echo "or mailagent will not build successfully."; \
false; fi
+ @if [ `id -u` = 0 ]; then \
+ echo "Do not build mailagent as root or it won't pass the sanity tests."; \
+ false; fi
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/examples/mailagent
+ ${INSTALL_DATA} ${WRKSRC}/agent/examples/* ${PREFIX}/share/examples/mailagent
.include <bsd.port.mk>