aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2006-02-14 02:53:33 +0800
committerolgeni <olgeni@FreeBSD.org>2006-02-14 02:53:33 +0800
commitf762667726370bf6dfe27ddb5b820ee0ed188875 (patch)
treefa56b98485c1353bdcc118704bf96f7a1b027b0d
parent4d09d7f727e0ddc7e6d79b04c6e6de53ae1bc80a (diff)
downloadfreebsd-ports-gnome-f762667726370bf6dfe27ddb5b820ee0ed188875.tar.gz
freebsd-ports-gnome-f762667726370bf6dfe27ddb5b820ee0ed188875.tar.zst
freebsd-ports-gnome-f762667726370bf6dfe27ddb5b820ee0ed188875.zip
Upgrade to current bsd.java.mk syntax.
-rw-r--r--java/netbeans/Makefile3
-rw-r--r--java/netbeans61/Makefile3
-rw-r--r--lang/erlang/Makefile4
-rw-r--r--lang/erlang14/Makefile4
4 files changed, 8 insertions, 6 deletions
diff --git a/java/netbeans/Makefile b/java/netbeans/Makefile
index b132e26da7ce..41afc35d98ec 100644
--- a/java/netbeans/Makefile
+++ b/java/netbeans/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= olgeni@FreeBSD.org
COMMENT= A full-featured integrated environment for Java
USE_BZIP2= yes
-USE_JAVA= 1.4+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
NO_BUILD= yes
RESTRICTED= Restrictive license
diff --git a/java/netbeans61/Makefile b/java/netbeans61/Makefile
index b132e26da7ce..41afc35d98ec 100644
--- a/java/netbeans61/Makefile
+++ b/java/netbeans61/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= olgeni@FreeBSD.org
COMMENT= A full-featured integrated environment for Java
USE_BZIP2= yes
-USE_JAVA= 1.4+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
NO_BUILD= yes
RESTRICTED= Restrictive license
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index bd9341cf54e1..1c4c42746adb 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -31,8 +31,8 @@ COMMENT= A functional programming language from Ericsson
# ${JAVA_HOME}/bin is added to the PATH, using the *_ENV macros.
.if !defined(WITHOUT_JAVA)
-USE_JAVA= 1.4+
-JAVA_BUILD= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
# Make sure ${JAVA_HOME}/bin is in the path
CONFIGURE_ENV+= PATH=${PATH}:${JAVA_HOME}/bin
MAKE_ENV+= PATH=${PATH}:${JAVA_HOME}/bin
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index bd9341cf54e1..1c4c42746adb 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -31,8 +31,8 @@ COMMENT= A functional programming language from Ericsson
# ${JAVA_HOME}/bin is added to the PATH, using the *_ENV macros.
.if !defined(WITHOUT_JAVA)
-USE_JAVA= 1.4+
-JAVA_BUILD= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
# Make sure ${JAVA_HOME}/bin is in the path
CONFIGURE_ENV+= PATH=${PATH}:${JAVA_HOME}/bin
MAKE_ENV+= PATH=${PATH}:${JAVA_HOME}/bin