aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2002-10-08 15:14:39 +0800
committerperky <perky@FreeBSD.org>2002-10-08 15:14:39 +0800
commitf802def6275e5237a4c814b23cb1f304c4da2957 (patch)
tree9031bd305ce6c86f05352d6b8837a6ed4799d7ed
parent7473eb02bcc4b4059ae1a64a9813d8e1b345973c (diff)
downloadfreebsd-ports-gnome-f802def6275e5237a4c814b23cb1f304c4da2957.tar.gz
freebsd-ports-gnome-f802def6275e5237a4c814b23cb1f304c4da2957.tar.zst
freebsd-ports-gnome-f802def6275e5237a4c814b23cb1f304c4da2957.zip
Add py-mad 0.3, a Python module that provides the MPEG Audio Decoder interface
-rw-r--r--audio/Makefile1
-rw-r--r--audio/py-mad/Makefile30
-rw-r--r--audio/py-mad/distinfo1
-rw-r--r--audio/py-mad/pkg-comment1
-rw-r--r--audio/py-mad/pkg-descr5
-rw-r--r--audio/py-mad/pkg-plist1
6 files changed, 39 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index f24cae2a4c6a..fb13fd98a313 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -188,6 +188,7 @@
SUBDIR += py-ao
SUBDIR += py-cddb
SUBDIR += py-id3
+ SUBDIR += py-mad
SUBDIR += py-ogg
SUBDIR += py-vorbis
SUBDIR += py-xmms
diff --git a/audio/py-mad/Makefile b/audio/py-mad/Makefile
new file mode 100644
index 000000000000..d7cd16f2286e
--- /dev/null
+++ b/audio/py-mad/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: py-mad
+# Date created: 8 October 2002
+# Whom: Hye-Shik Chang
+#
+# $FreeBSD$
+
+PORTNAME= mad
+PORTVERSION= 0.3
+CATEGORIES= audio python
+MASTER_SITES= http://spacepants.org/src/pymad/download/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pymad-${PORTVERSION}
+
+MAINTAINER= perky@FreeBSD.org
+
+LIB_DEPENDS= mad.1:${PORTSDIR}/audio/mad
+
+USE_REINPLACE= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_PYTHON_PREFIX= yes
+
+post-patch:
+ @${REINPLACE_CMD} 's/^\(.*compile.*\)\?\(.*\)\?\(.*\)$$/\1\2\3/' \
+ ${WRKSRC}/setup.py
+
+do-configure:
+ @cd ${WRKSRC} && ${PYTHON_CMD} config_unix.py --prefix ${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/audio/py-mad/distinfo b/audio/py-mad/distinfo
new file mode 100644
index 000000000000..9e2f77a4baec
--- /dev/null
+++ b/audio/py-mad/distinfo
@@ -0,0 +1 @@
+MD5 (pymad-0.3.tar.gz) = ec7d31f5f56d4277ed92ff97933ccd52
diff --git a/audio/py-mad/pkg-comment b/audio/py-mad/pkg-comment
new file mode 100644
index 000000000000..0539b2137a33
--- /dev/null
+++ b/audio/py-mad/pkg-comment
@@ -0,0 +1 @@
+Python module that provides the MPEG Audio Decoder interface
diff --git a/audio/py-mad/pkg-descr b/audio/py-mad/pkg-descr
new file mode 100644
index 000000000000..dd2f68db6103
--- /dev/null
+++ b/audio/py-mad/pkg-descr
@@ -0,0 +1,5 @@
+This is a Python module that allows Python programs to use the
+MPEG Audio Decoder library. It provides a high-level API which
+makes reading from MPEG audio streams a piece of cake.
+
+WWW: http://spacepants.org/src/pymad/
diff --git a/audio/py-mad/pkg-plist b/audio/py-mad/pkg-plist
new file mode 100644
index 000000000000..4ca08c48426b
--- /dev/null
+++ b/audio/py-mad/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/madmodule.so