aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2008-06-13 16:00:45 +0800
committeritetcu <itetcu@FreeBSD.org>2008-06-13 16:00:45 +0800
commitfe2a58ec882a2187eab1e04ab3e27e6725383d05 (patch)
tree5b062f6bb792d504ed5606c1bfa43c7aad68fc4f
parent7ec1380b06b28045253fe33ca99d54ce206e62d6 (diff)
downloadfreebsd-ports-gnome-fe2a58ec882a2187eab1e04ab3e27e6725383d05.tar.gz
freebsd-ports-gnome-fe2a58ec882a2187eab1e04ab3e27e6725383d05.tar.zst
freebsd-ports-gnome-fe2a58ec882a2187eab1e04ab3e27e6725383d05.zip
- unbreak for -D NOPORTDOCS
- use PORTDOCS and PORTEXAMPLES as it should - install directly useable docs (.ps not .ps.gz) - don't use ``!='' [1] - bump PORTREVISION Submitted by: my QA Tindy run kris@ in a mayl on ports [1]
-rw-r--r--math/bamg/Makefile17
-rw-r--r--math/bamg/pkg-plist58
2 files changed, 38 insertions, 37 deletions
diff --git a/math/bamg/Makefile b/math/bamg/Makefile
index 7d365225d68e..350c29c3e68a 100644
--- a/math/bamg/Makefile
+++ b/math/bamg/Makefile
@@ -7,13 +7,14 @@
PORTNAME= bamg
PORTVERSION= 0.68
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math science
MASTER_SITES= http://pauillac.inria.fr/cdrom/ftp/bamg/ \
http://www-rocq1.inria.fr/gamma/cdrom/ftp/bamg/ \
http://ftp.tuniv.szczecin.pl/pub/Linux/Scilab/INRIA/Gamma/bamg/
-.if !defined(NOPORTDOCS)
-DISTFILES= ${PORTNAME}${EXTRACT_SUFX} ${PORTNAME}.ps.gz
+DISTFILES= ${PORTNAME}${EXTRACT_SUFX}
+.ifndef(NOPORTDOCS)
+DISTFILES+= ${PORTNAME}.ps.gz
EXTRACT_ONLY= ${PORTNAME}${EXTRACT_SUFX}
.endif
@@ -30,17 +31,17 @@ USE_GMAKE= yes
ALL_TARGET= world
INSTALL_TARGET= install-world
-MAKE_ENV= CXX=${CXX} HOSTTYPE=${HOSTTYPE}
-
BINS= bamg bamg-g cvmsh2 drawbdmesh
EXDIRS= NACA012 quadloop square test
.include <bsd.port.pre.mk>
-HOSTTYPE!= ${UNAME} -s
+.pre-configure:
+HOSTTYPE= ${UNAME} -s
+MAKE_ENV= CXX=${CXX} HOSTTYPE=${${HOSTTYPE}}
post-patch:
- @${MV} ${WRKSRC}/FLAG.linux ${WRKSRC}/FLAG.${HOSTTYPE}
+ @${MV} ${WRKSRC}/FLAG.linux ${WRKSRC}/FLAG.${${HOSTTYPE}}
@${MV} ${WRKSRC}/FLAG.linux.orig ${WRKSRC}/FLAG.linux
post-install:
@@ -49,7 +50,7 @@ post-install:
.endfor
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${DISTDIR}/bamg.ps.gz ${DOCSDIR}
+ @${GZCAT} ${DISTDIR}/${PORTNAME}.ps.gz > ${DOCSDIR}/${PORTNAME}.ps
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.for exdir in ${EXDIRS}
@${MKDIR} ${EXAMPLESDIR}/${exdir}
diff --git a/math/bamg/pkg-plist b/math/bamg/pkg-plist
index 9f2f0a511ebf..4ddb61496499 100644
--- a/math/bamg/pkg-plist
+++ b/math/bamg/pkg-plist
@@ -2,33 +2,33 @@ bin/bamg
bin/bamg-g
bin/cvmsh2
bin/drawbdmesh
-%%PORTDOCS%%%%DOCSDIR%%/bamg.ps.gz
-%%PORTDOCS%%%%EXAMPLESDIR%%/NACA012/ad.sh
-%%PORTDOCS%%%%EXAMPLESDIR%%/NACA012/adap.sh
-%%PORTDOCS%%%%EXAMPLESDIR%%/NACA012/adap.sh-g
-%%PORTDOCS%%%%EXAMPLESDIR%%/NACA012/data
-%%PORTDOCS%%%%EXAMPLESDIR%%/NACA012/data-orign
-%%PORTDOCS%%%%EXAMPLESDIR%%/NACA012/naca.awk
-%%PORTDOCS%%%%EXAMPLESDIR%%/NACA012/plot.fv
-%%PORTDOCS%%%%EXAMPLESDIR%%/NACA012/plot.fv-1
-%%PORTDOCS%%%%EXAMPLESDIR%%/quadloop/dotest.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/square/circle_g.msh
-%%PORTDOCS%%%%EXAMPLESDIR%%/square/doadapt
-%%PORTDOCS%%%%EXAMPLESDIR%%/square/dotest
-%%PORTDOCS%%%%EXAMPLESDIR%%/square/l_g.msh
-%%PORTDOCS%%%%EXAMPLESDIR%%/square/octogone_g.msh
-%%PORTDOCS%%%%EXAMPLESDIR%%/square/square_g.msh
-%%PORTDOCS%%%%EXAMPLESDIR%%/square/square_raf_ani_g.mtr
-%%PORTDOCS%%%%EXAMPLESDIR%%/square/square_raf_g.msh
-%%PORTDOCS%%%%EXAMPLESDIR%%/square/square_raf_g.mtr
-%%PORTDOCS%%%%EXAMPLESDIR%%/test/dotest-o.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/test/dotest.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/test/dotest1.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/test/dotest2.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/test/dotest3.pl
+%%PORTDOCS%%%%DOCSDIR%%/bamg.ps
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NACA012/ad.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NACA012/adap.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NACA012/adap.sh-g
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NACA012/data
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NACA012/data-orign
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NACA012/naca.awk
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NACA012/plot.fv
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NACA012/plot.fv-1
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/quadloop/dotest.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/circle_g.msh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/doadapt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/dotest
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/l_g.msh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/octogone_g.msh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/square_g.msh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/square_raf_ani_g.mtr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/square_raf_g.msh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/square_raf_g.mtr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test/dotest-o.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test/dotest.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test/dotest1.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test/dotest2.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test/dotest3.pl
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/NACA012
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/quadloop
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/square
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/test
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/NACA012
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/quadloop
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/square
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/test
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%