aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2015-09-13 12:30:17 +0800
committerhrs <hrs@FreeBSD.org>2015-09-13 12:30:17 +0800
commitff104e2dd34cfa97f3082860c66c46b11c82962d (patch)
treef01f370df4650082e23b3481a1e81386b2418d81
parent6cebe1a105581c8c54b2ca34f0ae4f23a08c17a5 (diff)
downloadfreebsd-ports-gnome-ff104e2dd34cfa97f3082860c66c46b11c82962d.tar.gz
freebsd-ports-gnome-ff104e2dd34cfa97f3082860c66c46b11c82962d.tar.zst
freebsd-ports-gnome-ff104e2dd34cfa97f3082860c66c46b11c82962d.zip
- Rename japanese/marumoji-fonts with japanese/font-marumoji.
- Add LICENSE.
-rw-r--r--MOVED1
-rw-r--r--japanese/Makefile2
-rw-r--r--japanese/font-marumoji/Makefile33
-rw-r--r--japanese/font-marumoji/distinfo2
-rw-r--r--japanese/font-marumoji/files/Makefile.in (renamed from japanese/marumoji-fonts/files/Makefile.in)0
-rw-r--r--japanese/font-marumoji/files/pkg-install.in (renamed from japanese/marumoji-fonts/pkg-install)62
-rw-r--r--japanese/font-marumoji/pkg-descr (renamed from japanese/marumoji-fonts/pkg-descr)0
-rw-r--r--japanese/font-marumoji/pkg-plist (renamed from japanese/marumoji-fonts/pkg-plist)1
-rw-r--r--japanese/marumoji-fonts/Makefile47
-rw-r--r--japanese/marumoji-fonts/distinfo18
-rw-r--r--japanese/marumoji-fonts/files/LICENSE27
-rw-r--r--japanese/marumoji-fonts/pkg-deinstall49
12 files changed, 75 insertions, 167 deletions
diff --git a/MOVED b/MOVED
index 026676e0b47a..543cfca4dd8a 100644
--- a/MOVED
+++ b/MOVED
@@ -7865,3 +7865,4 @@ devel/cloudabi-compiler-rt||2015-09-12|Moved to the CloudABI Ports Collection
devel/cloudabi-libc++||2015-09-12|Moved to the CloudABI Ports Collection
devel/cloudabi-libc++abi||2015-09-12|Moved to the CloudABI Ports Collection
devel/cloudabi-libunwind||2015-09-12|Moved to the CloudABI Ports Collection
+japanese/marumoji-fonts|japanese/font-marumoji|2015-09-13|Renamed
diff --git a/japanese/Makefile b/japanese/Makefile
index 0c550a29b802..aa688049b2e8 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -68,6 +68,7 @@
SUBDIR += font-jisx0213
SUBDIR += font-kochi
SUBDIR += font-koruri
+ SUBDIR += font-marumoji
SUBDIR += font-migmix
SUBDIR += font-migu
SUBDIR += font-mona-ipa
@@ -150,7 +151,6 @@
SUBDIR += mailman
SUBDIR += man
SUBDIR += man-doc
- SUBDIR += marumoji-fonts
SUBDIR += mecab
SUBDIR += mecab-ipadic
SUBDIR += mg
diff --git a/japanese/font-marumoji/Makefile b/japanese/font-marumoji/Makefile
new file mode 100644
index 000000000000..97d0081d87ba
--- /dev/null
+++ b/japanese/font-marumoji/Makefile
@@ -0,0 +1,33 @@
+# Created by: Yoichi NAKAYAMA <yoichi@eken.phys.nagoya-u.ac.jp>
+# $FreeBSD$
+
+PORTNAME= marumoji
+PORTVERSION= 1.0
+PORTREVISION= 8
+CATEGORIES= japanese x11-fonts
+MASTER_SITES= LOCAL/hrs/${PORTNAME}
+PKGNAMEPREFIX= ja-font-
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Japanese marumoji fonts
+
+LICENSE= MIT
+LICENSE_FILES= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= mkbold:${PORTSDIR}/x11-fonts/mkbold-mkitalic \
+ bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf
+
+USES= fonts
+FONTNAME= marumoji
+MAKE_ENV= FONTSDIR=${FONTSDIR:S,${PREFIX},,}
+SUB_FILES= Makefile pkg-install
+PKGINSTALL= ${WRKDIR}/pkg-install
+PKGDEINSTALL= ${WRKDIR}/pkg-install
+
+${WRKSRC}/maru16.bdf:
+ cd ${WRKSRC} && ${SED} -f m18to16.sed < maru18.bdf > maru16.bdf
+
+pre-build: ${WRKSRC}/maru16.bdf apply-slist
+ ${INSTALL_DATA} ${WRKDIR}/Makefile ${WRKSRC}
+
+.include <bsd.port.mk>
diff --git a/japanese/font-marumoji/distinfo b/japanese/font-marumoji/distinfo
new file mode 100644
index 000000000000..6ad1fcf2eb18
--- /dev/null
+++ b/japanese/font-marumoji/distinfo
@@ -0,0 +1,2 @@
+SHA256 (marumoji-1.0.tar.gz) = 458a5fb1a703a06b17e825ddd39b6d74d48fb6d718a8e228581d39751e84dd69
+SIZE (marumoji-1.0.tar.gz) = 455737
diff --git a/japanese/marumoji-fonts/files/Makefile.in b/japanese/font-marumoji/files/Makefile.in
index a5a966153847..a5a966153847 100644
--- a/japanese/marumoji-fonts/files/Makefile.in
+++ b/japanese/font-marumoji/files/Makefile.in
diff --git a/japanese/marumoji-fonts/pkg-install b/japanese/font-marumoji/files/pkg-install.in
index a2e26735679c..c87a4043733a 100644
--- a/japanese/marumoji-fonts/pkg-install
+++ b/japanese/font-marumoji/files/pkg-install.in
@@ -1,24 +1,25 @@
#!/bin/sh
-if [ "$2" != "POST-INSTALL" ]; then
- exit 0
-fi
-
-FONTDIR=${PKG_PREFIX}/share/fonts/marumoji
-
-grepv() {
- awk -v SRC=$1 'BEGIN{while (getline < SRC) {ENTRY[$0]=1}} (ENTRY[$0] != 1) {print}' $2
+catfontsdir ()
+{
+ while read _IN
+ do
+ case "${_IN}" in
+ [0-9]*|*-misc-marumoji-*) ;;
+ *) echo ${_IN} ;;
+ esac
+ done
}
+addentries()
+{
# font alias entry here!
-TMPFILE=/tmp/install-fonts-alias-$$
-cat << EOF > ${TMPFILE}
+cat <<EOF
maru14 -misc-marumoji-medium-r-normal--14-130-75-75-c-140-jisx0208.1983-0
maru16 -misc-marumoji-medium-r-normal--16-150-75-75-c-160-jisx0208.1983-0
maru18 -misc-marumoji-medium-r-normal--18-170-75-75-c-180-jisx0208.1983-0
7x14rkmaru -misc-marumoji-medium-r-normal--14-130-75-75-c-70-jisx0201.1976-0
-7x14maru -misc-marumoji-medium-r-normal--14-130-75-75-c-70-iso8859-1
-8x16rkmr -misc-marumoji-medium-r-normal--16-150-75-75-c-80-jisx0201.1976-0
+7x14maru -misc-marumoji-medium-r-normal--14-130-75-75-c-70-iso8859-1 8x16rkmr -misc-marumoji-medium-r-normal--16-150-75-75-c-80-jisx0201.1976-0
8x16maru -misc-marumoji-medium-r-normal--16-150-75-75-c-80-iso8859-1
9x18rkmr -misc-marumoji-medium-r-normal--18-170-75-75-c-90-jisx0201.1976-0
9x18maru -misc-marumoji-medium-r-normal--18-170-75-75-c-90-iso8859-1
@@ -32,17 +33,30 @@ maru18 -misc-marumoji-medium-r-normal--18-170-75-75-c-180-jisx0208.1983-0
-misc-marumoji-medium-r-normal--18-130-100-100-c-90-jisx0201.1976-0 -misc-marumoji-medium-r-normal--18-170-75-75-c-90-jisx0201.1976-0
-misc-marumoji-medium-r-normal--18-130-100-100-c-180-jisx0208.1983-0 -misc-marumoji-medium-r-normal--18-170-75-75-c-180-jisx0208.1983-0
EOF
+}
-echo "Updating ${FONTDIR}/fonts.alias"
-cd ${FONTDIR}
-touch fonts.alias
-cp fonts.alias fonts.alias.orig
-(grepv ${TMPFILE} fonts.alias.orig ; cat ${TMPFILE}) > fonts.alias
-rm -f fonts.alias.orig ${TMPFILE}
-
-echo "**********************************************************"
-echo "You should restart X server or do 'xset fp rehash' command"
-echo "to enable this update."
-echo "**********************************************************"
+nfonts ()
+{
+ _L=0; while read _IN; do _L=$((${_L}+1)); done; echo ${_L}
+}
-exit 0
+case $2 in
+POST-INSTALL)
+ cd %%FONTSDIR%%
+ touch fonts.dir
+ (catfontsdir < fonts.dir; addentries) > fonts.dir.tmp
+ nfonts < fonts.dir.tmp > fonts.dir
+ cat fonts.dir.tmp >> fonts.dir
+ rm -f fonts.dir.tmp
+;;
+DEINSTALL)
+ cd %%FONTSDIR%%
+ catfontsdir < fonts.dir > fonts.dir.tmp
+ nfonts < fonts.dir.tmp > fonts.dir
+ cat fonts.dir.tmp >> fonts.dir
+ rm -f fonts.dir.tmp
+ if [ -r fonts.dir -a `wc -l < fonts.dir` = 1 ]; then
+ rm -f fonts.dir
+ fi
+;;
+esac
diff --git a/japanese/marumoji-fonts/pkg-descr b/japanese/font-marumoji/pkg-descr
index 764c15ec89a8..764c15ec89a8 100644
--- a/japanese/marumoji-fonts/pkg-descr
+++ b/japanese/font-marumoji/pkg-descr
diff --git a/japanese/marumoji-fonts/pkg-plist b/japanese/font-marumoji/pkg-plist
index 1523006196d4..a872223e39a4 100644
--- a/japanese/marumoji-fonts/pkg-plist
+++ b/japanese/font-marumoji/pkg-plist
@@ -34,4 +34,3 @@
%%FONTSDIR%%/maru18b.pcf.gz
%%FONTSDIR%%/maru18bi.pcf.gz
%%FONTSDIR%%/maru18i.pcf.gz
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE
diff --git a/japanese/marumoji-fonts/Makefile b/japanese/marumoji-fonts/Makefile
deleted file mode 100644
index 4299ce436e04..000000000000
--- a/japanese/marumoji-fonts/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-# Created by: Yoichi NAKAYAMA <yoichi@eken.phys.nagoya-u.ac.jp>
-# $FreeBSD$
-
-PORTNAME= marumoji-fonts
-PORTVERSION= 1.0
-PORTREVISION= 7
-CATEGORIES= japanese x11-fonts
-MASTER_SITES= LOCAL/yoichi
-DISTFILES= maru14.bdf.v13.gz maru18.bdf.v10.gz \
- m18to16.sed \
- 7x14maru.bdf.gz 7x14rkmr.bdf.gz \
- 8x16maru.bdf.gz 8x16rkmr.bdf.gz \
- 9x18maru.bdf.gz 9x18rkmr.bdf.gz
-DIST_SUBDIR= ${PORTNAME}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Japanese marumoji fonts
-
-BUILD_DEPENDS= mkbold:${PORTSDIR}/x11-fonts/mkbold-mkitalic \
- bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf
-
-USES= fonts
-NO_WRKSUBDIR= yes
-FONTNAME= marumoji
-
-EXTRACT_CMD= ${CP}
-EXTRACT_BEFORE_ARGS= -p
-EXTRACT_AFTER_ARGS= ${WRKDIR}
-
-MAKE_ENV= FONTSDIR=${FONTSDIR:S,${PREFIX},,}
-
-OPTIONS_DEFINE= DOCS
-
-post-extract:
- @${MV} ${WRKDIR}/maru14.bdf.v13.gz ${WRKDIR}/maru14.bdf.gz
- @${MV} ${WRKDIR}/maru18.bdf.v10.gz ${WRKDIR}/maru18.bdf.gz
- @${CP} ${FILESDIR}/Makefile.in ${WRKDIR}/Makefile
- @(cd ${WRKDIR}; ${GUNZIP_CMD} *.gz)
-
-pre-build:
- @(cd ${WRKDIR}; ${SED} -f m18to16.sed < maru18.bdf > maru16.bdf)
-
-post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${FILESDIR}/LICENSE ${STAGEDIR}${DOCSDIR}
-
-.include <bsd.port.mk>
diff --git a/japanese/marumoji-fonts/distinfo b/japanese/marumoji-fonts/distinfo
deleted file mode 100644
index 93b7223230ba..000000000000
--- a/japanese/marumoji-fonts/distinfo
+++ /dev/null
@@ -1,18 +0,0 @@
-SHA256 (marumoji-fonts/maru14.bdf.v13.gz) = 0895593347591ca5da1f2b9a88c7d65f828f7c6c4b6d58cedce204584bcad2ef
-SIZE (marumoji-fonts/maru14.bdf.v13.gz) = 202507
-SHA256 (marumoji-fonts/maru18.bdf.v10.gz) = db0ae23d72da63ef8ac1d54af89d9b1b5ac3b20d39170440fb43df6587c12853
-SIZE (marumoji-fonts/maru18.bdf.v10.gz) = 239496
-SHA256 (marumoji-fonts/m18to16.sed) = e7c1550a0380db2c0330e3924e0916a0e3af790f2ba9986724d473a46b892d34
-SIZE (marumoji-fonts/m18to16.sed) = 678
-SHA256 (marumoji-fonts/7x14maru.bdf.gz) = 1da0e488c12bd02005b5a4a4e9b303add563f463d72a9519b81186ab74b3ca3f
-SIZE (marumoji-fonts/7x14maru.bdf.gz) = 1987
-SHA256 (marumoji-fonts/7x14rkmr.bdf.gz) = d0a2fc67a1e9d333161b0c649b656406d032c1ceae678f9bae94318ec55e3633
-SIZE (marumoji-fonts/7x14rkmr.bdf.gz) = 3538
-SHA256 (marumoji-fonts/8x16maru.bdf.gz) = ad6bd8682062abf9b6bddf813657f65d34322c2fb17dfb5fa6e3767a59ac5885
-SIZE (marumoji-fonts/8x16maru.bdf.gz) = 3359
-SHA256 (marumoji-fonts/8x16rkmr.bdf.gz) = 4fa085ca4d1ba46a686d597bae122867b816213da34f3c0688615ea8e56e0432
-SIZE (marumoji-fonts/8x16rkmr.bdf.gz) = 3042
-SHA256 (marumoji-fonts/9x18maru.bdf.gz) = 3f9449c2083ada50c1f9557c3a2a094352bdd035e9343fa23056814fcd19bf23
-SIZE (marumoji-fonts/9x18maru.bdf.gz) = 3368
-SHA256 (marumoji-fonts/9x18rkmr.bdf.gz) = c20573e53336993052b2b3d9e290fb29385f8800f3a61b042a62d21cf6c8fa7b
-SIZE (marumoji-fonts/9x18rkmr.bdf.gz) = 3049
diff --git a/japanese/marumoji-fonts/files/LICENSE b/japanese/marumoji-fonts/files/LICENSE
deleted file mode 100644
index d29075376bfc..000000000000
--- a/japanese/marumoji-fonts/files/LICENSE
+++ /dev/null
@@ -1,27 +0,0 @@
-License agreement for marumoji-fonts port
-
-Copyright notice in 7x14rkmr.bdf.gz is the following (others are
-public domain).
-
-Permission to use, copy, modify, distribute, and sell this
-software and its documentation for any purpose is hereby granted
-without fee, provided that the above copyright notice appear in
-all copies and that both that copyright notice and this permis-
-sion notice appear in supporting documentation, and that the name
-of PFU not be used in advertising or publicity pertaining to dis-
-tribution of the software without specific, written prior permis-
-sion. PFU makes no representations about the suitability of this
-software for any purpose. It is provided "as is" without express
-or implied warranty.
-
-PFU DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, IN-
-CLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
-NO EVENT SHALL PFU BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSE-
-QUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF
-USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLI-
-GENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION
-WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
-
-Original designed by K.Shirakami <shira@pfu.fujitsu.co.jp>
- Ver. 1.1
- freeware
diff --git a/japanese/marumoji-fonts/pkg-deinstall b/japanese/marumoji-fonts/pkg-deinstall
deleted file mode 100644
index ac50c41030af..000000000000
--- a/japanese/marumoji-fonts/pkg-deinstall
+++ /dev/null
@@ -1,49 +0,0 @@
-#!/bin/sh
-
-if [ "$2" != "DEINSTALL" ]; then
- exit 0
-fi
-
-FONTDIR=${PKG_PREFIX}/share/fonts/marumoji
-
-grepv() {
- awk -v SRC=$1 'BEGIN{while (getline < SRC) {ENTRY[$0]=1}} (ENTRY[$0] != 1) {print}' $2
-}
-
-# font alias entry here!
-TMPFILE=/tmp/install-fonts-alias-$$
-cat << EOF > ${TMPFILE}
-maru14 -misc-marumoji-medium-r-normal--14-130-75-75-c-140-jisx0208.1983-0
-maru16 -misc-marumoji-medium-r-normal--16-150-75-75-c-160-jisx0208.1983-0
-maru18 -misc-marumoji-medium-r-normal--18-170-75-75-c-180-jisx0208.1983-0
-7x14rkmaru -misc-marumoji-medium-r-normal--14-130-75-75-c-70-jisx0201.1976-0
-7x14maru -misc-marumoji-medium-r-normal--14-130-75-75-c-70-iso8859-1
-8x16rkmr -misc-marumoji-medium-r-normal--16-150-75-75-c-80-jisx0201.1976-0
-8x16maru -misc-marumoji-medium-r-normal--16-150-75-75-c-80-iso8859-1
-9x18rkmr -misc-marumoji-medium-r-normal--18-170-75-75-c-90-jisx0201.1976-0
-9x18maru -misc-marumoji-medium-r-normal--18-170-75-75-c-90-iso8859-1
--misc-marumoji-medium-r-normal--14-100-100-100-c-70-iso8859-1 -misc-marumoji-medium-r-normal--14-130-75-75-c-70-iso8859-1
--misc-marumoji-medium-r-normal--14-100-100-100-c-70-jisx0201.1976-0 -misc-marumoji-medium-r-normal--14-130-75-75-c-70-jisx0201.1976-0
--misc-marumoji-medium-r-normal--14-100-100-100-c-140-jisx0208.1983-0 -misc-marumoji-medium-r-normal--14-130-75-75-c-140-jisx0208.1983-0
--misc-marumoji-medium-r-normal--16-120-100-100-c-80-iso8859-1 -misc-marumoji-medium-r-normal--16-150-75-75-c-80-iso8859-1
--misc-marumoji-medium-r-normal--16-120-100-100-c-80-jisx0201.1976-0 -misc-marumoji-medium-r-normal--16-150-75-75-c-80-jisx0201.1976-0
--misc-marumoji-medium-r-normal--16-120-100-100-c-160-jisx0208.1983-0 -misc-marumoji-medium-r-normal--16-150-75-75-c-160-jisx0208.1983-0
--misc-marumoji-medium-r-normal--18-130-100-100-c-90-iso8859-1 -misc-marumoji-medium-r-normal--18-170-75-75-c-90-iso8859-1
--misc-marumoji-medium-r-normal--18-130-100-100-c-90-jisx0201.1976-0 -misc-marumoji-medium-r-normal--18-170-75-75-c-90-jisx0201.1976-0
--misc-marumoji-medium-r-normal--18-130-100-100-c-180-jisx0208.1983-0 -misc-marumoji-medium-r-normal--18-170-75-75-c-180-jisx0208.1983-0
-EOF
-
-echo "Updating ${FONTDIR}/fonts.alias"
-cd ${FONTDIR}
-touch fonts.alias
-cp fonts.alias fonts.alias.orig
-grepv ${TMPFILE} fonts.alias.orig > fonts.alias
-if [ ! -s fonts.alias ]; then rm -f fonts.alias; fi
-rm -f fonts.alias.orig ${TMPFILE}
-
-echo "**********************************************************"
-echo "You should restart X server or do 'xset fp rehash' command"
-echo "to enable this update."
-echo "**********************************************************"
-
-exit 0