aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-10-06 09:03:46 +0800
committeralepulver <alepulver@FreeBSD.org>2006-10-06 09:03:46 +0800
commit0614898693fd76af3d083997ef6c58d36b8dc7e0 (patch)
treedf58c4d440d260723a594b2a7d615dd10ac8cc84
parentb98947757de0d4fe73235395d1355bd518e10c95 (diff)
downloadfreebsd-ports-gnome-0614898693fd76af3d083997ef6c58d36b8dc7e0.tar.gz
freebsd-ports-gnome-0614898693fd76af3d083997ef6c58d36b8dc7e0.tar.zst
freebsd-ports-gnome-0614898693fd76af3d083997ef6c58d36b8dc7e0.zip
This module offers an interface to PayPal's transaction system.
PR: ports/103817 Submitted by: Steven Kreuzer
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Business-PayPal/Makefile33
-rw-r--r--www/p5-Business-PayPal/distinfo3
-rw-r--r--www/p5-Business-PayPal/pkg-descr1
-rw-r--r--www/p5-Business-PayPal/pkg-plist6
5 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e59d8151a4ae..06a43553a460 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -496,6 +496,7 @@
SUBDIR += p5-Bigtop
SUBDIR += p5-Bundle-Slash
SUBDIR += p5-Bundle-Sledge
+ SUBDIR += p5-Business-PayPal
SUBDIR += p5-CGI-Ajax
SUBDIR += p5-CGI-Application
SUBDIR += p5-CGI-Application-Plugin-DBH
diff --git a/www/p5-Business-PayPal/Makefile b/www/p5-Business-PayPal/Makefile
new file mode 100644
index 000000000000..3f0f18bfee6c
--- /dev/null
+++ b/www/p5-Business-PayPal/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Business-PayPal
+# Date created: Fri 29 Sep 2006
+# Whom: Steven Kreuzer
+#
+# $FreeBSD$
+#
+
+PORTNAME= Business-PayPal
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Business
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skreuzer@f2o.org
+COMMENT= Perl extension for automating PayPal transactions
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Business::PayPal.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Business-PayPal/distinfo b/www/p5-Business-PayPal/distinfo
new file mode 100644
index 000000000000..f3a0472b9feb
--- /dev/null
+++ b/www/p5-Business-PayPal/distinfo
@@ -0,0 +1,3 @@
+MD5 (Business-PayPal-0.02.tar.gz) = efc5b537076f5ade7338211ac5935ab1
+SHA256 (Business-PayPal-0.02.tar.gz) = d61917e20a6afd4304ace0ad13fb3cc36c0fc6bc1f16da7ae54609bbcf78315f
+SIZE (Business-PayPal-0.02.tar.gz) = 7905
diff --git a/www/p5-Business-PayPal/pkg-descr b/www/p5-Business-PayPal/pkg-descr
new file mode 100644
index 000000000000..8e5e12edd39c
--- /dev/null
+++ b/www/p5-Business-PayPal/pkg-descr
@@ -0,0 +1 @@
+This module offers an interface to PayPal's transaction system.
diff --git a/www/p5-Business-PayPal/pkg-plist b/www/p5-Business-PayPal/pkg-plist
new file mode 100644
index 000000000000..349ab6182c33
--- /dev/null
+++ b/www/p5-Business-PayPal/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Business/PayPal.pm
+%%SITE_PERL%%/Business/getppcert.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/PayPal/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/PayPal
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business
+@dirrm %%SITE_PERL%%/Business