aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-10-09 04:36:55 +0800
committermiwi <miwi@FreeBSD.org>2007-10-09 04:36:55 +0800
commit08cf000ab4d2c14702a373c010b9b842486a026e (patch)
tree5e3089e689c3f66d9465ffed1a915894efa4254a
parent594423301537572a775de51b297201af55b4e4ab (diff)
downloadfreebsd-ports-gnome-08cf000ab4d2c14702a373c010b9b842486a026e.tar.gz
freebsd-ports-gnome-08cf000ab4d2c14702a373c010b9b842486a026e.tar.zst
freebsd-ports-gnome-08cf000ab4d2c14702a373c010b9b842486a026e.zip
- Add OPTIONS handling
PR: 116451 Submitted by: volker@vwsoft.com Approved by: maintainer
-rw-r--r--audio/asunder/Makefile21
1 files changed, 20 insertions, 1 deletions
diff --git a/audio/asunder/Makefile b/audio/asunder/Makefile
index 88844c18f2b6..1b489ed74d2f 100644
--- a/audio/asunder/Makefile
+++ b/audio/asunder/Makefile
@@ -6,6 +6,7 @@
PORTNAME= asunder
PORTVERSION= 0.8.1
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://littlesvr.ca/asunder/releases/
@@ -15,8 +16,26 @@ COMMENT= A lightweight GTK+ CD ripper
LIB_DEPENDS= cddb.4:${PORTSDIR}/audio/libcddb
RUN_DEPENDS= ${LOCALBASE}/bin/cdparanoia:${PORTSDIR}/audio/cdparanoia
+OPTIONS= LAME "lame support" on \
+ OGG "ogg-vorbis support" on \
+ FLAC "FLAC support" on
+
GNU_CONFIGURE= yes
USE_XLIB= yes
USE_GNOME= gtk20
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_LAME)
+RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
+.endif
+
+.if defined(WITH_OGG)
+RUN_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
+.endif
+
+.if defined(WITH_FLAC)
+RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
+.endif
+
+.include <bsd.port.post.mk>