aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortrhodes <trhodes@FreeBSD.org>2006-01-04 04:17:12 +0800
committertrhodes <trhodes@FreeBSD.org>2006-01-04 04:17:12 +0800
commit0a16fde24a17e2e6aefa3ea157007145fc0df0d6 (patch)
treea827a761c0fb90104cdb800fd812662dc7097ab3
parentf961284a4180c3fc3a5da632cda59662267b27a6 (diff)
downloadfreebsd-ports-gnome-0a16fde24a17e2e6aefa3ea157007145fc0df0d6.tar.gz
freebsd-ports-gnome-0a16fde24a17e2e6aefa3ea157007145fc0df0d6.tar.zst
freebsd-ports-gnome-0a16fde24a17e2e6aefa3ea157007145fc0df0d6.zip
Fix build.
Requested by: kris
-rw-r--r--comms/hcidump/Makefile4
-rw-r--r--comms/hcidump/files/timet.patch19
2 files changed, 23 insertions, 0 deletions
diff --git a/comms/hcidump/Makefile b/comms/hcidump/Makefile
index 5bd014e94218..89b6a8929c42 100644
--- a/comms/hcidump/Makefile
+++ b/comms/hcidump/Makefile
@@ -30,4 +30,8 @@ IGNORE= it needs Bluetooth stack (FreeBSD 5.2 or newer)
ONLY_FOR_ARCHS= i386
.endif
+.if ${OSVERSION} <= 700011
+EXTRA_PATCHES= files/timet.patch
+.endif
+
.include <bsd.port.post.mk>
diff --git a/comms/hcidump/files/timet.patch b/comms/hcidump/files/timet.patch
new file mode 100644
index 000000000000..ed96df401261
--- /dev/null
+++ b/comms/hcidump/files/timet.patch
@@ -0,0 +1,19 @@
+--- parser/parser.c Fri Sep 12 19:38:11 2003
++++ parser/parser.c Tue Jan 3 15:09:30 2006
+@@ -29,6 +29,7 @@
+ #include <ctype.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <inttypes.h>
+
+ #include "parser.h"
+
+@@ -65,7 +66,7 @@
+
+ if (!parser.state) {
+ if (parser.flags & DUMP_TSTAMP)
+- printf("%8lu.%06lu ", f->ts.tv_sec, f->ts.tv_usec);
++ printf("%8jd.%06lu ", (intmax_t)f->ts.tv_sec, f->ts.tv_usec);
+ printf("%c ", (f->in ? '>' : '<'));
+ parser.state = 1;
+ } else