aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2002-03-24 08:25:07 +0800
committerpetef <petef@FreeBSD.org>2002-03-24 08:25:07 +0800
commit118b4892656af14a7d0bd224a1d97199349fb5b4 (patch)
tree46dcbbb78531bd336a6552a1e265a8f75139f36d
parentd5b3b83035fc8eb89dc9c2e17ad24b03130e7964 (diff)
downloadfreebsd-ports-gnome-118b4892656af14a7d0bd224a1d97199349fb5b4.tar.gz
freebsd-ports-gnome-118b4892656af14a7d0bd224a1d97199349fb5b4.tar.zst
freebsd-ports-gnome-118b4892656af14a7d0bd224a1d97199349fb5b4.zip
Don't clobber the system strcasestr().
Submitted by: bento
-rw-r--r--www/asp2php/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/www/asp2php/Makefile b/www/asp2php/Makefile
index 385def7877cd..6d6f94476801 100644
--- a/www/asp2php/Makefile
+++ b/www/asp2php/Makefile
@@ -28,6 +28,10 @@ PLIST_SUB+= WANT_GTK=""
PLIST_SUB+= WANT_GTK="@comment "
.endif
+post-patch:
+ @${PERL} -pi -e 's,strcasestr,strcasestr_,' ${WRKSRC}/functions.h \
+ ${WRKSRC}/general.c
+
pre-build:
${PERL} -pi -e "s:gtk-config:${GTK_CONFIG}:g" ${WRKSRC}/Makefile