aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2007-02-15 18:07:32 +0800
committerijliao <ijliao@FreeBSD.org>2007-02-15 18:07:32 +0800
commit11f6d7ee4749a5045e835bca58181fedef113f23 (patch)
tree5598792fcc018c2a01378528029cd7dfab4e7cc6
parent1cd5b661507c893a0a97117efdef33d6f493cec6 (diff)
downloadfreebsd-ports-gnome-11f6d7ee4749a5045e835bca58181fedef113f23.tar.gz
freebsd-ports-gnome-11f6d7ee4749a5045e835bca58181fedef113f23.tar.zst
freebsd-ports-gnome-11f6d7ee4749a5045e835bca58181fedef113f23.zip
add winpdb 1.0.8
An advanced Python debugger
-rw-r--r--devel/Makefile1
-rw-r--r--devel/winpdb/Makefile29
-rw-r--r--devel/winpdb/distinfo3
-rw-r--r--devel/winpdb/pkg-descr5
-rw-r--r--devel/winpdb/pkg-plist8
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 271e05375d14..15d0f003f92a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2089,6 +2089,7 @@
SUBDIR += websvn
SUBDIR += wfut
SUBDIR += wininfo
+ SUBDIR += winpdb
SUBDIR += wizardkit
SUBDIR += wxGlade
SUBDIR += wxGlade-devel
diff --git a/devel/winpdb/Makefile b/devel/winpdb/Makefile
new file mode 100644
index 000000000000..68ea14678a90
--- /dev/null
+++ b/devel/winpdb/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: winpdb
+# Date created: Feb 15, 2007
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= winpdb
+PORTVERSION= 1.0.8
+CATEGORIES= devel python
+MASTER_SITES= SF
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= An advanced Python debugger
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_WX= 2.6
+WX_COMPS= python
+
+post-install:
+.for file in rpdb2 winpdb
+ @${MV} -f ${PREFIX}/bin/_${file}.py ${PREFIX}/bin/${file}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/winpdb/distinfo b/devel/winpdb/distinfo
new file mode 100644
index 000000000000..47a72d448d06
--- /dev/null
+++ b/devel/winpdb/distinfo
@@ -0,0 +1,3 @@
+MD5 (winpdb-1.0.8.tar.gz) = f9e0a551e152e6c9dbfca0e59a684f43
+SHA256 (winpdb-1.0.8.tar.gz) = 27d4919483f1aafa606f344c44d41da4f3e83fbb007113899bbc498a8d2dc388
+SIZE (winpdb-1.0.8.tar.gz) = 81011
diff --git a/devel/winpdb/pkg-descr b/devel/winpdb/pkg-descr
new file mode 100644
index 000000000000..9c9e41186fd8
--- /dev/null
+++ b/devel/winpdb/pkg-descr
@@ -0,0 +1,5 @@
+Winpdb is a GPL python debugger, with support for smart breakpoints, multiple
+threads, namespace modification, embedded debugging, password encrypted
+communication and speed of up to 20 times that of pdb.
+
+WWW: http://winpdb.sourceforge.net/
diff --git a/devel/winpdb/pkg-plist b/devel/winpdb/pkg-plist
new file mode 100644
index 000000000000..966f276671f8
--- /dev/null
+++ b/devel/winpdb/pkg-plist
@@ -0,0 +1,8 @@
+bin/rpdb2
+bin/winpdb
+%%PYTHON_SITELIBDIR%%/rpdb2.py
+%%PYTHON_SITELIBDIR%%/rpdb2.pyc
+%%PYTHON_SITELIBDIR%%/rpdb2.pyo
+%%PYTHON_SITELIBDIR%%/winpdb.py
+%%PYTHON_SITELIBDIR%%/winpdb.pyc
+%%PYTHON_SITELIBDIR%%/winpdb.pyo