aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2007-10-10 01:51:23 +0800
committerflz <flz@FreeBSD.org>2007-10-10 01:51:23 +0800
commit17c251b945d079b05e0d0ce2172e3afb26c7de6c (patch)
treebec0af5af03bfc8cd053c3ec99f7f40e9fd4cd48
parent1568615f2e8faa5906d6a6333e2552243579620d (diff)
downloadfreebsd-ports-gnome-17c251b945d079b05e0d0ce2172e3afb26c7de6c.tar.gz
freebsd-ports-gnome-17c251b945d079b05e0d0ce2172e3afb26c7de6c.tar.zst
freebsd-ports-gnome-17c251b945d079b05e0d0ce2172e3afb26c7de6c.zip
Add xf86-video-openchrome 0.2.6, an alternative driver for VIA chipsets.
Tested by: garga
-rw-r--r--x11-drivers/Makefile1
-rw-r--r--x11-drivers/xf86-video-openchrome/Makefile33
-rw-r--r--x11-drivers/xf86-video-openchrome/distinfo3
-rw-r--r--x11-drivers/xf86-video-openchrome/files/patch-man_Makefile.am29
-rw-r--r--x11-drivers/xf86-video-openchrome/pkg-descr4
-rw-r--r--x11-drivers/xf86-video-openchrome/pkg-plist11
6 files changed, 81 insertions, 0 deletions
diff --git a/x11-drivers/Makefile b/x11-drivers/Makefile
index 955ae6c6cef7..14c3c3f55f10 100644
--- a/x11-drivers/Makefile
+++ b/x11-drivers/Makefile
@@ -48,6 +48,7 @@
SUBDIR += xf86-video-newport
SUBDIR += xf86-video-nsc
SUBDIR += xf86-video-nv
+ SUBDIR += xf86-video-openchrome
SUBDIR += xf86-video-rendition
SUBDIR += xf86-video-s3
SUBDIR += xf86-video-s3virge
diff --git a/x11-drivers/xf86-video-openchrome/Makefile b/x11-drivers/xf86-video-openchrome/Makefile
new file mode 100644
index 000000000000..2e4e98c131e6
--- /dev/null
+++ b/x11-drivers/xf86-video-openchrome/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: xf86-video-openchrome
+# Date Created: 17 Sep 2007
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xf86-video-openchrome
+PORTVERSION= 0.2.6
+CATEGORIES= x11-drivers
+MASTER_SITES= http://archive.ubuntu.com/ubuntu/pool/main/x/xserver-xorg-video-openchrome/
+DISTFILES= xserver-xorg-video-openchrome_${PORTVERSION}+svn357.orig.tar.gz
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X.Org openchrome display driver
+
+CONFLICTS= xf86-video-via-[0-9]*
+
+USE_TGZ= yes
+WRKSRC= ${WRKDIR}/xserver-xorg-video-openchrome
+NOMANCOMPRESS= yes
+
+USE_AUTOTOOLS= autoconf:261:env automake:19:env libtool:15:env
+
+XORG_CAT= driver
+USE_GL= gl
+USE_XORG= xvmc xf86driproto glproto
+MAN4= via.4x
+
+pre-configure:
+ @(cd ${WRKSRC} && ${SH} ./autogen.sh)
+
+.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-video-openchrome/distinfo b/x11-drivers/xf86-video-openchrome/distinfo
new file mode 100644
index 000000000000..7dbc7ced549a
--- /dev/null
+++ b/x11-drivers/xf86-video-openchrome/distinfo
@@ -0,0 +1,3 @@
+MD5 (xorg/driver/xserver-xorg-video-openchrome_0.2.6+svn357.orig.tar.gz) = 46bfb583347ee294a8c2c7bb2180d5a1
+SHA256 (xorg/driver/xserver-xorg-video-openchrome_0.2.6+svn357.orig.tar.gz) = 5425a7a315111baa88f801a97450a5e9f9a104305a5e07331645d55ac447795e
+SIZE (xorg/driver/xserver-xorg-video-openchrome_0.2.6+svn357.orig.tar.gz) = 249450
diff --git a/x11-drivers/xf86-video-openchrome/files/patch-man_Makefile.am b/x11-drivers/xf86-video-openchrome/files/patch-man_Makefile.am
new file mode 100644
index 000000000000..e1a7455c227a
--- /dev/null
+++ b/x11-drivers/xf86-video-openchrome/files/patch-man_Makefile.am
@@ -0,0 +1,29 @@
+--- man/Makefile.am.orig Tue Oct 9 19:01:32 2007
++++ man/Makefile.am Tue Oct 9 19:02:32 2007
+@@ -29,7 +29,7 @@
+
+ driverman_MANFILES = @DRIVER_NAME@.man
+
+-driverman_DATA = $(driverman_MANFILES:man=@DRIVER_MAN_SUFFIX@)
++driverman_DATA = $(driverman_MANFILES:man=@DRIVER_MAN_SUFFIX@x)
+
+ EXTRA_DIST = @DRIVER_NAME@.man
+
+@@ -48,14 +48,14 @@
+ -e 's|__xconfigfile__|xorg.conf|g' \
+ -e 's|__projectroot__|$(prefix)|g' \
+ -e 's|__appmansuffix__|$(APP_MAN_SUFFIX)|g' \
+- -e 's|__drivermansuffix__|$(DRIVER_MAN_SUFFIX)|g' \
++ -e 's|__drivermansuffix__|$(DRIVER_MAN_SUFFIX)x|g' \
+ -e 's|__adminmansuffix__|$(ADMIN_MAN_SUFFIX)|g' \
+ -e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g' \
+ -e 's|__filemansuffix__|$(FILE_MAN_SUFFIX)|g'
+
+-SUFFIXES = .$(DRIVER_MAN_SUFFIX) .man
++SUFFIXES = .$(DRIVER_MAN_SUFFIX)x .man
+
+-.man.$(DRIVER_MAN_SUFFIX):
++.man.$(DRIVER_MAN_SUFFIX)x:
+ sed $(MAN_SUBSTS) < $< > $@
+
+ @DRIVER_NAME@.man:
diff --git a/x11-drivers/xf86-video-openchrome/pkg-descr b/x11-drivers/xf86-video-openchrome/pkg-descr
new file mode 100644
index 000000000000..c0a747403333
--- /dev/null
+++ b/x11-drivers/xf86-video-openchrome/pkg-descr
@@ -0,0 +1,4 @@
+This package contains the X.Org xf86-video-openchrome driver.
+
+- Florent Thoumie
+flz@FreeBSD.org
diff --git a/x11-drivers/xf86-video-openchrome/pkg-plist b/x11-drivers/xf86-video-openchrome/pkg-plist
new file mode 100644
index 000000000000..06c919d0743b
--- /dev/null
+++ b/x11-drivers/xf86-video-openchrome/pkg-plist
@@ -0,0 +1,11 @@
+lib/libviaXvMC.la
+lib/libviaXvMC.so
+lib/libviaXvMC.so.1
+lib/libviaXvMCPro.la
+lib/libviaXvMCPro.so
+lib/libviaXvMCPro.so.1
+lib/xorg/modules/drivers/via_drv.la
+lib/xorg/modules/drivers/via_drv.so
+@dirrmtry lib/xorg/modules/drivers
+@dirrmtry lib/xorg/modules
+@dirrmtry lib/xorg