aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2013-06-14 04:41:01 +0800
committerhrs <hrs@FreeBSD.org>2013-06-14 04:41:01 +0800
commit184b1aa9007659c99eee1815e28c65693ac51f89 (patch)
tree991e48756c6bf41b401ca7d13d83d116231752ce
parenta994f801cbc40c4a7ad5789810789bb9d7476a0c (diff)
downloadfreebsd-ports-gnome-184b1aa9007659c99eee1815e28c65693ac51f89.tar.gz
freebsd-ports-gnome-184b1aa9007659c99eee1815e28c65693ac51f89.tar.zst
freebsd-ports-gnome-184b1aa9007659c99eee1815e28c65693ac51f89.zip
Update to 1.3.4.
-rw-r--r--security/ipv6toolkit/Makefile23
-rw-r--r--security/ipv6toolkit/distinfo4
-rw-r--r--security/ipv6toolkit/files/BSDMakefile.in22
-rw-r--r--security/ipv6toolkit/files/Makefile.in16
-rw-r--r--security/ipv6toolkit/files/patch-Makefile51
-rw-r--r--security/ipv6toolkit/pkg-descr2
6 files changed, 60 insertions, 58 deletions
diff --git a/security/ipv6toolkit/Makefile b/security/ipv6toolkit/Makefile
index 594420722513..33c3192e5885 100644
--- a/security/ipv6toolkit/Makefile
+++ b/security/ipv6toolkit/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= ipv6toolkit
-PORTVERSION= 1.3.1
+PORTVERSION= 1.3.4
CATEGORIES= security ipv6
MASTER_SITES= http://www.si6networks.com/tools/ipv6toolkit/
DISTNAME= ipv6-toolkit-v${PORTVERSION}
@@ -13,16 +13,31 @@ LICENSE= GPLv3
MAKE_ENV= DATADIR=${DATADIR}
MAKE_JOBS_SAFE= yes
+SUB_FILES= BSDMakefile Makefile
+MAKEFILE= BSDMakefile
PORTDOCS= README.TXT
-MAN1= flow6.1 frag6.1 icmp6.1 jumbos6.1 na6.1 ni6.1 ns6.1 ra6.1 \
+MAN1= flow6.1 frag6.1 icmp6.1 jumbo6.1 na6.1 ni6.1 ns6.1 ra6.1 \
rd6.1 rs6.1 scan6.1 tcp6.1
MAN5= ipv6toolkit.conf.5
-post-patch:
+PROGDIRS= address6 flow6 frag6 icmp6 jumbo6 na6 ni6 ns6 ra6 rd6 rs6 scan6 tcp6
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+post-extract:
+ @cd ${WRKSRC} && ${MKDIR} ${PROGDIRS}
+
+post-patch: apply-slist
${REINPLACE_CMD} -e 's,%%DATADIR%%,${DATADIR},' \
${WRKSRC}/data/ipv6toolkit.conf
+ ${INSTALL_DATA} ${WRKDIR}/BSDMakefile ${WRKSRC}
+ for D in ${PROGDIRS}; do \
+ ${INSTALL_DATA} ${WRKDIR}/Makefile ${WRKSRC}/$$D; \
+ done
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.TXT ${DOCSDIR}
diff --git a/security/ipv6toolkit/distinfo b/security/ipv6toolkit/distinfo
index 63690df40291..7473572e3467 100644
--- a/security/ipv6toolkit/distinfo
+++ b/security/ipv6toolkit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ipv6-toolkit-v1.3.1.tar.gz) = e7c6b239ea4b6f111af897a6dd1fa2ccf97d939addad5a687d87ebf677305212
-SIZE (ipv6-toolkit-v1.3.1.tar.gz) = 2917946
+SHA256 (ipv6-toolkit-v1.3.4.tar.gz) = 75ff27cd30407cd57f35a7646b82e6fede9cfc7e1fac089b3da43e547424af48
+SIZE (ipv6-toolkit-v1.3.4.tar.gz) = 1052088
diff --git a/security/ipv6toolkit/files/BSDMakefile.in b/security/ipv6toolkit/files/BSDMakefile.in
new file mode 100644
index 000000000000..224fb9ce8bfa
--- /dev/null
+++ b/security/ipv6toolkit/files/BSDMakefile.in
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+SUBDIR= address6 flow6 frag6 icmp6 jumbo6 na6 ni6 ns6 ra6 rd6 rs6 scan6 tcp6
+
+.PATH: ${.CURDIR}/manuals
+
+FILESGROUPS= CONF DB
+CONF= data/ipv6toolkit.conf
+CONFDIR?= ${PREFIX}/etc
+DB= data/oui.txt
+DBDIR?= ${PREFIX}/share/ipv6toolkit
+
+PREFIX?= /usr/local
+MANDIR?= ${PREFIX}/man/man
+MAN= ipv6toolkit.conf.5
+NO_MANCOMPRESS=
+
+beforeinstall:
+ install -d -m 0555 ${DBDIR}
+afterinstall: installfiles maninstall
+
+.include <bsd.prog.mk>
diff --git a/security/ipv6toolkit/files/Makefile.in b/security/ipv6toolkit/files/Makefile.in
new file mode 100644
index 000000000000..d1d4a132a3f1
--- /dev/null
+++ b/security/ipv6toolkit/files/Makefile.in
@@ -0,0 +1,16 @@
+# $FreeBSD$
+
+PREFIX?= /usr/local
+LOCALBASE?= /usr/local
+BINDIR?= ${PREFIX}/bin
+MANDIR?= ${PREFIX}/man/man
+NO_MANCOMPRESS=
+
+.PATH: ${.CURDIR}/../tools ${.CURDIR}/../manuals
+
+PROG= ${.CURDIR:T}
+MAN= ${PROG}.1
+LDADD= -lpcap -lm
+CFLAGS+= -DIPV6TOOLKITCONF=\"${PREFIX}/etc/ipv6toolkit.conf\"
+
+.include <bsd.prog.mk>
diff --git a/security/ipv6toolkit/files/patch-Makefile b/security/ipv6toolkit/files/patch-Makefile
deleted file mode 100644
index d32b04c204b1..000000000000
--- a/security/ipv6toolkit/files/patch-Makefile
+++ /dev/null
@@ -1,51 +0,0 @@
---- Makefile.orig 2013-02-16 18:15:13.000000000 +0900
-+++ Makefile 2013-02-18 01:36:14.000000000 +0900
-@@ -1,12 +1,14 @@
-+# $FreeBSD$
-+
- #
- # SI6 Networks' IPv6 toolkit Makefile
- #
--CC= gcc
--CFLAGS= -Wall
-+CC?= gcc
-+CFLAGS+= -Wall -DIPV6TOOLKITCONF=\"${PREFIX}/etc/ipv6toolkit.conf\"
- LDFLAGS+= -lpcap -lm
--MANPATH= /usr/share/man
--DATAPATH= /usr/share
--BINPATH= /usr/bin
-+MANPATH= ${MANPREFIX}/man
-+DATAPATH= ${DATADIR}
-+BINPATH= ${PREFIX}/bin
- SRCPATH= tools
- TOOLS= flow6 frag6 icmp6 jumbo6 na6 ni6 ns6 ra6 rd6 rs6 scan6 tcp6
-
-@@ -51,21 +53,21 @@
- clean:
- -rm -f $(TOOLS)
-
--install: all
-+install:
- # Install the binaries
- install -m0755 -d $(BINPATH)
-- install -m0755 $(TOOLS) $(BINPATH)
-+ ${BSD_INSTALL_PROGRAM} $(TOOLS) $(BINPATH)
-
- # Install the configuration file
-- install -m0644 data/ipv6toolkit.conf /etc
-+ ${BSD_INSTALL_DATA} data/ipv6toolkit.conf ${PREFIX}/etc
-
- # Install the IEEE OUI database
-- install -m0755 -d $(DATAPATH)/ipv6toolkit
-- install -m0644 data/oui.txt $(DATAPATH)/ipv6toolkit
-+ install -m0755 -d $(DATAPATH)
-+ ${BSD_INSTALL_DATA} -m0644 data/oui.txt $(DATAPATH)
-
- # Install the manual pages
- install -m0755 -d $(MANPATH)/man1
-- install -m0644 manuals/*.1 $(MANPATH)/man1
-+ ${BSD_INSTALL_MAN} manuals/*.1 $(MANPATH)/man1
- install -m0755 -d $(MANPATH)/man5
-- install -m0644 manuals/*.5 $(MANPATH)/man1
-+ ${BSD_INSTALL_MAN} -m0644 manuals/*.5 $(MANPATH)/man5
-
diff --git a/security/ipv6toolkit/pkg-descr b/security/ipv6toolkit/pkg-descr
index e5dcde600be7..75d70239d73f 100644
--- a/security/ipv6toolkit/pkg-descr
+++ b/security/ipv6toolkit/pkg-descr
@@ -1,4 +1,4 @@
The IPv6 toolkit is a portable IPv6 security assessment suite produced
by Fernando Gont on behalf of the UK CPNI.
-WWW: http://www.si6networks.com/tools/ipv6toolkit/
+WWW: http://www.si6networks.com/tools/ipv6toolkit/