aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-04-26 07:46:27 +0800
committerbapt <bapt@FreeBSD.org>2014-04-26 07:46:27 +0800
commit202047fdee9f5fb87992d6626f4188af3ae33544 (patch)
treefe65d882139e5d04a64964441739697943e9c3c8
parent45d27a08938bd1b374af1e9c30944e889a3fb42e (diff)
downloadfreebsd-ports-gnome-202047fdee9f5fb87992d6626f4188af3ae33544.tar.gz
freebsd-ports-gnome-202047fdee9f5fb87992d6626f4188af3ae33544.tar.zst
freebsd-ports-gnome-202047fdee9f5fb87992d6626f4188af3ae33544.zip
Stagify brasero
Convert to USES=libtool Chase shlib number change Clean up a bit chased ports
-rw-r--r--audio/goobox/Makefile18
-rw-r--r--audio/rhythmbox/Makefile2
-rw-r--r--audio/sound-juicer/Makefile6
-rw-r--r--audio/sound-juicer/pkg-plist2
-rw-r--r--sysutils/brasero/Makefile21
-rw-r--r--sysutils/brasero/pkg-plist37
-rw-r--r--x11-toolkits/py-gnome-desktop/Makefile2
7 files changed, 28 insertions, 60 deletions
diff --git a/audio/goobox/Makefile b/audio/goobox/Makefile
index be3729d88203..3e0037d8e13a 100644
--- a/audio/goobox/Makefile
+++ b/audio/goobox/Makefile
@@ -4,7 +4,7 @@
PORTNAME= goobox
PORTVERSION= 2.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -20,28 +20,22 @@ LIB_DEPENDS= libdiscid.so:${PORTSDIR}/audio/libdiscid \
RUN_DEPENDS= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme
USE_XORG= x11
-USES= gettext gmake pkgconfig
-USE_BZIP2= yes
-USE_GNOME= gnomeprefix gnomehack intlhack gtk20 gconf2 desktopfileutils
+USES= gettext gmake desktop-file-utils pathfix pkgconfig tar:bzip2
+USE_GNOME= gnomeprefix intlhack gtk20 gconf2
USE_GSTREAMER= cdparanoia gconf core gio
GNU_CONFIGURE= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
GCONF_SCHEMAS= goobox.schemas
OPTIONS_DEFINE= NOTIFY
OPTIONS_DEFAULT=NOTIFY
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNOTIFY}
-LIB_DEPENDS+= libnotify.so:${PORTSDIR}/devel/libnotify
-CONFIGURE_ARGS+=--enable-notification
-.else
-CONFIGURE_ARGS+=--disable-notification
-.endif
+NOTIFY_LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
+NOTIFY_CONFIGURE_ENABLE= notification
.include <bsd.port.mk>
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index aecf7e16db9c..64b131c5a8e6 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -4,7 +4,7 @@
PORTNAME= rhythmbox
PORTVERSION= 0.12.8
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= audio gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/audio/sound-juicer/Makefile b/audio/sound-juicer/Makefile
index 2dba284fc16d..8d81c541e62b 100644
--- a/audio/sound-juicer/Makefile
+++ b/audio/sound-juicer/Makefile
@@ -4,7 +4,7 @@
PORTNAME= sound-juicer
PORTVERSION= 2.32.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -20,8 +20,7 @@ LIB_DEPENDS= libmusicbrainz3.so:${PORTSDIR}/audio/libmusicbrainz3 \
libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libbrasero-media.so:${PORTSDIR}/sysutils/brasero
-USE_BZIP2= yes
-USES= gettext gmake pathfix pkgconfig
+USES= gettext gmake pathfix pkgconfig tar:bzip2 desktop-file-utils
INSTALLS_OMF= yes
USE_GNOME= intlhack gnomeprefix gconf2 libglade2 gnomedocutils
USE_GSTREAMER= cdparanoia vorbis flac gconf good gio
@@ -30,6 +29,7 @@ CONFIGURE_ARGS= --enable-ignore-missing-cd
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
GCONF_SCHEMAS= sound-juicer.schemas
diff --git a/audio/sound-juicer/pkg-plist b/audio/sound-juicer/pkg-plist
index 774f610d3dad..e36ba4d9d8fe 100644
--- a/audio/sound-juicer/pkg-plist
+++ b/audio/sound-juicer/pkg-plist
@@ -224,8 +224,6 @@ share/omf/sound-juicer/sound-juicer-zh_CN.omf
@dirrm share/gnome/help/sound-juicer/C/figures
@dirrm share/gnome/help/sound-juicer/C
@dirrm share/gnome/help/sound-juicer
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/xh/LC_MESSAGES
diff --git a/sysutils/brasero/Makefile b/sysutils/brasero/Makefile
index 07a2b3c40c7c..f9c79fecc00a 100644
--- a/sysutils/brasero/Makefile
+++ b/sysutils/brasero/Makefile
@@ -4,7 +4,7 @@
PORTNAME= brasero
PORTVERSION= 2.32.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= sysutils audio multimedia gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -12,20 +12,20 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= CD/DVD mastering tool for the GNOME desktop
-LIB_DEPENDS= notify:${PORTSDIR}/devel/libnotify \
- unique-1.0:${PORTSDIR}/x11-toolkits/unique \
- totem-plparser:${PORTSDIR}/multimedia/totem-pl-parser \
- canberra-gtk:${PORTSDIR}/audio/libcanberra
+LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify \
+ libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique \
+ libtotem-plparser.so:${PORTSDIR}/multimedia/totem-pl-parser \
+ libcanberra-gtk.so:${PORTSDIR}/audio/libcanberra
RUN_DEPENDS= growisofs:${PORTSDIR}/sysutils/dvd+rw-tools \
cdrdao:${PORTSDIR}/sysutils/cdrdao \
yelp:${PORTSDIR}/x11/yelp
CONFLICTS= brasero-3.[0-9]*
-USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_XORG= sm
-USES= pathfix gettext shared-mime-info gmake pkgconfig
+USES= pathfix gettext shared-mime-info gmake pkgconfig tar:bzip2 \
+ libtool desktop-file-utils
USE_GNOME= intlhack gnomeprefix gnomedocutils
USE_LDCONFIG= yes
USE_GSTREAMER= gconf core
@@ -35,8 +35,8 @@ CONFIGURE_ARGS= --disable-inotify --with-html-dir=${PREFIX}/share/doc \
--enable-gtk3=no --enable-introspection=yes
CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_CAM_LIB_H=1
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
-MAN1= brasero.1
GLIB_SCHEMAS= org.gnome.brasero.gschema.xml
OPTIONS_DEFINE= NAUTILUS LIBBURNIA
@@ -46,7 +46,6 @@ LIBBURNIA_DESC= libburnia plug-ins
PLIST_SUB= FULL_VERSION=${PORTVERSION}
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNAUTILUS}
@@ -59,8 +58,8 @@ CONFIGURE_ARGS+=--enable-nautilus=no
.endif
.if ${PORT_OPTIONS:MLIBBURNIA}
-LIB_DEPENDS+= burn:${PORTSDIR}/devel/libburn \
- isofs:${PORTSDIR}/devel/libisofs
+LIB_DEPENDS+= libburn.so:${PORTSDIR}/devel/libburn \
+ libisofs.so:${PORTSDIR}/devel/libisofs
CONFIGURE_ARGS+=--enable-libburnia
PLIST_SUB+= LIBBURNIA=""
.else
diff --git a/sysutils/brasero/pkg-plist b/sysutils/brasero/pkg-plist
index 98931c48232b..1a3b29970472 100644
--- a/sysutils/brasero/pkg-plist
+++ b/sysutils/brasero/pkg-plist
@@ -30,67 +30,44 @@ include/brasero/brasero-track-type.h
include/brasero/brasero-track.h
include/brasero/brasero-units.h
include/brasero/brasero-volume.h
-lib/brasero/plugins/libbrasero-audio2cue.la
lib/brasero/plugins/libbrasero-audio2cue.so
-lib/brasero/plugins/libbrasero-burn-uri.la
lib/brasero/plugins/libbrasero-burn-uri.so
-lib/brasero/plugins/libbrasero-cdda2wav.la
lib/brasero/plugins/libbrasero-cdda2wav.so
-lib/brasero/plugins/libbrasero-cdrdao.la
lib/brasero/plugins/libbrasero-cdrdao.so
-lib/brasero/plugins/libbrasero-cdrecord.la
lib/brasero/plugins/libbrasero-cdrecord.so
-lib/brasero/plugins/libbrasero-checksum-file.la
lib/brasero/plugins/libbrasero-checksum-file.so
-lib/brasero/plugins/libbrasero-checksum.la
lib/brasero/plugins/libbrasero-checksum.so
-lib/brasero/plugins/libbrasero-dvdauthor.la
lib/brasero/plugins/libbrasero-dvdauthor.so
-lib/brasero/plugins/libbrasero-dvdcss.la
lib/brasero/plugins/libbrasero-dvdcss.so
-lib/brasero/plugins/libbrasero-dvdrwformat.la
lib/brasero/plugins/libbrasero-dvdrwformat.so
-lib/brasero/plugins/libbrasero-genisoimage.la
lib/brasero/plugins/libbrasero-genisoimage.so
-lib/brasero/plugins/libbrasero-growisofs.la
lib/brasero/plugins/libbrasero-growisofs.so
-%%LIBBURNIA%%lib/brasero/plugins/libbrasero-libburn.la
%%LIBBURNIA%%lib/brasero/plugins/libbrasero-libburn.so
-%%LIBBURNIA%%lib/brasero/plugins/libbrasero-libisofs.la
%%LIBBURNIA%%lib/brasero/plugins/libbrasero-libisofs.so
-lib/brasero/plugins/libbrasero-local-track.la
lib/brasero/plugins/libbrasero-local-track.so
-lib/brasero/plugins/libbrasero-mkisofs.la
lib/brasero/plugins/libbrasero-mkisofs.so
-lib/brasero/plugins/libbrasero-normalize.la
lib/brasero/plugins/libbrasero-normalize.so
-lib/brasero/plugins/libbrasero-readcd.la
lib/brasero/plugins/libbrasero-readcd.so
-lib/brasero/plugins/libbrasero-readom.la
lib/brasero/plugins/libbrasero-readom.so
-lib/brasero/plugins/libbrasero-transcode.la
lib/brasero/plugins/libbrasero-transcode.so
-lib/brasero/plugins/libbrasero-vcdimager.la
lib/brasero/plugins/libbrasero-vcdimager.so
-lib/brasero/plugins/libbrasero-vob.la
lib/brasero/plugins/libbrasero-vob.so
-lib/brasero/plugins/libbrasero-wodim.la
lib/brasero/plugins/libbrasero-wodim.so
lib/girepository-1.0/BraseroBurn-%%FULL_VERSION%%.typelib
lib/girepository-1.0/BraseroMedia-%%FULL_VERSION%%.typelib
-lib/libbrasero-burn.la
lib/libbrasero-burn.so
-lib/libbrasero-burn.so.3
-lib/libbrasero-media.la
+lib/libbrasero-burn.so.1
+lib/libbrasero-burn.so.1.2.0
lib/libbrasero-media.so
-lib/libbrasero-media.so.3
-lib/libbrasero-utils.la
+lib/libbrasero-media.so.1
+lib/libbrasero-media.so.1.2.0
lib/libbrasero-utils.so
-lib/libbrasero-utils.so.3
-%%NAUTILUS%%lib/nautilus/extensions-2.0/libnautilus-brasero-extension.la
+lib/libbrasero-utils.so.1
+lib/libbrasero-utils.so.1.2.0
%%NAUTILUS%%lib/nautilus/extensions-2.0/libnautilus-brasero-extension.so
libdata/pkgconfig/libbrasero-burn.pc
libdata/pkgconfig/libbrasero-media.pc
+man/man1/brasero.1.gz
share/GConf/gsettings/brasero.convert
share/applications/brasero.desktop
%%NAUTILUS%%share/applications/brasero-nautilus.desktop
diff --git a/x11-toolkits/py-gnome-desktop/Makefile b/x11-toolkits/py-gnome-desktop/Makefile
index c6c5424b96a6..25ba7f0a6307 100644
--- a/x11-toolkits/py-gnome-desktop/Makefile
+++ b/x11-toolkits/py-gnome-desktop/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gnome-desktop
PORTVERSION= 2.32.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-toolkits python gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/gnome-python-desktop/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}