aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-02-06 17:24:09 +0800
committerrafan <rafan@FreeBSD.org>2007-02-06 17:24:09 +0800
commit24d56ac20489eb6e1c6aeb54bfd88d3bf2926c8d (patch)
tree474c4ef9ce00a41c99e4dadd8ec1d5787d3ce50d
parentbfd7b7fce8cf2ed1a67c33cbd68f38f1e87eb4ae (diff)
downloadfreebsd-ports-gnome-24d56ac20489eb6e1c6aeb54bfd88d3bf2926c8d.tar.gz
freebsd-ports-gnome-24d56ac20489eb6e1c6aeb54bfd88d3bf2926c8d.tar.zst
freebsd-ports-gnome-24d56ac20489eb6e1c6aeb54bfd88d3bf2926c8d.zip
Add ffs2recov 1.0, a utility to recover UFS2 filesystems.
PR: ports/108766 Submitted by: sten at blinkenlights.nl
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/ffs2recov/Makefile24
-rw-r--r--sysutils/ffs2recov/distinfo3
-rw-r--r--sysutils/ffs2recov/files/Makefile12
-rw-r--r--sysutils/ffs2recov/pkg-descr24
5 files changed, 64 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 425db1f8eda3..1973db6c1864 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -178,6 +178,7 @@
SUBDIR += fcron
SUBDIR += fdupes
SUBDIR += fetchlog
+ SUBDIR += ffs2recov
SUBDIR += file
SUBDIR += filedupe
SUBDIR += filelight
diff --git a/sysutils/ffs2recov/Makefile b/sysutils/ffs2recov/Makefile
new file mode 100644
index 000000000000..baaa28cde874
--- /dev/null
+++ b/sysutils/ffs2recov/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: ffs2recov
+# Date created: 20070204
+# Whom: sten@blinkenlights.nl
+#
+# $FreeBSD$
+#
+
+PORTNAME= ffs2recov
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://www.exit.com/Archives/FreeBSD/
+
+MAINTAINER= sten@blinkenlights.nl
+COMMENT= A utility to recover UFS2 filesystems
+
+USE_BZIP2= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN8= ffs2recov.8
+PLIST_FILES= sbin/ffs2recov
+
+MAKE_ENV= BINDIR=${PREFIX}/sbin MANDIR=${MANPREFIX}/man/man
+
+.include <bsd.port.mk>
diff --git a/sysutils/ffs2recov/distinfo b/sysutils/ffs2recov/distinfo
new file mode 100644
index 000000000000..77125312bf05
--- /dev/null
+++ b/sysutils/ffs2recov/distinfo
@@ -0,0 +1,3 @@
+MD5 (ffs2recov-1.0.tar.bz2) = 93f187f6a820dd3fd4b430ced1805986
+SHA256 (ffs2recov-1.0.tar.bz2) = 92b442008085d5141ccf536bdfc09e3fc877a9fd90fa42c5460e2559f4cbd614
+SIZE (ffs2recov-1.0.tar.bz2) = 15022
diff --git a/sysutils/ffs2recov/files/Makefile b/sysutils/ffs2recov/files/Makefile
new file mode 100644
index 000000000000..914aff1d749b
--- /dev/null
+++ b/sysutils/ffs2recov/files/Makefile
@@ -0,0 +1,12 @@
+# $FreeBSD$
+
+PROG= ffs2recov
+SRCS= main.c block.c inode.c io.c super.c
+MAN= ffs2recov.8
+
+DPADD= ${LIBUFS}
+LDADD= -lufs
+
+WARNS?= 6
+
+.include <bsd.prog.mk>
diff --git a/sysutils/ffs2recov/pkg-descr b/sysutils/ffs2recov/pkg-descr
new file mode 100644
index 000000000000..39e3e23001c4
--- /dev/null
+++ b/sysutils/ffs2recov/pkg-descr
@@ -0,0 +1,24 @@
+This is the UFS2 version of ffsrecov, heavily (and I do mean _heavily_) based
+on John-Mark Gurney's program of the same name. It does basically the same
+thing, only it's a little more resistant to crashes caused by bad pointers,
+offsets and the like, and it does a little more than his did. Don't contact
+him for problems with this program, it's definitely _my_ fault if it breaks.
+
+This program is not ready for prime time. It has some shortfalls, it has a
+bunch of new options that are mostly undocumented and the manpage could
+stand to be rewritten. One _good_ thing is that it now uses the libufs
+library and is therefore not as dependent on carrying around low-level code.
+
+On the other hand, it worked for me. Using this tool, I was able to recover
+almost all of a several-hundred-gigabyte file system that had been stomped
+by a misconfigured RAID controller. (That's why I wrote the thing in the
+first place, in fact.) With the right knowledge and a lot of patience,
+it is possible to recover most or all of a trashed file system, at least if
+it's not _too_ trashed.
+
+I'm releasing it under the Berkeley two-clause license in the hope that
+someone with more time will pick it up, polish it and make something
+a little more useful out of it.
+
+Frank Mayhar
+frank@exit.com