aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-10-01 21:28:47 +0800
committermnag <mnag@FreeBSD.org>2005-10-01 21:28:47 +0800
commit287785629254b36f13e5c8d53e35b9b2656f54d9 (patch)
tree3d07e89a424a658ae8d54c2e33eeaff241a707cc
parente72f19163215dfdf6368fc94815a2ff94e6d1ee9 (diff)
downloadfreebsd-ports-gnome-287785629254b36f13e5c8d53e35b9b2656f54d9.tar.gz
freebsd-ports-gnome-287785629254b36f13e5c8d53e35b9b2656f54d9.tar.zst
freebsd-ports-gnome-287785629254b36f13e5c8d53e35b9b2656f54d9.zip
New port
This is a command-line utility which tries to determine the encoder used to create an mp3 file. Each encoder has unique characteristics fingerprinted into each file. This program analyzes algorithms that are used in any given file and determines which encoder was used. For example the Xing encoder never uses short blocks. PR: 86768 Submitted by: Emanuel Haupt <ehaupt@critical.ch> Approved by: pav (mentor)
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mp3guessenc/Makefile34
-rw-r--r--audio/mp3guessenc/distinfo2
-rw-r--r--audio/mp3guessenc/files/patch-mp3guessenc.c22
-rw-r--r--audio/mp3guessenc/pkg-descr8
5 files changed, 67 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 63c6bd41224e..2c3017112565 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -301,6 +301,7 @@
SUBDIR += mp3ck
SUBDIR += mp3encode
SUBDIR += mp3gain
+ SUBDIR += mp3guessenc
SUBDIR += mp3info
SUBDIR += mp3mover
SUBDIR += mp3rename
diff --git a/audio/mp3guessenc/Makefile b/audio/mp3guessenc/Makefile
new file mode 100644
index 000000000000..3c2290f9ea62
--- /dev/null
+++ b/audio/mp3guessenc/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: mp3guessenc
+# Date created: 1 Oct 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3guessenc
+PORTVERSION= 0.21
+CATEGORIES= audio
+MASTER_SITES= http://shibatch.sourceforge.net/download/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Utility for guessing which encoder was used to encode an mp3 file
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}
+
+PLIST_FILES= bin/mp3guessenc
+
+post-extract:
+ @${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//' \
+ ${WRKSRC}/${PORTNAME}.c \
+ ${WRKSRC}/VbrTag.h
+
+do-build:
+ ${CC} ${CFLAGS} ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/audio/mp3guessenc/distinfo b/audio/mp3guessenc/distinfo
new file mode 100644
index 000000000000..2d0287058396
--- /dev/null
+++ b/audio/mp3guessenc/distinfo
@@ -0,0 +1,2 @@
+MD5 (mp3guessenc-0.21.zip) = 32de7429c3a7b4feceea85dd33c7e703
+SIZE (mp3guessenc-0.21.zip) = 18434
diff --git a/audio/mp3guessenc/files/patch-mp3guessenc.c b/audio/mp3guessenc/files/patch-mp3guessenc.c
new file mode 100644
index 000000000000..294b8c30e67b
--- /dev/null
+++ b/audio/mp3guessenc/files/patch-mp3guessenc.c
@@ -0,0 +1,22 @@
+--- mp3guessenc.c.orig Sat Oct 1 00:34:43 2005
++++ mp3guessenc.c Sat Oct 1 00:38:22 2005
+@@ -515,6 +515,7 @@
+ for(q--;q >= lame_string && *q == 'U';q--) *q = '\0';
+
+ LSEX_END:
++ {}
+ }
+
+ ///////////////////////////////////////////////////////
+@@ -541,7 +542,10 @@
+ for(i=0;i<256;i++) lame_string[i] = '\0';
+
+ input_file = fopen(argv[1],"rb");
+- if (input_file == NULL) exit(0);
++ if (input_file == NULL) {
++ printf("Usage: mp3guessenc mp3file\n");
++ exit(0);
++ }
+
+ fseek(input_file,0,SEEK_END);
+ filesize = ftell(input_file);
diff --git a/audio/mp3guessenc/pkg-descr b/audio/mp3guessenc/pkg-descr
new file mode 100644
index 000000000000..f54fcb9cd3c6
--- /dev/null
+++ b/audio/mp3guessenc/pkg-descr
@@ -0,0 +1,8 @@
+This is a command-line utility which tries to determine the encoder used to
+create an mp3 file.
+
+Each encoder has unique characteristics fingerprinted into each file. This
+program analyzes algorithms that are used in any given file and determines which
+encoder was used. For example the Xing encoder never uses short blocks.
+
+WWW: http://shibatch.sourceforge.net