aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormmoll <mmoll@FreeBSD.org>2015-10-09 21:31:57 +0800
committermmoll <mmoll@FreeBSD.org>2015-10-09 21:31:57 +0800
commit2b514ae771b33134d8de911e3af9851018e287d9 (patch)
treee569f4bf2fce02f271ee3242ac6d4d8058846bf0
parent418b0712f10a971aa63754768c786335c41dff16 (diff)
downloadfreebsd-ports-gnome-2b514ae771b33134d8de911e3af9851018e287d9.tar.gz
freebsd-ports-gnome-2b514ae771b33134d8de911e3af9851018e287d9.tar.zst
freebsd-ports-gnome-2b514ae771b33134d8de911e3af9851018e287d9.zip
new port: sysutils/rubygem-smart_proxy_remote_execution_ssh
Plugin for foreman-proxy allowing using SSH for remote execution. WWW: https://github.com/theforeman/smart_proxy_remote_execution_ssh
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/rubygem-smart_proxy_remote_execution_ssh/Makefile36
-rw-r--r--sysutils/rubygem-smart_proxy_remote_execution_ssh/distinfo2
-rw-r--r--sysutils/rubygem-smart_proxy_remote_execution_ssh/pkg-descr3
4 files changed, 42 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index bfdebe5cbe7a..c0b6c9ac6989 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -890,6 +890,7 @@
SUBDIR += rubygem-shellany
SUBDIR += rubygem-smart_proxy_chef
SUBDIR += rubygem-smart_proxy_dynflow
+ SUBDIR += rubygem-smart_proxy_remote_execution_ssh
SUBDIR += rubygem-smart_proxy_salt
SUBDIR += rubygem-sys-admin
SUBDIR += rubygem-sys-cpu
diff --git a/sysutils/rubygem-smart_proxy_remote_execution_ssh/Makefile b/sysutils/rubygem-smart_proxy_remote_execution_ssh/Makefile
new file mode 100644
index 000000000000..2a461fef0a5b
--- /dev/null
+++ b/sysutils/rubygem-smart_proxy_remote_execution_ssh/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= smart_proxy_remote_execution_ssh
+PORTVERSION= 0.0.6
+CATEGORIES= sysutils ruby
+MASTER_SITES= RG
+
+MAINTAINER= mmoll@FreeBSD.org
+COMMENT= SSH remote execution provider for foreman-proxy
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= foreman-proxy>=1.9.0:${PORTSDIR}/net/foreman-proxy \
+ rubygem-net-scp>=0:${PORTSDIR}/security/rubygem-net-scp \
+ rubygem-net-ssh>=0:${PORTSDIR}/security/rubygem-net-ssh \
+ rubygem-smart_proxy_dynflow>=0.0.3:${PORTSDIR}/sysutils/rubygem-smart_proxy_dynflow
+
+NO_ARCH= yes
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+PLIST_FILES= share/foreman-proxy/bundler.d/remote_execution_ssh.rb \
+ "@sample etc/foreman-proxy/settings.d/remote_execution_ssh.yml.sample"
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/foreman-proxy/settings.d
+ ${INSTALL_DATA} ${WRKSRC}/settings.d/remote_execution_ssh.yml.example \
+ ${STAGEDIR}${PREFIX}/etc/foreman-proxy/settings.d/remote_execution_ssh.yml.sample
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/foreman-proxy/bundler.d
+ ${INSTALL_DATA} ${WRKSRC}/bundler.d/remote_execution_ssh.rb \
+ ${STAGEDIR}${PREFIX}/share/foreman-proxy/bundler.d/remote_execution_ssh.rb
+
+.include <bsd.port.mk>
diff --git a/sysutils/rubygem-smart_proxy_remote_execution_ssh/distinfo b/sysutils/rubygem-smart_proxy_remote_execution_ssh/distinfo
new file mode 100644
index 000000000000..ad846f76fc3e
--- /dev/null
+++ b/sysutils/rubygem-smart_proxy_remote_execution_ssh/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/smart_proxy_remote_execution_ssh-0.0.6.gem) = 6390147300d8d2dd93ccfcef6b8cea6a565048b9ddfd8579dd43de89c3feb9da
+SIZE (rubygem/smart_proxy_remote_execution_ssh-0.0.6.gem) = 22528
diff --git a/sysutils/rubygem-smart_proxy_remote_execution_ssh/pkg-descr b/sysutils/rubygem-smart_proxy_remote_execution_ssh/pkg-descr
new file mode 100644
index 000000000000..5e449438bcf5
--- /dev/null
+++ b/sysutils/rubygem-smart_proxy_remote_execution_ssh/pkg-descr
@@ -0,0 +1,3 @@
+Plugin for foreman-proxy allowing using SSH for remote execution.
+
+WWW: https://github.com/theforeman/smart_proxy_remote_execution_ssh