aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2007-02-19 02:34:13 +0800
committergarga <garga@FreeBSD.org>2007-02-19 02:34:13 +0800
commit2da32fee626669022d30a83faabf597d526326cb (patch)
treed2ff95ef4d8d8c4a460d597137ad44f394b816f0
parent53a43978c1ecfe1627445354141ba3827f05b10b (diff)
downloadfreebsd-ports-gnome-2da32fee626669022d30a83faabf597d526326cb.tar.gz
freebsd-ports-gnome-2da32fee626669022d30a83faabf597d526326cb.tar.zst
freebsd-ports-gnome-2da32fee626669022d30a83faabf597d526326cb.zip
- Fix build with clamav 0.90
- Bump PORTREVISION Reported by: krismail
-rw-r--r--security/squidclam/Makefile3
-rw-r--r--www/havp/Makefile1
-rw-r--r--www/havp/files/patch-havp_scanners_clamlibscanner.cpp20
3 files changed, 24 insertions, 0 deletions
diff --git a/security/squidclam/Makefile b/security/squidclam/Makefile
index 63a7bd917825..35dadb4b6f59 100644
--- a/security/squidclam/Makefile
+++ b/security/squidclam/Makefile
@@ -7,6 +7,7 @@
PORTNAME= squidclam
PORTVERSION= 0.11
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -34,6 +35,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|cl_perror|cl_strerror|g' \
+ ${WRKSRC}/squidclam.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
diff --git a/www/havp/Makefile b/www/havp/Makefile
index 98a3bfd686f2..111626f04387 100644
--- a/www/havp/Makefile
+++ b/www/havp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= havp
PORTVERSION= 0.82
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.server-side.de/download/ \
http://bio3k.softboard.ru/uploads/arch/
diff --git a/www/havp/files/patch-havp_scanners_clamlibscanner.cpp b/www/havp/files/patch-havp_scanners_clamlibscanner.cpp
new file mode 100644
index 000000000000..7e49825f8fbd
--- /dev/null
+++ b/www/havp/files/patch-havp_scanners_clamlibscanner.cpp
@@ -0,0 +1,20 @@
+--- havp/scanners/clamlibscanner.cpp.orig Sun Feb 18 15:32:07 2007
++++ havp/scanners/clamlibscanner.cpp Sun Feb 18 15:32:35 2007
+@@ -29,7 +29,7 @@
+
+ LogFile::ErrorMessage("ClamAV: Using database directory: %s\n", dbdir);
+
+- if ( (ret = cl_loaddbdir(dbdir, &root, &no)) != 0 )
++ if ( (ret = cl_load(dbdir, &root, &no, CL_DB_STDOPT)) != 0 )
+ {
+ LogFile::ErrorMessage("ClamAV: Could not load database: %s\n", cl_strerror(ret));
+ return false;
+@@ -65,7 +65,7 @@
+
+ cl_settempdir(Params::GetConfigString("TEMPDIR").c_str(), 0);
+
+- if ( (ret = cl_loaddbdir(dbdir, &root, &no)) != 0 )
++ if ( (ret = cl_load(dbdir, &root, &no, CL_DB_STDOPT)) != 0 )
+ {
+ LogFile::ErrorMessage("ClamAV: Could not reload database: %s\n", cl_strerror(ret));
+ return false;