aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2014-02-27 04:59:16 +0800
committergerald <gerald@FreeBSD.org>2014-02-27 04:59:16 +0800
commit2da3576bdd268dd9622b73e6766c1f82033a5a7d (patch)
tree730d7b6fd824b72154c57cca1eed5d54f1a49fdb
parentc767ba635ee67bb3ce0ab87f5fc04213726c5d82 (diff)
downloadfreebsd-ports-gnome-2da3576bdd268dd9622b73e6766c1f82033a5a7d.tar.gz
freebsd-ports-gnome-2da3576bdd268dd9622b73e6766c1f82033a5a7d.tar.zst
freebsd-ports-gnome-2da3576bdd268dd9622b73e6766c1f82033a5a7d.zip
Replace the manual construction of ${LOCALBASE}/lib/${CC}, which is not
appropriate for clang and fragile for GCC, by ${LDFLAGS}. This is not only more robust, ${LDFLAGS} will also provide -Wl,-rpath when necessary. Plus extend an existing CONFIGURE_ENV instead of overwriting it. With these changes, the configure problem that made the build fail goes away. On FreeBSD 10.x and above there still are C++ errors later in the build, so leave the port BROKEN. Approved by: swills (maintainer) With help from: redports.org, mat, decke
-rw-r--r--graphics/visionworkbench/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/visionworkbench/Makefile b/graphics/visionworkbench/Makefile
index 01dfc53e75a9..dc0cf2367826 100644
--- a/graphics/visionworkbench/Makefile
+++ b/graphics/visionworkbench/Makefile
@@ -47,7 +47,7 @@ CFLAGS+= -Dtgammaf=tgamma
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
-CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include ${CFLAGS}" \
+CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include ${CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${LDFLAGS}"
post-patch:
@@ -55,7 +55,7 @@ post-patch:
pre-configure:
echo "HAVE_PKG_FLAPACK=yes" >> ${WRKSRC}/config.options
- echo "PKG_FLAPACK_LDFLAGS=-L${LOCALBASE}/lib/${CC}" >> ${WRKSRC}/config.options
+ echo "PKG_FLAPACK_LDFLAGS=${LDFLAGS}" >> ${WRKSRC}/config.options
echo "HAVE_PKG_PYTHON=yes" >> ${WRKSRC}/config.options
echo "PYTHON_LDFLAGS=-L${PYTHON_LIBDIR} -lboost_python -l${PYTHON_VERSION} ${PTHREAD_LIBS}" >> ${WRKSRC}/config.options
echo "PYTHON_CPPFLAGS=-I${PYTHON_INCLUDEDIR}" >> ${WRKSRC}/config.options