aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2008-11-21 20:39:18 +0800
committerosa <osa@FreeBSD.org>2008-11-21 20:39:18 +0800
commit2e34476733fbb560d51942e57b4646a166330de4 (patch)
tree361eceb747e51da2062cde1177cccb60e7799b05
parent092eadcaa710708fe2bf78737eac7ae094142c1c (diff)
downloadfreebsd-ports-gnome-2e34476733fbb560d51942e57b4646a166330de4.tar.gz
freebsd-ports-gnome-2e34476733fbb560d51942e57b4646a166330de4.tar.zst
freebsd-ports-gnome-2e34476733fbb560d51942e57b4646a166330de4.zip
Update from 0.6.32 to 0.6.33.
Also, add the patch for bugfix: the "listen" directive parameters such as "backlog", "rcvbuf", etc. were not set, if a default server was not the first one. These changes also added into mainstream for future releases. <ChangeLog> *) Feature: now nginx returns the 405 status code for POST method requesting a static file only if the file exists. *) Workaround: compatibility with glibc 2.3. Thanks to Eric Benson and Maxim Dounin. *) Bugfix: the resolver did not understand big DNS responses. Thanks to Zyb. *) Bugfix: in HTTPS mode requests might fail with the "bad write retry" error. *) Bugfix: the ngx_http_charset_module did not understand quoted charset name received from backend. *) Bugfix: if the "max_fails=0" parameter was used in upstream with several servers, then a worker process exited on a SIGFPE signal. Thanks to Maxim Dounin. *) Bugfix: the $r->header_in() method did not return value of the "Host", "User-Agent", and "Connection" request header lines; the bug had appeared in 0.6.32. *) Bugfix: a full response was returned for request method HEAD while redirection via an "error_page" directive. *) Bugfix: if a directory has search only rights and the first index file was absent, then nginx returned the 500 status code. *) Bugfix: of recursive error_page for 500 status code. </ChangeLog>
-rw-r--r--www/nginx/Makefile3
-rw-r--r--www/nginx/distinfo6
-rw-r--r--www/nginx/files/patch-src::http::nginx_http.c10
3 files changed, 14 insertions, 5 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 44416bd78d67..a64c63ab655b 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.6.32
-PORTREVISION= 1
+PORTVERSION= 0.6.33
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 562c12259f30..bf70376aa634 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -1,3 +1,3 @@
-MD5 (nginx-0.6.32.tar.gz) = c09a2ace3c91f45dabbb608b11e48ed1
-SHA256 (nginx-0.6.32.tar.gz) = d74bbb9235e7beabf7be03a7dec99f0cab89fa4430a998a6a7151901ea141e9d
-SIZE (nginx-0.6.32.tar.gz) = 522183
+MD5 (nginx-0.6.33.tar.gz) = 36d7a2ae7204a7ba0cd7625c4ccdba68
+SHA256 (nginx-0.6.33.tar.gz) = f21b5923b51b799fc91292e513ec965239189f5ad2936bd88a18b0a807c49613
+SIZE (nginx-0.6.33.tar.gz) = 523162
diff --git a/www/nginx/files/patch-src::http::nginx_http.c b/www/nginx/files/patch-src::http::nginx_http.c
new file mode 100644
index 000000000000..e6cd2d60ff8e
--- /dev/null
+++ b/www/nginx/files/patch-src::http::nginx_http.c
@@ -0,0 +1,10 @@
+--- src/http/ngx_http.c.orig 2008-03-24 16:04:02.000000000 +0300
++++ src/http/ngx_http.c 2008-08-27 22:11:11.000000000 +0400
+@@ -558,6 +558,7 @@
+
+ in_addr[a].core_srv_conf = cscfp[s];
+ in_addr[a].default_server = 1;
++ in_addr[a].listen_conf = &lscf[l].conf;
+ }
+
+ goto found;