aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-06-14 15:51:23 +0800
committerijliao <ijliao@FreeBSD.org>2001-06-14 15:51:23 +0800
commit3356bf5a2579ed777d158b87e82d9279cd01def7 (patch)
tree010607fd4eaeee2d205b9d4796de22a753cb5ab1
parent57a7f24b283e4e2b6ebc0f98bcdb21eeacc0cc90 (diff)
downloadfreebsd-ports-gnome-3356bf5a2579ed777d158b87e82d9279cd01def7.tar.gz
freebsd-ports-gnome-3356bf5a2579ed777d158b87e82d9279cd01def7.tar.zst
freebsd-ports-gnome-3356bf5a2579ed777d158b87e82d9279cd01def7.zip
add txt2regex
A Regular Expression "wizard"
-rw-r--r--misc/Makefile1
-rw-r--r--misc/txt2regex/Makefile30
-rw-r--r--misc/txt2regex/distinfo1
-rw-r--r--misc/txt2regex/pkg-comment1
-rw-r--r--misc/txt2regex/pkg-descr7
-rw-r--r--misc/txt2regex/pkg-plist1
6 files changed, 41 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 654e8468435b..081399f476c0 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -163,6 +163,7 @@
SUBDIR += tkrunit
SUBDIR += ttyrec
SUBDIR += tvguide
+ SUBDIR += txt2regex
SUBDIR += uf-view
SUBDIR += uk-phone
SUBDIR += uk-postcodes
diff --git a/misc/txt2regex/Makefile b/misc/txt2regex/Makefile
new file mode 100644
index 000000000000..6ccacb664b1e
--- /dev/null
+++ b/misc/txt2regex/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# New ports collection makefile for: txt2regex
+# Date created: Jun 14, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= txt2regex
+PORTVERSION= 0.3
+CATEGORIES= misc
+MASTER_SITES= http://txt2regex.sourceforge.net/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ijliao@FreeBSD.org
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
+ gseq:${PORTSDIR}/misc/sh-utils
+
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e "s,/bin/bash,${LOCALBASE}/bin/bash,g ; \
+ s,\`seq,\`gseq,g" ${WRKSRC}/txt2regex-0.3.sh
+ @${PERL} -pi -e "s,/usr,${LOCALBASE},g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/txt2regex-0.3.sh ${PREFIX}/bin/txt2regex
+
+.include <bsd.port.mk>
diff --git a/misc/txt2regex/distinfo b/misc/txt2regex/distinfo
new file mode 100644
index 000000000000..fff984d45fcd
--- /dev/null
+++ b/misc/txt2regex/distinfo
@@ -0,0 +1 @@
+MD5 (txt2regex-0.3.tgz) = bcf6c5e1b27edd3d80c63d269aa96fa0
diff --git a/misc/txt2regex/pkg-comment b/misc/txt2regex/pkg-comment
new file mode 100644
index 000000000000..fcbe480fbca7
--- /dev/null
+++ b/misc/txt2regex/pkg-comment
@@ -0,0 +1 @@
+A Regular Expression "wizard"
diff --git a/misc/txt2regex/pkg-descr b/misc/txt2regex/pkg-descr
new file mode 100644
index 000000000000..505417e9eeea
--- /dev/null
+++ b/misc/txt2regex/pkg-descr
@@ -0,0 +1,7 @@
+^txt2regex$ is a Regular Expression "wizard", all written with bash2 builtins,
+that converts human sentences to RegExs. with a simple interface, you just
+answer to questions and build your own RegEx for a large variety of programs,
+like awk, ed, emacs, grep, perl, php, python, sed, tcl and vim. there are 18
+supported programs now.
+
+WWW: http://txt2regex.sourceforge.net/
diff --git a/misc/txt2regex/pkg-plist b/misc/txt2regex/pkg-plist
new file mode 100644
index 000000000000..d98f60cfe8f5
--- /dev/null
+++ b/misc/txt2regex/pkg-plist
@@ -0,0 +1 @@
+bin/txt2regex