aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2001-02-07 06:26:23 +0800
committerdirk <dirk@FreeBSD.org>2001-02-07 06:26:23 +0800
commit3cd5be3d70d2229dce7117034b2e3af88e560a0f (patch)
tree7f0fcee486c4a8ec097bb25ebe535e134cd516fc
parent13e05b46b5336cf833ceccaac5c355feed5eedff (diff)
downloadfreebsd-ports-gnome-3cd5be3d70d2229dce7117034b2e3af88e560a0f.tar.gz
freebsd-ports-gnome-3cd5be3d70d2229dce7117034b2e3af88e560a0f.tar.zst
freebsd-ports-gnome-3cd5be3d70d2229dce7117034b2e3af88e560a0f.zip
Add support for YP and BCMath.
Submitted by: Marius Strom <marius@marius.org>
-rw-r--r--www/mod_php4/scripts/configure.php8
-rw-r--r--www/mod_php5/scripts/configure.php8
2 files changed, 16 insertions, 0 deletions
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index 3cb42aa20a43..25c3910c13d0 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -29,6 +29,8 @@ XML "XML support" OFF \
FTP "File Transfer Protocol support" OFF \
gettext "gettext library support" OFF \
jstring "jstring module" OFF \
+YP "YP/NIS support" OFF \
+BCMath "BCMath support" OFF \
2> /tmp/checklist.tmp.$$
retval=$?
@@ -172,6 +174,12 @@ post-extract:
./buildconf)
EOF
;;
+ \"YP\")
+ echo "CONFIGURE_ARGS+=--enable-yp"
+ ;;
+ \"BCMath\")
+ echo "CONFIGURE_ARGS+=--enable-bcmath"
+ ;;
*)
echo "Invalid option(s): $*" > /dev/stderr
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index 3cb42aa20a43..25c3910c13d0 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -29,6 +29,8 @@ XML "XML support" OFF \
FTP "File Transfer Protocol support" OFF \
gettext "gettext library support" OFF \
jstring "jstring module" OFF \
+YP "YP/NIS support" OFF \
+BCMath "BCMath support" OFF \
2> /tmp/checklist.tmp.$$
retval=$?
@@ -172,6 +174,12 @@ post-extract:
./buildconf)
EOF
;;
+ \"YP\")
+ echo "CONFIGURE_ARGS+=--enable-yp"
+ ;;
+ \"BCMath\")
+ echo "CONFIGURE_ARGS+=--enable-bcmath"
+ ;;
*)
echo "Invalid option(s): $*" > /dev/stderr
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc