aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-05-20 06:01:13 +0800
committermarcus <marcus@FreeBSD.org>2007-05-20 06:01:13 +0800
commit3cd8209a03f8009623b914f1b67160bfab1c3c8f (patch)
tree8144eb5df066cbb0ac1d9d8779ea79ff5e5026c7
parentde7bde33b15ed0109c9b689dbbbb3a59442a2675 (diff)
downloadfreebsd-ports-gnome-3cd8209a03f8009623b914f1b67160bfab1c3c8f.tar.gz
freebsd-ports-gnome-3cd8209a03f8009623b914f1b67160bfab1c3c8f.tar.zst
freebsd-ports-gnome-3cd8209a03f8009623b914f1b67160bfab1c3c8f.zip
Remove support for a separate X11BASE.
Approved by: portmgr (implicit)
-rw-r--r--devel/gnome-vfs/Makefile4
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c2
-rw-r--r--misc/shared-mime-info/Makefile14
-rw-r--r--misc/shared-mime-info/files/patch-update-mime-database.c2
-rw-r--r--x11-toolkits/gtk20/Makefile9
-rw-r--r--x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.c2
-rw-r--r--x11-toolkits/gtk30/Makefile9
-rw-r--r--x11-toolkits/gtk30/files/patch-gtk_xdgmime_xdgmime.c2
8 files changed, 16 insertions, 28 deletions
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index 571ff7c4af6e..65873e625c1e 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gnome-vfs
PORTVERSION= 2.18.1
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-vfs/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -82,9 +82,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/libgnomevfs/Makefile.in
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
- s|/usr/X11R6|${X11BASE}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g; \
- s|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/libgnomevfs/xdgmime.c \
${WRKSRC}/libgnomevfs/gnome-vfs-hal-mounts.c
@${REINPLACE_CMD} -e 's|-lacl||g' \
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c b/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c
index 7119f852fa75..aaa8ff29d555 100644
--- a/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c
+++ b/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c
@@ -5,7 +5,7 @@
xdg_data_dirs = getenv ("XDG_DATA_DIRS");
if (xdg_data_dirs == NULL)
- xdg_data_dirs = "/usr/local/share/:/usr/share/";
-+ xdg_data_dirs = "%%LOCALBASE%%/share/gnome/:%%X11BASE%%/share/gnome/:%%LOCALBASE%%/share/:%%X11BASE%%/share/:/usr/share/";
++ xdg_data_dirs = "%%LOCALBASE%%/share/gnome/:%%LOCALBASE%%/share/:/usr/share/";
ptr = xdg_data_dirs;
diff --git a/misc/shared-mime-info/Makefile b/misc/shared-mime-info/Makefile
index ef2025c421d0..299dbb6baf0a 100644
--- a/misc/shared-mime-info/Makefile
+++ b/misc/shared-mime-info/Makefile
@@ -6,7 +6,7 @@
PORTNAME= shared-mime-info
PORTVERSION= 0.21
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc gnome
MASTER_SITES= http://people.freedesktop.org/~hadess/
@@ -26,9 +26,7 @@ MAN1= update-mime-database.1
PKGINSTALL= ${WRKDIR}/pkg-install
-MIMEDIRS= ${X11BASE}/share/gnome/mime \
- ${LOCALBASE}/share/gnome/mime \
- ${X11BASE}/share/mime \
+MIMEDIRS= ${LOCALBASE}/share/gnome/mime \
${LOCALBASE}/share/mime \
${PREFIX}/share/mime \
/usr/share/mime
@@ -38,15 +36,9 @@ MIMESUBDIRS= application audio image inode message model multipart \
post-patch:
@${REINPLACE_CMD} -e 's|%%MIMEDIRS%%|${MIMEDIRS}|g' \
${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
- s|%%X11BASE%%|${X11BASE}|g' \
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/update-mime-database.c
-pre-su-install:
-.for subdir in ${MIMESUBDIRS}
- ${MKDIR} ${X11BASE}/share/mime/${subdir}
-.endfor
-
post-install:
@${SED} -e 's|%%PREFIX%%|${PREFIX}| ; \
s|%%MIMEDIRS%%|${MIMEDIRS}|' \
diff --git a/misc/shared-mime-info/files/patch-update-mime-database.c b/misc/shared-mime-info/files/patch-update-mime-database.c
index a9837e64314c..0af2d2a1fd86 100644
--- a/misc/shared-mime-info/files/patch-update-mime-database.c
+++ b/misc/shared-mime-info/files/patch-update-mime-database.c
@@ -15,7 +15,7 @@
env = getenv("XDG_DATA_DIRS");
if (!env)
- env = "/usr/local/share/:/usr/share/";
-+ env = "%%X11BASE%%/share/gnome/:/usr/local/share/gnome/:%%X11BASE%%/share/:/usr/local/share/:/usr/share/";
++ env = "/usr/local/share/gnome/:/usr/local/share/:/usr/share/";
dirs = g_strsplit(env, ":", 0);
g_return_if_fail(dirs != NULL);
for (n = 0; dirs[n]; n++)
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index 8b79e24cc61a..eedaf1abd334 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gtk
PORTVERSION= 2.10.12
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/,} \
ftp://ftp.gtk.org/pub/gtk/v2.10/ \
@@ -45,8 +45,8 @@ USE_GETTEXT= yes
USE_XLIB= yes
CONFIGURE_ARGS= --enable-static --with-xinput=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
- -I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+ -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
GTK_VERSION= 2.10.0
PLIST_SUB= GTK_VERSION="${GTK_VERSION}"
@@ -73,8 +73,7 @@ post-patch:
${XARGS} ${REINPLACE_CMD} -e 's|-lgmodule|@GMODULE_LIBS@|g'
@${REINPLACE_CMD} -e 's|[{]libdir[}]/locale|{datadir}/locale|g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
- s|%%X11BASE%%|${X11BASE}|g' \
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/gtk/xdgmime/xdgmime.c
# GnomeVFS needs pthread; gtk-demo may use GnomeVFS (via GtkFileChooser)
@${REINPLACE_CMD} -e 's|@CFLAGS@|& ${PTHREAD_CFLAGS}|; \
diff --git a/x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.c b/x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.c
index b39aaedd07b5..c33fc40e8264 100644
--- a/x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.c
+++ b/x11-toolkits/gtk20/files/patch-gtk_xdgmime_xdgmime.c
@@ -5,7 +5,7 @@
xdg_data_dirs = getenv ("XDG_DATA_DIRS");
if (xdg_data_dirs == NULL)
- xdg_data_dirs = "/usr/local/share/:/usr/share/";
-+ xdg_data_dirs = "%%X11BASE%%/share/gnome/:/usr/local/share/gnome/:%%X11BASE%%/share/:/usr/local/share/:/usr/share/";
++ xdg_data_dirs = "/usr/local/share/gnome/:/usr/local/share/:/usr/share/";
ptr = xdg_data_dirs;
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index 8b79e24cc61a..eedaf1abd334 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gtk
PORTVERSION= 2.10.12
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/,} \
ftp://ftp.gtk.org/pub/gtk/v2.10/ \
@@ -45,8 +45,8 @@ USE_GETTEXT= yes
USE_XLIB= yes
CONFIGURE_ARGS= --enable-static --with-xinput=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
- -I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+ -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
GTK_VERSION= 2.10.0
PLIST_SUB= GTK_VERSION="${GTK_VERSION}"
@@ -73,8 +73,7 @@ post-patch:
${XARGS} ${REINPLACE_CMD} -e 's|-lgmodule|@GMODULE_LIBS@|g'
@${REINPLACE_CMD} -e 's|[{]libdir[}]/locale|{datadir}/locale|g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
- s|%%X11BASE%%|${X11BASE}|g' \
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/gtk/xdgmime/xdgmime.c
# GnomeVFS needs pthread; gtk-demo may use GnomeVFS (via GtkFileChooser)
@${REINPLACE_CMD} -e 's|@CFLAGS@|& ${PTHREAD_CFLAGS}|; \
diff --git a/x11-toolkits/gtk30/files/patch-gtk_xdgmime_xdgmime.c b/x11-toolkits/gtk30/files/patch-gtk_xdgmime_xdgmime.c
index b39aaedd07b5..c33fc40e8264 100644
--- a/x11-toolkits/gtk30/files/patch-gtk_xdgmime_xdgmime.c
+++ b/x11-toolkits/gtk30/files/patch-gtk_xdgmime_xdgmime.c
@@ -5,7 +5,7 @@
xdg_data_dirs = getenv ("XDG_DATA_DIRS");
if (xdg_data_dirs == NULL)
- xdg_data_dirs = "/usr/local/share/:/usr/share/";
-+ xdg_data_dirs = "%%X11BASE%%/share/gnome/:/usr/local/share/gnome/:%%X11BASE%%/share/:/usr/local/share/:/usr/share/";
++ xdg_data_dirs = "/usr/local/share/gnome/:/usr/local/share/:/usr/share/";
ptr = xdg_data_dirs;