aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-07-03 13:00:30 +0800
committermarcus <marcus@FreeBSD.org>2002-07-03 13:00:30 +0800
commit3eb9df28a0400113760342c8cf3116a4af99493e (patch)
tree11b8381dfda5c6bebe5e9057c7abd0bf684f7ad8
parente610f1a6fa829a57acb7aefdb5b289b69bd4d4eb (diff)
downloadfreebsd-ports-gnome-3eb9df28a0400113760342c8cf3116a4af99493e.tar.gz
freebsd-ports-gnome-3eb9df28a0400113760342c8cf3116a4af99493e.tar.zst
freebsd-ports-gnome-3eb9df28a0400113760342c8cf3116a4af99493e.zip
Re-fix the sawfish configurators after switching over to librep.
Reported by: Anders Andersson <anders@hack.org> Pointy hat to: me
-rw-r--r--lang/librep/Makefile3
-rw-r--r--lang/librep/files/patch-ltmain.sh19
2 files changed, 21 insertions, 1 deletions
diff --git a/lang/librep/Makefile b/lang/librep/Makefile
index 1e1a2841bcb1..e50ad4088725 100644
--- a/lang/librep/Makefile
+++ b/lang/librep/Makefile
@@ -7,6 +7,7 @@
PORTNAME= librep
PORTVERSION= 0.16.1
+PORTREVISION= 1
CATEGORIES= lang gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= librep
@@ -26,7 +27,7 @@ USE_GMAKE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lxpg4 -lintl"
+ LIBS="-L${LOCALBASE}/lib -lxpg4 -lintl ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --with-aclocaldir=${PREFIX}/share/aclocal
CONFIGURE_TARGET= ${ARCH}-pc-freebsd${OSREL:C/\..*//}
diff --git a/lang/librep/files/patch-ltmain.sh b/lang/librep/files/patch-ltmain.sh
new file mode 100644
index 000000000000..bb2407590cad
--- /dev/null
+++ b/lang/librep/files/patch-ltmain.sh
@@ -0,0 +1,19 @@
+--- ltmain.sh.orig Wed Jan 23 11:38:40 2002
++++ ltmain.sh Sun Feb 3 01:44:17 2002
+@@ -1037,8 +1037,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+