aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-04-19 02:22:30 +0800
committerpav <pav@FreeBSD.org>2005-04-19 02:22:30 +0800
commit52a7fdbf6e279c89c3ccb5ab13e36b92a4a9fbd5 (patch)
tree0c2213b63ace855957e8b651f5dcef1d059a3796
parente57a21575680b431788b782139d3b229a8a03995 (diff)
downloadfreebsd-ports-gnome-52a7fdbf6e279c89c3ccb5ab13e36b92a4a9fbd5.tar.gz
freebsd-ports-gnome-52a7fdbf6e279c89c3ccb5ab13e36b92a4a9fbd5.tar.zst
freebsd-ports-gnome-52a7fdbf6e279c89c3ccb5ab13e36b92a4a9fbd5.zip
This is a small utility for checking and repairing the qmail queue
structure. It will fix uid/gid settings and permissions. It will rename the message files to match their inodes. It will even create directories and files that don't exist that should be there (you can even create a queue from scratch). It will also print warnings for any files it finds that should not exist. PR: ports/79913 Submitted by: Renato Botelho <freebsd@galle.com.br>
-rw-r--r--mail/Makefile1
-rw-r--r--mail/queue-fix/Makefile53
-rw-r--r--mail/queue-fix/distinfo4
-rw-r--r--mail/queue-fix/pkg-descr9
-rw-r--r--mail/queue-fix/pkg-plist4
5 files changed, 71 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 02ee9d151caf..c23c984ce5b0 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -402,6 +402,7 @@
SUBDIR += qsf
SUBDIR += qtools
SUBDIR += queue-repair
+ SUBDIR += queue-fix
SUBDIR += quickml
SUBDIR += raysfilter
SUBDIR += razor-agents
diff --git a/mail/queue-fix/Makefile b/mail/queue-fix/Makefile
new file mode 100644
index 000000000000..9b02233e1eb2
--- /dev/null
+++ b/mail/queue-fix/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: queue-fix
+# Date created: 2005-04-14
+# Whom: Renato Botelho <freebsd@galle.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= queue-fix
+PORTVERSION= 1.4
+CATEGORIES= mail
+MASTER_SITES= http://www.netmeridian.com/e-huss/
+
+MAINTAINER= freebsd@galle.com.br
+COMMENT= Repairs or generates a qmail queue structure
+
+RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail
+
+OPTIONS= BIG_TODO "Use big_todo patch" off
+
+CONFIGURE_SCRIPT=
+ALL_TARGET=
+
+PLIST_SUB= DOCDIR=${DOCDIR}
+
+.if exists(${PREFIX}/qmail/bin/qmail-send)
+PREFIX?= ${PREFIX}/qmail
+.else
+PREFIX?= /var/qmail
+.endif
+
+.if (${PREFIX} == ${LOCALBASE})
+DOCDIR= share/doc/qmail/queue-fix
+.else
+DOCDIR= doc/queue-fix
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_BIG_TODO)
+PATCH_SITES+= http://www.qmail.org/
+PATCHFILES+= queue-fix-todo.patch
+PATCH_DIST_STRIP+= -p1
+.endif
+
+do-install:
+ @${MKDIR} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/queue-fix ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/${DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/${DOCDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/queue-fix/distinfo b/mail/queue-fix/distinfo
new file mode 100644
index 000000000000..20799a34bc56
--- /dev/null
+++ b/mail/queue-fix/distinfo
@@ -0,0 +1,4 @@
+MD5 (queue-fix-1.4.tar.gz) = 43f915c104024e6f33a5b3ff52dfb75b
+SIZE (queue-fix-1.4.tar.gz) = 18486
+MD5 (queue-fix-todo.patch) = cbebb217b1b3b32f20995f2c869f6121
+SIZE (queue-fix-todo.patch) = 3056
diff --git a/mail/queue-fix/pkg-descr b/mail/queue-fix/pkg-descr
new file mode 100644
index 000000000000..c5c6539def41
--- /dev/null
+++ b/mail/queue-fix/pkg-descr
@@ -0,0 +1,9 @@
+This is a small utility for checking and repairing the qmail queue
+structure. It will fix uid/gid settings and permissions. It will
+rename the message files to match their inodes. It will even create
+directories and files that don't exist that should be there (you can
+even create a queue from scratch). It will also print warnings for
+any files it finds that should not exist.
+
+Author: Eric Huss <e-huss at netmeridian.com>
+WWW: http://www.qmail.org/
diff --git a/mail/queue-fix/pkg-plist b/mail/queue-fix/pkg-plist
new file mode 100644
index 000000000000..bc713f95889f
--- /dev/null
+++ b/mail/queue-fix/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+bin/queue-fix
+%%PORTDOCS%%%%DOCDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCDIR%%