aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-04-10 01:48:43 +0800
committermiwi <miwi@FreeBSD.org>2007-04-10 01:48:43 +0800
commit571265307c7cef9c45e1b2e513253b976fecaefe (patch)
tree2a8ee9659dbea87c5afec7893120f0f0382f264c
parent7d328e4a5256fbcdd4d2b93da5a296408ef20d31 (diff)
downloadfreebsd-ports-gnome-571265307c7cef9c45e1b2e513253b976fecaefe.tar.gz
freebsd-ports-gnome-571265307c7cef9c45e1b2e513253b976fecaefe.tar.zst
freebsd-ports-gnome-571265307c7cef9c45e1b2e513253b976fecaefe.zip
- Fix firmware directory
PR: 111061 Submitted by: trasz (maintainer)
-rw-r--r--emulators/simh/Makefile4
-rw-r--r--emulators/simh/files/patch-VAX-vax_sysdev.c19
2 files changed, 23 insertions, 0 deletions
diff --git a/emulators/simh/Makefile b/emulators/simh/Makefile
index 5fab8852e116..31d541e09941 100644
--- a/emulators/simh/Makefile
+++ b/emulators/simh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= simh
PORTVERSION= 3.7
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://simh.trailing-edge.com/sources/
DISTNAME= ${PORTNAME}v37-0
@@ -47,6 +48,9 @@ MAKE_ENV= USE_NETWORK=1
pre-patch:
@${MKDIR} ${WRKSRC}/BIN
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/VAX/vax_sysdev.c
+
do-install:
.for file in ${BIN_FILES}
${INSTALL_PROGRAM} ${WRKDIR}/BIN/${file} ${PREFIX}/bin
diff --git a/emulators/simh/files/patch-VAX-vax_sysdev.c b/emulators/simh/files/patch-VAX-vax_sysdev.c
new file mode 100644
index 000000000000..f9821dc3d69a
--- /dev/null
+++ b/emulators/simh/files/patch-VAX-vax_sysdev.c
@@ -0,0 +1,19 @@
+--- VAX/vax_sysdev.c.orig Sat Mar 24 09:13:42 2007
++++ VAX/vax_sysdev.c Sat Mar 24 09:17:45 2007
+@@ -1524,8 +1524,15 @@
+ if (sim_log) fprintf (sim_log,
+ "Loading boot code from ka655x.bin\n");
+ r = load_cmd (0, "-R ka655x.bin");
+- if (r != SCPE_OK) return r;
++ if (r != SCPE_OK) {
++ printf ("Loading boot code from %%PREFIX%%/share/simh/ka655x.bin\n");
++ if (sim_log) fprintf (sim_log,
++ "Loading boot code from %%PREFIX%%/share/simh/ka655x.bin\n");
++ r = load_cmd (0, "-R %%PREFIX%%/share/simh/ka655x.bin");
++ if (r != SCPE_OK)
++ return r;
+ }
++}
+ return SCPE_OK;
+ }
+