aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2011-08-01 16:01:55 +0800
committerpgj <pgj@FreeBSD.org>2011-08-01 16:01:55 +0800
commit5a39f82f32c023d0d1fc032fe787e2625d838be9 (patch)
tree0107c91c7dad3aa5798176db64f2926b3cbb9bf5
parent7276ec8bda4a94c28127316d5a9f33f010353514 (diff)
downloadfreebsd-ports-gnome-5a39f82f32c023d0d1fc032fe787e2625d838be9.tar.gz
freebsd-ports-gnome-5a39f82f32c023d0d1fc032fe787e2625d838be9.tar.zst
freebsd-ports-gnome-5a39f82f32c023d0d1fc032fe787e2625d838be9.zip
- Update to 3.20110702
- Un-break build PR: ports/158667 Submitted by: Fraser Tweedale <frase@frase.id.au> (maintainer)
-rw-r--r--devel/git-annex/Makefile22
-rw-r--r--devel/git-annex/distinfo4
-rw-r--r--devel/git-annex/files/patch-Makefile14
-rw-r--r--devel/hs-git-annex/Makefile22
-rw-r--r--devel/hs-git-annex/distinfo4
-rw-r--r--devel/hs-git-annex/files/patch-Makefile14
6 files changed, 46 insertions, 34 deletions
diff --git a/devel/git-annex/Makefile b/devel/git-annex/Makefile
index b98d38f9dab5..ca95fc430269 100644
--- a/devel/git-annex/Makefile
+++ b/devel/git-annex/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= git-annex
-PORTVERSION= 0.20110601
+PORTVERSION= 3.20110702
CATEGORIES= devel haskell
MASTER_SITES= http://git.kitenet.net/?p=git-annex.git;a=snapshot;sf=tgz;h=refs/tags/
DISTFILES= ${PORTVERSION}
@@ -20,24 +20,32 @@ BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
hs-pcre-light>=0:${PORTSDIR}/devel/hs-pcre-light \
hs-utf8-string>=0:${PORTSDIR}/devel/hs-utf8-string \
hs-SHA>=0:${PORTSDIR}/security/hs-SHA \
- hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc
+ hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc \
+ hs-curl>0:${PORTSDIR}/ftp/hs-curl \
+ git:${PORTSDIR}/devel/git \
+ rsync:${PORTSDIR}/net/rsync
+
RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
hs-MissingH>=0:${PORTSDIR}/devel/hs-MissingH \
hs-pcre-light>=0:${PORTSDIR}/devel/hs-pcre-light \
hs-utf8-string>=0:${PORTSDIR}/devel/hs-utf8-string \
hs-SHA>=0:${PORTSDIR}/security/hs-SHA \
- hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc
-
-BROKEN= does not configure
+ hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc \
+ hs-curl>0:${PORTSDIR}/ftp/hs-curl \
+ git:${PORTSDIR}/devel/git \
+ rsync:${PORTSDIR}/net/rsync
USE_PERL5= yes
USE_GMAKE= yes
-MAN1= git-annex.1 git-annex-shell.1
+MAN1= git-annex.1 \
+ git-annex-shell.1 \
+ git-union-merge.1
LICENSE= GPLv3
PLIST_FILES= bin/git-annex \
- bin/git-annex-shell
+ bin/git-annex-shell \
+ bin/git-union-merge
.include <bsd.port.mk>
diff --git a/devel/git-annex/distinfo b/devel/git-annex/distinfo
index edacae9e6724..4eb6cba3c8ed 100644
--- a/devel/git-annex/distinfo
+++ b/devel/git-annex/distinfo
@@ -1,2 +1,2 @@
-SHA256 (git-annex/0.20110601) = 2718e5634a4384d8a2a284bac66f1cff76d2c048b6c57662c24c575a97e9193b
-SIZE (git-annex/0.20110601) = 358008
+SHA256 (git-annex/3.20110702) = 66d633bcbd49d4a34b241222bf83f35e85af3207454de3fde4afaf1dd1409580
+SIZE (git-annex/3.20110702) = 378351
diff --git a/devel/git-annex/files/patch-Makefile b/devel/git-annex/files/patch-Makefile
index fee6be5c2660..c9c6e3512786 100644
--- a/devel/git-annex/files/patch-Makefile
+++ b/devel/git-annex/files/patch-Makefile
@@ -1,14 +1,12 @@
-diff --git a/Makefile b/Makefile
-index 286c3a6..3ed7a59 100644
---- Makefile
-+++ Makefile
+--- ./Makefile.orig 2011-07-02 21:08:05.000000000 +0200
++++ ./Makefile 2011-08-01 09:35:21.000000000 +0200
@@ -1,4 +1,4 @@
-PREFIX=/usr
-+PREFIX=/usr/local
++PREFIX?=/usr/local
IGNORE=-ignore-package monads-fd
GHCFLAGS=-O2 -Wall $(IGNORE) -fspec-constr-count=5
ifdef PROFILE
-@@ -37,12 +37,8 @@ git-annex-shell.1: doc/git-annex-shell.mdwn
+@@ -43,12 +43,8 @@
install: all
install -d $(DESTDIR)$(PREFIX)/bin
install $(bins) $(DESTDIR)$(PREFIX)/bin
@@ -22,8 +20,8 @@ index 286c3a6..3ed7a59 100644
+ install -m 0644 $(mans) $(DESTDIR)$(PREFIX)/man/man1
test: $(bins)
- if ! $(GHCMAKE) -O0 test; then \
-@@ -59,21 +55,7 @@ testcoverage: $(bins)
+ @if ! $(GHCMAKE) -O0 test; then \
+@@ -65,21 +61,7 @@
@hpc report test --exclude=Main --exclude=QC
@hpc markup test --exclude=Main --exclude=QC --destdir=.hpc >/dev/null
diff --git a/devel/hs-git-annex/Makefile b/devel/hs-git-annex/Makefile
index b98d38f9dab5..ca95fc430269 100644
--- a/devel/hs-git-annex/Makefile
+++ b/devel/hs-git-annex/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= git-annex
-PORTVERSION= 0.20110601
+PORTVERSION= 3.20110702
CATEGORIES= devel haskell
MASTER_SITES= http://git.kitenet.net/?p=git-annex.git;a=snapshot;sf=tgz;h=refs/tags/
DISTFILES= ${PORTVERSION}
@@ -20,24 +20,32 @@ BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
hs-pcre-light>=0:${PORTSDIR}/devel/hs-pcre-light \
hs-utf8-string>=0:${PORTSDIR}/devel/hs-utf8-string \
hs-SHA>=0:${PORTSDIR}/security/hs-SHA \
- hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc
+ hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc \
+ hs-curl>0:${PORTSDIR}/ftp/hs-curl \
+ git:${PORTSDIR}/devel/git \
+ rsync:${PORTSDIR}/net/rsync
+
RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
hs-MissingH>=0:${PORTSDIR}/devel/hs-MissingH \
hs-pcre-light>=0:${PORTSDIR}/devel/hs-pcre-light \
hs-utf8-string>=0:${PORTSDIR}/devel/hs-utf8-string \
hs-SHA>=0:${PORTSDIR}/security/hs-SHA \
- hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc
-
-BROKEN= does not configure
+ hs-dataenc>=0:${PORTSDIR}/converters/hs-dataenc \
+ hs-curl>0:${PORTSDIR}/ftp/hs-curl \
+ git:${PORTSDIR}/devel/git \
+ rsync:${PORTSDIR}/net/rsync
USE_PERL5= yes
USE_GMAKE= yes
-MAN1= git-annex.1 git-annex-shell.1
+MAN1= git-annex.1 \
+ git-annex-shell.1 \
+ git-union-merge.1
LICENSE= GPLv3
PLIST_FILES= bin/git-annex \
- bin/git-annex-shell
+ bin/git-annex-shell \
+ bin/git-union-merge
.include <bsd.port.mk>
diff --git a/devel/hs-git-annex/distinfo b/devel/hs-git-annex/distinfo
index edacae9e6724..4eb6cba3c8ed 100644
--- a/devel/hs-git-annex/distinfo
+++ b/devel/hs-git-annex/distinfo
@@ -1,2 +1,2 @@
-SHA256 (git-annex/0.20110601) = 2718e5634a4384d8a2a284bac66f1cff76d2c048b6c57662c24c575a97e9193b
-SIZE (git-annex/0.20110601) = 358008
+SHA256 (git-annex/3.20110702) = 66d633bcbd49d4a34b241222bf83f35e85af3207454de3fde4afaf1dd1409580
+SIZE (git-annex/3.20110702) = 378351
diff --git a/devel/hs-git-annex/files/patch-Makefile b/devel/hs-git-annex/files/patch-Makefile
index fee6be5c2660..c9c6e3512786 100644
--- a/devel/hs-git-annex/files/patch-Makefile
+++ b/devel/hs-git-annex/files/patch-Makefile
@@ -1,14 +1,12 @@
-diff --git a/Makefile b/Makefile
-index 286c3a6..3ed7a59 100644
---- Makefile
-+++ Makefile
+--- ./Makefile.orig 2011-07-02 21:08:05.000000000 +0200
++++ ./Makefile 2011-08-01 09:35:21.000000000 +0200
@@ -1,4 +1,4 @@
-PREFIX=/usr
-+PREFIX=/usr/local
++PREFIX?=/usr/local
IGNORE=-ignore-package monads-fd
GHCFLAGS=-O2 -Wall $(IGNORE) -fspec-constr-count=5
ifdef PROFILE
-@@ -37,12 +37,8 @@ git-annex-shell.1: doc/git-annex-shell.mdwn
+@@ -43,12 +43,8 @@
install: all
install -d $(DESTDIR)$(PREFIX)/bin
install $(bins) $(DESTDIR)$(PREFIX)/bin
@@ -22,8 +20,8 @@ index 286c3a6..3ed7a59 100644
+ install -m 0644 $(mans) $(DESTDIR)$(PREFIX)/man/man1
test: $(bins)
- if ! $(GHCMAKE) -O0 test; then \
-@@ -59,21 +55,7 @@ testcoverage: $(bins)
+ @if ! $(GHCMAKE) -O0 test; then \
+@@ -65,21 +61,7 @@
@hpc report test --exclude=Main --exclude=QC
@hpc markup test --exclude=Main --exclude=QC --destdir=.hpc >/dev/null