aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-11-22 04:58:04 +0800
committermiwi <miwi@FreeBSD.org>2008-11-22 04:58:04 +0800
commit68fd1202ebd674836c3cda5f4bb331d2442afaa5 (patch)
treee9f3169b9b1be0e10a49c410c2a4ecba3a1a3cd7
parentadc4ed83de18230f73c21cb68b341625dabd71d5 (diff)
downloadfreebsd-ports-gnome-68fd1202ebd674836c3cda5f4bb331d2442afaa5.tar.gz
freebsd-ports-gnome-68fd1202ebd674836c3cda5f4bb331d2442afaa5.tar.zst
freebsd-ports-gnome-68fd1202ebd674836c3cda5f4bb331d2442afaa5.zip
Sinatra is a DSL for quickly creating web-applications in Ruby
with minimal effort. It sits on top of Rack, a minimal standard interface for Ruby web frameworks. For templating, the choices include erb, haml, sass and Builder. WWW: http://github.com/bmizerany/sinatra PR: ports/128551 Submitted by: Daniel Roethlisberger <daniel at roe.ch>
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-sinatra/Makefile30
-rw-r--r--www/rubygem-sinatra/distinfo3
-rw-r--r--www/rubygem-sinatra/pkg-descr6
-rw-r--r--www/rubygem-sinatra/pkg-message12
5 files changed, 52 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 23214c24d5fb..ab1482daae88 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1286,6 +1286,7 @@
SUBDIR += rubygem-rubyfulsoup
SUBDIR += rubygem-scrapi
SUBDIR += rubygem-scrubyt
+ SUBDIR += rubygem-sinatra
SUBDIR += rubygem-staticmatic
SUBDIR += rubygem-taggable
SUBDIR += rubygem-thin
diff --git a/www/rubygem-sinatra/Makefile b/www/rubygem-sinatra/Makefile
new file mode 100644
index 000000000000..9cf6a2d7bc65
--- /dev/null
+++ b/www/rubygem-sinatra/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: rubygem-sinatra
+# Date created: 2008-11-02
+# Whom: Daniel Roethlisberger <daniel@roe.ch>
+#
+# $FreeBSD$
+
+PORTNAME= sinatra
+PORTVERSION= 0.3.0
+CATEGORIES= www rubygems
+MASTER_SITES= RF
+
+MAINTAINER= daniel@roe.ch
+COMMENT= A classy web development framework in ruby
+
+BUILD_DEPENDS= rubygem-rack>=0.4.0:${PORTSDIR}/www/rubygem-rack
+RUN_DEPENDS= rubygem-rack>=0.4.0:${PORTSDIR}/www/rubygem-rack
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO} ${GEM_CACHE} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-sinatra/distinfo b/www/rubygem-sinatra/distinfo
new file mode 100644
index 000000000000..5ba99d2c6458
--- /dev/null
+++ b/www/rubygem-sinatra/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/sinatra-0.3.0.gem) = ed0d3272d903fb555e61555ed450c2ab
+SHA256 (rubygem/sinatra-0.3.0.gem) = 79a5d3e64017efd0f5b4a9fdad6917a35eba336f759ffb5926ffc1aa7438270e
+SIZE (rubygem/sinatra-0.3.0.gem) = 91648
diff --git a/www/rubygem-sinatra/pkg-descr b/www/rubygem-sinatra/pkg-descr
new file mode 100644
index 000000000000..85950c36827a
--- /dev/null
+++ b/www/rubygem-sinatra/pkg-descr
@@ -0,0 +1,6 @@
+Sinatra is a DSL for quickly creating web-applications in Ruby
+with minimal effort. It sits on top of Rack, a minimal standard
+interface for Ruby web frameworks. For templating, the choices
+include erb, haml, sass and Builder.
+
+WWW: http://github.com/bmizerany/sinatra
diff --git a/www/rubygem-sinatra/pkg-message b/www/rubygem-sinatra/pkg-message
new file mode 100644
index 000000000000..38f53e8fd0c0
--- /dev/null
+++ b/www/rubygem-sinatra/pkg-message
@@ -0,0 +1,12 @@
+
+ **** NOTE ****
+
+ Sinatra optionally integrates with haml/sass or Builder
+ for templating and mongrel or thin as an HTTP server.
+ To use them, install the respective ports separately:
+
+ www/rubygem-haml
+ devel/rubygem-builder
+ www/rubygem-mongrel
+ www/rubygem-thin
+