aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2010-08-17 02:38:14 +0800
committeracm <acm@FreeBSD.org>2010-08-17 02:38:14 +0800
commit70fe68bfd49a08479d0fb3a61bd3334b966269a5 (patch)
tree6f8bdad7577bc8e0a00761b060842bce9b424367
parent592c7c6c8bdbb9ba36be1c5124beb2a28c391aad (diff)
downloadfreebsd-ports-gnome-70fe68bfd49a08479d0fb3a61bd3334b966269a5.tar.gz
freebsd-ports-gnome-70fe68bfd49a08479d0fb3a61bd3334b966269a5.tar.zst
freebsd-ports-gnome-70fe68bfd49a08479d0fb3a61bd3334b966269a5.zip
- Update to 2.4.0
PR: 146001 Submitted by: Christopher Key <cjk32 __ __ cam.ac.uk>
-rw-r--r--lang/fpc-units/Makefile45
1 files changed, 35 insertions, 10 deletions
diff --git a/lang/fpc-units/Makefile b/lang/fpc-units/Makefile
index fd70cb1bf9e4..6085a7124e70 100644
--- a/lang/fpc-units/Makefile
+++ b/lang/fpc-units/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= units
-PORTVERSION= 2.2.4
-PORTREVISION= 3
+PORTVERSION= 2.4.0
CATEGORIES= lang
MASTER_SITES= # none
PKGNAMEPREFIX= fpc-
@@ -17,15 +16,20 @@ EXTRACT_ONLY= # none
MAINTAINER= acm@FreeBSD.org
COMMENT= A meta port to install Free Pascal units
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
NO_BUILD= yes
BUILDNAME= ${ARCH}-freebsd
-OPTIONS= ASPELL "Interface to aspell spelling checker" on \
+OPTIONS= A52 "Interface to a52 library" on \
+ ASPELL "Interface to aspell spelling checker" on \
BFD "Interface to GNU Binary Format description" on \
+ BZIP2 "Free Pascal bzip2 unit" on \
CAIRO "Interface to cairo library" on \
CHM "Free Pbscal unit to manipulate chm files" on \
+ DBUS "Interface to dbus library" on \
+ DTS "Interface to dts library" on \
+ FASTCGI "Free Pascal fastcgi unit" on \
FCL_ASYNC "Free Pascal interface to async library" on \
FCL_BASE "Free Pascal Component Library (base)" on \
FCL_DB "Free Pascal Component Library (db)" on \
@@ -36,30 +40,47 @@ OPTIONS= ASPELL "Interface to aspell spelling checker" on \
FCL_PASSRC "Free Pascal Component Library (passrc)" on \
FCL_PROCESS "Unit to start and manipulate other programs" on \
FCL_REGISTRY "Free Pascal Component Library (registry)" on \
+ FCL_RES "Free Pascal Component Library (res)" on \
FCL_WEB "Free Pascal Component Library (web)" on \
FCL_XML "Free Pascal Component Library (xml)" on \
FFTW "Interface to the FFTW3 library" on \
- FPMKUNIT "Free Pascal build system unit" on \
FPGTK "Interface to create programs with gtk" on \
+ FPMKUNIT "Free Pascal build system unit" on \
+ FPVECTORIAL "Free Pascal fpvectorial unit" on \
FV "Free Pascal unit for Delphi support" on \
GDBM "Interface to the GNU database system" on \
GGI "Interface to libggi library" on \
+ GMP "Interface to gmp library" on \
GNOME1 "Interface to create programs for GNOME" on \
GTK1 "Interface to gtk libraries" on \
GTK2 "Interface to gtk2 libraries" on \
+ HERMES "Free Pascal hermes unit" on \
ICONVENC "Interface to iconv library" on \
IMAGEMAGICK "Interface to ImageMagick" on \
IMLIB "Interface to imlib library" on \
+ LDAP "Interface to OpenLDAP" on \
LIBCURL "Interface to curl library" on \
LIBGD "Interface to gd library" on \
LIBPNG "Interface to png library" on \
+ LIBXML2 "Interface to libxml2 library" on \
+ LUA "Interface to lua interpreter" on \
+ MAD "Interface to mad library" on \
+ MATROSKA "Interface to matroska library" on \
+ MODPLUG "Interface to modplug library" on \
NCURSES "Interface to ncurses library" on \
+ NEWT "Interface to newt library" on \
NUMLIB "Free Pascal unit for numerical methods" on \
+ OGGVORBIS "Interaface to ogg & vorbis libraries" on \
+ OPENAL "Interface to openal library" on \
OPENGL "Interface to opengl library" on \
OPENSSL "Interface to openssl library" on \
PCAP "Interface to pcap library" on \
+ PROJ4 "Interface to proj library" on \
PXLIB "Unit to read various Paradox file" on \
+ REXX "Intrface to rexx-regina library" on \
+ RSVG "Interface to rsvg2 library" on \
SDL "Free Pascal interface to SDL library" on \
+ SNDFILE "Interface to sndfile library" on \
SVGALIB "Interface to svgalib library" on \
SYMBOLIC "Simple expression parsing and evaluating" on \
SYSLOG "Interface to system logger" on \
@@ -67,6 +88,7 @@ OPTIONS= ASPELL "Interface to aspell spelling checker" on \
UNZIP "Routines for unzipping zip files" on \
USERS "Interface to manipulate users" on \
UTMP "Gather information from the utmp file" on \
+ UUID "Free Pascal uuid unit" on \
X11 "Interface to X windows server" on \
XFORMS "Interface to X-Forms" on \
ZLIB "Interface to the zlib compression library" on \
@@ -79,11 +101,14 @@ OPTIONSFILE?= ${PORT_DBDIR}/${LATEST_LINK}/options
.include "${OPTIONSFILE}"
.endif
-ALL_OPTIONS= ASPELL BFD CAIRO CHM FCL-ASYNC FCL-BASE FCL-DB FCL-FPCUNIT FCL-IMAGE \
- FCL-JSON FCL-NET FCL-PASSRC FCL-PROCESS FCL-REGISTRY FCL-WEB FCL-XML \
- FFTW FPMKUNIT FPGTK FV GDBM GGI GNOME1 GTK1 GTK2 ICONVENC IMAGEMAGICK IMLIB LIBCURL \
- LIBGD LIBPNG NCURSES NUMLIB OPENGL OPENSSL PCAP PXLIB SDL SVGALIB SYMBOLIC \
- SYSLOG TCL UNZIP USERS UTMP X11 XFORMS ZLIB
+ALL_OPTIONS= A52 ASPELL BFD BZIP2 CAIRO CHM DBUS DTS FASTCGI FCL-ASYNC FCL-BASE \
+ FCL-DB FCL-FPCUNIT FCL-IMAGE FCL-JSON FCL-NET FCL-PASSRC FCL-PROCESS \
+ FCL-REGISTRY FCL-RES FCL-WEB FCL-XML FFTW FPGTK FPMKUNIT FPVECTORIAL \
+ FV GDBM GGI GMP GNOME1 GTK1 GTK2 HERMES ICONVENC IMAGEMAGICK IMLIB \
+ LDAP LIBCURL LIBGD LIBPNG LIBXML2 LUA MAD MATROSKA MODPLUG NCURSES \
+ NEWT NUMLIB OGGVORBIS OPENAL OPENGL OPENSSL PCAP PROJ4 PXLIB RSVG \
+ REXX SDL SNDFILE SVGALIB SYMBOLIC SYSLOG TCL UNZIP USERS UTMP UUID \
+ X11 XFORMS ZLIB
UNITS_SELECTED= #
.for OPT in ${ALL_OPTIONS}