aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2008-11-21 23:45:58 +0800
committerhrs <hrs@FreeBSD.org>2008-11-21 23:45:58 +0800
commit71585d66549e9c015eef949e90fa0e7ea1e865ee (patch)
treee0760c5168e0847793401b5a0c5a8f5a864cd56a
parentef2b5d8fc8441da821b853a11908951484876716 (diff)
downloadfreebsd-ports-gnome-71585d66549e9c015eef949e90fa0e7ea1e865ee.tar.gz
freebsd-ports-gnome-71585d66549e9c015eef949e90fa0e7ea1e865ee.tar.zst
freebsd-ports-gnome-71585d66549e9c015eef949e90fa0e7ea1e865ee.zip
Add textproc/linux-scim-gtk, Linux binary version of an SCIM module
for gtk library, separated from textproc/linux-scim-libs.
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/linux-f10-scim-gtk/Makefile65
-rw-r--r--textproc/linux-f10-scim-gtk/distinfo.i386.fc46
-rw-r--r--textproc/linux-f10-scim-gtk/distinfo.i386.fc76
-rw-r--r--textproc/linux-f10-scim-gtk/distinfo.i386.fc86
-rw-r--r--textproc/linux-f10-scim-gtk/pkg-descr5
-rw-r--r--textproc/linux-f10-scim-gtk/pkg-plist5
-rw-r--r--textproc/linux-f8-scim-gtk/Makefile65
-rw-r--r--textproc/linux-f8-scim-gtk/distinfo.i386.fc46
-rw-r--r--textproc/linux-f8-scim-gtk/distinfo.i386.fc76
-rw-r--r--textproc/linux-f8-scim-gtk/distinfo.i386.fc86
-rw-r--r--textproc/linux-f8-scim-gtk/pkg-descr5
-rw-r--r--textproc/linux-f8-scim-gtk/pkg-plist5
-rw-r--r--textproc/linux-scim-gtk/Makefile65
-rw-r--r--textproc/linux-scim-gtk/distinfo.i386.fc46
-rw-r--r--textproc/linux-scim-gtk/distinfo.i386.fc76
-rw-r--r--textproc/linux-scim-gtk/distinfo.i386.fc86
-rw-r--r--textproc/linux-scim-gtk/pkg-descr5
-rw-r--r--textproc/linux-scim-gtk/pkg-plist5
19 files changed, 280 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e01ecf8abd00..92a816b5e691 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -306,6 +306,7 @@
SUBDIR += linux-expat
SUBDIR += linux-libxml
SUBDIR += linux-libxml2
+ SUBDIR += linux-scim-gtk
SUBDIR += linux-scim-libs
SUBDIR += linux-xerces-c2
SUBDIR += linuxdoc
diff --git a/textproc/linux-f10-scim-gtk/Makefile b/textproc/linux-f10-scim-gtk/Makefile
new file mode 100644
index 000000000000..fbdc0bca65ff
--- /dev/null
+++ b/textproc/linux-f10-scim-gtk/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: linux-scim-gtk
+# Date created: 21 November 2008
+# Whom: hrs
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-gtk
+PORTVERSION= # defined below
+CATEGORIES= textproc linux
+MASTER_SITE_SUBDIR= # defined below
+PKGNAMESUFFIX= -fc${LINUX_DIST_VER}
+DISTNAME= # defined below
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Smart Common Input Method platform, gtk module, Linux binary
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-x11-2.0.so.0:${PORTSDIR}/x11-toolkits/linux-gtk2 \
+ ${LINUXBASE}/usr/lib/libscim-1.0.so.8:${PORTSDIR}/textproc/linux-scim-libs
+
+MASTER_SITE_SRC_SUBDIR= # defined below
+SRC_DISTFILES= scim-${PORTVERSION}-${PORTSUBVERSION}.fc${LINUX_DIST_VER}${SRC_SUFX}
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX_RPM= yes
+USE_LDCONFIG= yes
+PLIST_SUB= LINUX_RPM_ARCH=${LINUX_RPM_ARCH}
+MD5_FILE= ${PKGDIR}/distinfo.${LINUX_RPM_ARCH}.fc${LINUX_DIST_VER}
+
+.if defined(OVERRIDE_LINUX_BASE_PORT) && ${OVERRIDE_LINUX_BASE_PORT} == f8
+PORTVERSION= 1.4.7
+PORTSUBVERSION= 7
+LINUX_DIST_VER= 8
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${PORTSUBVERSION}.fc${LINUX_DIST_VER}
+MASTER_SITE_SUBDIR= ../releases/${LINUX_DIST_VER}/Everything/${LINUX_RPM_ARCH}/os/Packages
+MASTER_SITE_SRC_SUBDIR= ../releases/${LINUX_DIST_VER}/Everything/source/SRPMS
+.elif defined(OVERRIDE_LINUX_BASE_PORT) && ${OVERRIDE_LINUX_BASE_PORT} == f7
+PORTVERSION= 1.4.5
+PORTSUBVERSION= 18
+LINUX_DIST_VER= 7
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${PORTSUBVERSION}.fc${LINUX_DIST_VER}
+MASTER_SITE_SUBDIR= ../releases/${LINUX_DIST_VER}/Everything/${LINUX_RPM_ARCH}/os/Fedora
+MASTER_SITE_SRC_SUBDIR= ../releases/${LINUX_DIST_VER}/Everything/source/SRPMS
+.else
+PORTVERSION= 1.4.4
+PORTSUBVERSION= 1
+DISTNAME= scim-libs-${PORTVERSION}-${PORTSUBVERSION}.fc${LINUX_DIST_VER}
+LINUX_DIST_VER= 4
+MASTER_SITE_SUBDIR= ../extras/${LINUX_DIST_VER}/${LINUX_RPM_ARCH}
+MASTER_SITE_SRC_SUBDIR= ../extras/${LINUX_DIST_VER}/SRPMS
+
+post-extract:
+ cd ${WRKDIR}/usr/lib && ${RM} -rf libscim-* scim-1.0
+.endif
+
+.for V in fc4 f7 f8
+makesum-${V}:
+ ${MAKE} PACKAGE_BUILDING=yes OVERRIDE_LINUX_BASE_PORT=${V} makesum
+.endfor
+makesum-all: makesum-fc4 makesum-f7 makesum-f8
+
+post-install:
+ @chroot ${PREFIX} /usr/bin/gtk-query-immodules-2.0-32 > ${PREFIX}/etc/gtk-2.0/${LINUX_RPM_ARCH}-redhat-linux-gnu/gtk.immodules
+
+.include <bsd.port.mk>
diff --git a/textproc/linux-f10-scim-gtk/distinfo.i386.fc4 b/textproc/linux-f10-scim-gtk/distinfo.i386.fc4
new file mode 100644
index 000000000000..25cea5323143
--- /dev/null
+++ b/textproc/linux-f10-scim-gtk/distinfo.i386.fc4
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/4/scim-libs-1.4.4-1.fc4.i386.rpm) = f25bd31a5a0f6e524199a9f700ba0ee8
+SHA256 (rpm/i386/fedora/4/scim-libs-1.4.4-1.fc4.i386.rpm) = d5eae50f1b1ed241557a447aa6610591a86a85f5a4213794b83697b4828a0896
+SIZE (rpm/i386/fedora/4/scim-libs-1.4.4-1.fc4.i386.rpm) = 722213
+MD5 (rpm/i386/fedora/4/scim-1.4.4-1.fc4.src.rpm) = a5b60af9aa09ba4f7cb0e1d706648f07
+SHA256 (rpm/i386/fedora/4/scim-1.4.4-1.fc4.src.rpm) = 19d51a711b49d387d42f98f3340fab54ebfb1b0838276ec814c4da00b9edceb5
+SIZE (rpm/i386/fedora/4/scim-1.4.4-1.fc4.src.rpm) = 2624736
diff --git a/textproc/linux-f10-scim-gtk/distinfo.i386.fc7 b/textproc/linux-f10-scim-gtk/distinfo.i386.fc7
new file mode 100644
index 000000000000..7976d2e9291a
--- /dev/null
+++ b/textproc/linux-f10-scim-gtk/distinfo.i386.fc7
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/7/scim-gtk-1.4.5-18.fc7.i386.rpm) = a2b75a06a5e590c17a940295bc5a4f14
+SHA256 (rpm/i386/fedora/7/scim-gtk-1.4.5-18.fc7.i386.rpm) = f470a2212c7e90cb45b22a73612a062e46b32b9cd7ef72fa870cb80f4a29fa97
+SIZE (rpm/i386/fedora/7/scim-gtk-1.4.5-18.fc7.i386.rpm) = 73138
+MD5 (rpm/i386/fedora/7/scim-1.4.5-18.fc7.src.rpm) = c11057bfaaff7fc6fcc278bdf3bec899
+SHA256 (rpm/i386/fedora/7/scim-1.4.5-18.fc7.src.rpm) = 4dbe60d2962e53c54cb237e82d152604a15b7b17166c8300075991512ef867b1
+SIZE (rpm/i386/fedora/7/scim-1.4.5-18.fc7.src.rpm) = 3210779
diff --git a/textproc/linux-f10-scim-gtk/distinfo.i386.fc8 b/textproc/linux-f10-scim-gtk/distinfo.i386.fc8
new file mode 100644
index 000000000000..f308d9f96970
--- /dev/null
+++ b/textproc/linux-f10-scim-gtk/distinfo.i386.fc8
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/8/scim-gtk-1.4.7-7.fc8.i386.rpm) = 10ac4d236445d8393b9ec2e03266665b
+SHA256 (rpm/i386/fedora/8/scim-gtk-1.4.7-7.fc8.i386.rpm) = e2ee0b209d5b7a7e0bf60d7dfc2a31fbe75d096ab4e892b09aa7133e4e49bc2a
+SIZE (rpm/i386/fedora/8/scim-gtk-1.4.7-7.fc8.i386.rpm) = 77056
+MD5 (rpm/i386/fedora/8/scim-1.4.7-7.fc8.src.rpm) = 983f86fa040f81be8e8aae227cf35cb1
+SHA256 (rpm/i386/fedora/8/scim-1.4.7-7.fc8.src.rpm) = 93faafef3ad42a8349007e7d28988dac23fea212ff55e9f957a07e4a54f12276
+SIZE (rpm/i386/fedora/8/scim-1.4.7-7.fc8.src.rpm) = 3121068
diff --git a/textproc/linux-f10-scim-gtk/pkg-descr b/textproc/linux-f10-scim-gtk/pkg-descr
new file mode 100644
index 000000000000..ff9dfc89a940
--- /dev/null
+++ b/textproc/linux-f10-scim-gtk/pkg-descr
@@ -0,0 +1,5 @@
+Smart Common Input Method platform, in short SCIM, is a development platform
+to make Input Method developers live easier. It has very clear architecture
+and very simple programming interface.
+
+WWW: http://www.scim-im.org
diff --git a/textproc/linux-f10-scim-gtk/pkg-plist b/textproc/linux-f10-scim-gtk/pkg-plist
new file mode 100644
index 000000000000..8a3bd7b36aa9
--- /dev/null
+++ b/textproc/linux-f10-scim-gtk/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD: /tmp/pcvs/ports/textproc/linux-f10-scim-gtk/pkg-plist,v 1.1 2008-11-21 15:45:58 hrs Exp $
+usr/lib/gtk-2.0/immodules/im-scim.so
+@dirrmtry usr/lib/gtk-2.0/immodules
+@exec chroot %D /usr/bin/gtk-query-immodules-2.0-32 > %D/etc/gtk-2.0/%%LINUX_RPM_ARCH%%-redhat-linux-gnu/gtk.immodules
+@unexec chroot %D /usr/bin/gtk-query-immodules-2.0-32 > %D/etc/gtk-2.0/%%LINUX_RPM_ARCH%%-redhat-linux-gnu/gtk.immodules
diff --git a/textproc/linux-f8-scim-gtk/Makefile b/textproc/linux-f8-scim-gtk/Makefile
new file mode 100644
index 000000000000..fbdc0bca65ff
--- /dev/null
+++ b/textproc/linux-f8-scim-gtk/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: linux-scim-gtk
+# Date created: 21 November 2008
+# Whom: hrs
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-gtk
+PORTVERSION= # defined below
+CATEGORIES= textproc linux
+MASTER_SITE_SUBDIR= # defined below
+PKGNAMESUFFIX= -fc${LINUX_DIST_VER}
+DISTNAME= # defined below
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Smart Common Input Method platform, gtk module, Linux binary
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-x11-2.0.so.0:${PORTSDIR}/x11-toolkits/linux-gtk2 \
+ ${LINUXBASE}/usr/lib/libscim-1.0.so.8:${PORTSDIR}/textproc/linux-scim-libs
+
+MASTER_SITE_SRC_SUBDIR= # defined below
+SRC_DISTFILES= scim-${PORTVERSION}-${PORTSUBVERSION}.fc${LINUX_DIST_VER}${SRC_SUFX}
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX_RPM= yes
+USE_LDCONFIG= yes
+PLIST_SUB= LINUX_RPM_ARCH=${LINUX_RPM_ARCH}
+MD5_FILE= ${PKGDIR}/distinfo.${LINUX_RPM_ARCH}.fc${LINUX_DIST_VER}
+
+.if defined(OVERRIDE_LINUX_BASE_PORT) && ${OVERRIDE_LINUX_BASE_PORT} == f8
+PORTVERSION= 1.4.7
+PORTSUBVERSION= 7
+LINUX_DIST_VER= 8
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${PORTSUBVERSION}.fc${LINUX_DIST_VER}
+MASTER_SITE_SUBDIR= ../releases/${LINUX_DIST_VER}/Everything/${LINUX_RPM_ARCH}/os/Packages
+MASTER_SITE_SRC_SUBDIR= ../releases/${LINUX_DIST_VER}/Everything/source/SRPMS
+.elif defined(OVERRIDE_LINUX_BASE_PORT) && ${OVERRIDE_LINUX_BASE_PORT} == f7
+PORTVERSION= 1.4.5
+PORTSUBVERSION= 18
+LINUX_DIST_VER= 7
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${PORTSUBVERSION}.fc${LINUX_DIST_VER}
+MASTER_SITE_SUBDIR= ../releases/${LINUX_DIST_VER}/Everything/${LINUX_RPM_ARCH}/os/Fedora
+MASTER_SITE_SRC_SUBDIR= ../releases/${LINUX_DIST_VER}/Everything/source/SRPMS
+.else
+PORTVERSION= 1.4.4
+PORTSUBVERSION= 1
+DISTNAME= scim-libs-${PORTVERSION}-${PORTSUBVERSION}.fc${LINUX_DIST_VER}
+LINUX_DIST_VER= 4
+MASTER_SITE_SUBDIR= ../extras/${LINUX_DIST_VER}/${LINUX_RPM_ARCH}
+MASTER_SITE_SRC_SUBDIR= ../extras/${LINUX_DIST_VER}/SRPMS
+
+post-extract:
+ cd ${WRKDIR}/usr/lib && ${RM} -rf libscim-* scim-1.0
+.endif
+
+.for V in fc4 f7 f8
+makesum-${V}:
+ ${MAKE} PACKAGE_BUILDING=yes OVERRIDE_LINUX_BASE_PORT=${V} makesum
+.endfor
+makesum-all: makesum-fc4 makesum-f7 makesum-f8
+
+post-install:
+ @chroot ${PREFIX} /usr/bin/gtk-query-immodules-2.0-32 > ${PREFIX}/etc/gtk-2.0/${LINUX_RPM_ARCH}-redhat-linux-gnu/gtk.immodules
+
+.include <bsd.port.mk>
diff --git a/textproc/linux-f8-scim-gtk/distinfo.i386.fc4 b/textproc/linux-f8-scim-gtk/distinfo.i386.fc4
new file mode 100644
index 000000000000..25cea5323143
--- /dev/null
+++ b/textproc/linux-f8-scim-gtk/distinfo.i386.fc4
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/4/scim-libs-1.4.4-1.fc4.i386.rpm) = f25bd31a5a0f6e524199a9f700ba0ee8
+SHA256 (rpm/i386/fedora/4/scim-libs-1.4.4-1.fc4.i386.rpm) = d5eae50f1b1ed241557a447aa6610591a86a85f5a4213794b83697b4828a0896
+SIZE (rpm/i386/fedora/4/scim-libs-1.4.4-1.fc4.i386.rpm) = 722213
+MD5 (rpm/i386/fedora/4/scim-1.4.4-1.fc4.src.rpm) = a5b60af9aa09ba4f7cb0e1d706648f07
+SHA256 (rpm/i386/fedora/4/scim-1.4.4-1.fc4.src.rpm) = 19d51a711b49d387d42f98f3340fab54ebfb1b0838276ec814c4da00b9edceb5
+SIZE (rpm/i386/fedora/4/scim-1.4.4-1.fc4.src.rpm) = 2624736
diff --git a/textproc/linux-f8-scim-gtk/distinfo.i386.fc7 b/textproc/linux-f8-scim-gtk/distinfo.i386.fc7
new file mode 100644
index 000000000000..7976d2e9291a
--- /dev/null
+++ b/textproc/linux-f8-scim-gtk/distinfo.i386.fc7
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/7/scim-gtk-1.4.5-18.fc7.i386.rpm) = a2b75a06a5e590c17a940295bc5a4f14
+SHA256 (rpm/i386/fedora/7/scim-gtk-1.4.5-18.fc7.i386.rpm) = f470a2212c7e90cb45b22a73612a062e46b32b9cd7ef72fa870cb80f4a29fa97
+SIZE (rpm/i386/fedora/7/scim-gtk-1.4.5-18.fc7.i386.rpm) = 73138
+MD5 (rpm/i386/fedora/7/scim-1.4.5-18.fc7.src.rpm) = c11057bfaaff7fc6fcc278bdf3bec899
+SHA256 (rpm/i386/fedora/7/scim-1.4.5-18.fc7.src.rpm) = 4dbe60d2962e53c54cb237e82d152604a15b7b17166c8300075991512ef867b1
+SIZE (rpm/i386/fedora/7/scim-1.4.5-18.fc7.src.rpm) = 3210779
diff --git a/textproc/linux-f8-scim-gtk/distinfo.i386.fc8 b/textproc/linux-f8-scim-gtk/distinfo.i386.fc8
new file mode 100644
index 000000000000..f308d9f96970
--- /dev/null
+++ b/textproc/linux-f8-scim-gtk/distinfo.i386.fc8
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/8/scim-gtk-1.4.7-7.fc8.i386.rpm) = 10ac4d236445d8393b9ec2e03266665b
+SHA256 (rpm/i386/fedora/8/scim-gtk-1.4.7-7.fc8.i386.rpm) = e2ee0b209d5b7a7e0bf60d7dfc2a31fbe75d096ab4e892b09aa7133e4e49bc2a
+SIZE (rpm/i386/fedora/8/scim-gtk-1.4.7-7.fc8.i386.rpm) = 77056
+MD5 (rpm/i386/fedora/8/scim-1.4.7-7.fc8.src.rpm) = 983f86fa040f81be8e8aae227cf35cb1
+SHA256 (rpm/i386/fedora/8/scim-1.4.7-7.fc8.src.rpm) = 93faafef3ad42a8349007e7d28988dac23fea212ff55e9f957a07e4a54f12276
+SIZE (rpm/i386/fedora/8/scim-1.4.7-7.fc8.src.rpm) = 3121068
diff --git a/textproc/linux-f8-scim-gtk/pkg-descr b/textproc/linux-f8-scim-gtk/pkg-descr
new file mode 100644
index 000000000000..ff9dfc89a940
--- /dev/null
+++ b/textproc/linux-f8-scim-gtk/pkg-descr
@@ -0,0 +1,5 @@
+Smart Common Input Method platform, in short SCIM, is a development platform
+to make Input Method developers live easier. It has very clear architecture
+and very simple programming interface.
+
+WWW: http://www.scim-im.org
diff --git a/textproc/linux-f8-scim-gtk/pkg-plist b/textproc/linux-f8-scim-gtk/pkg-plist
new file mode 100644
index 000000000000..edea60a1536a
--- /dev/null
+++ b/textproc/linux-f8-scim-gtk/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD: /tmp/pcvs/ports/textproc/linux-f8-scim-gtk/Attic/pkg-plist,v 1.1 2008-11-21 15:45:58 hrs Exp $
+usr/lib/gtk-2.0/immodules/im-scim.so
+@dirrmtry usr/lib/gtk-2.0/immodules
+@exec chroot %D /usr/bin/gtk-query-immodules-2.0-32 > %D/etc/gtk-2.0/%%LINUX_RPM_ARCH%%-redhat-linux-gnu/gtk.immodules
+@unexec chroot %D /usr/bin/gtk-query-immodules-2.0-32 > %D/etc/gtk-2.0/%%LINUX_RPM_ARCH%%-redhat-linux-gnu/gtk.immodules
diff --git a/textproc/linux-scim-gtk/Makefile b/textproc/linux-scim-gtk/Makefile
new file mode 100644
index 000000000000..fbdc0bca65ff
--- /dev/null
+++ b/textproc/linux-scim-gtk/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: linux-scim-gtk
+# Date created: 21 November 2008
+# Whom: hrs
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-gtk
+PORTVERSION= # defined below
+CATEGORIES= textproc linux
+MASTER_SITE_SUBDIR= # defined below
+PKGNAMESUFFIX= -fc${LINUX_DIST_VER}
+DISTNAME= # defined below
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Smart Common Input Method platform, gtk module, Linux binary
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-x11-2.0.so.0:${PORTSDIR}/x11-toolkits/linux-gtk2 \
+ ${LINUXBASE}/usr/lib/libscim-1.0.so.8:${PORTSDIR}/textproc/linux-scim-libs
+
+MASTER_SITE_SRC_SUBDIR= # defined below
+SRC_DISTFILES= scim-${PORTVERSION}-${PORTSUBVERSION}.fc${LINUX_DIST_VER}${SRC_SUFX}
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX_RPM= yes
+USE_LDCONFIG= yes
+PLIST_SUB= LINUX_RPM_ARCH=${LINUX_RPM_ARCH}
+MD5_FILE= ${PKGDIR}/distinfo.${LINUX_RPM_ARCH}.fc${LINUX_DIST_VER}
+
+.if defined(OVERRIDE_LINUX_BASE_PORT) && ${OVERRIDE_LINUX_BASE_PORT} == f8
+PORTVERSION= 1.4.7
+PORTSUBVERSION= 7
+LINUX_DIST_VER= 8
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${PORTSUBVERSION}.fc${LINUX_DIST_VER}
+MASTER_SITE_SUBDIR= ../releases/${LINUX_DIST_VER}/Everything/${LINUX_RPM_ARCH}/os/Packages
+MASTER_SITE_SRC_SUBDIR= ../releases/${LINUX_DIST_VER}/Everything/source/SRPMS
+.elif defined(OVERRIDE_LINUX_BASE_PORT) && ${OVERRIDE_LINUX_BASE_PORT} == f7
+PORTVERSION= 1.4.5
+PORTSUBVERSION= 18
+LINUX_DIST_VER= 7
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${PORTSUBVERSION}.fc${LINUX_DIST_VER}
+MASTER_SITE_SUBDIR= ../releases/${LINUX_DIST_VER}/Everything/${LINUX_RPM_ARCH}/os/Fedora
+MASTER_SITE_SRC_SUBDIR= ../releases/${LINUX_DIST_VER}/Everything/source/SRPMS
+.else
+PORTVERSION= 1.4.4
+PORTSUBVERSION= 1
+DISTNAME= scim-libs-${PORTVERSION}-${PORTSUBVERSION}.fc${LINUX_DIST_VER}
+LINUX_DIST_VER= 4
+MASTER_SITE_SUBDIR= ../extras/${LINUX_DIST_VER}/${LINUX_RPM_ARCH}
+MASTER_SITE_SRC_SUBDIR= ../extras/${LINUX_DIST_VER}/SRPMS
+
+post-extract:
+ cd ${WRKDIR}/usr/lib && ${RM} -rf libscim-* scim-1.0
+.endif
+
+.for V in fc4 f7 f8
+makesum-${V}:
+ ${MAKE} PACKAGE_BUILDING=yes OVERRIDE_LINUX_BASE_PORT=${V} makesum
+.endfor
+makesum-all: makesum-fc4 makesum-f7 makesum-f8
+
+post-install:
+ @chroot ${PREFIX} /usr/bin/gtk-query-immodules-2.0-32 > ${PREFIX}/etc/gtk-2.0/${LINUX_RPM_ARCH}-redhat-linux-gnu/gtk.immodules
+
+.include <bsd.port.mk>
diff --git a/textproc/linux-scim-gtk/distinfo.i386.fc4 b/textproc/linux-scim-gtk/distinfo.i386.fc4
new file mode 100644
index 000000000000..25cea5323143
--- /dev/null
+++ b/textproc/linux-scim-gtk/distinfo.i386.fc4
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/4/scim-libs-1.4.4-1.fc4.i386.rpm) = f25bd31a5a0f6e524199a9f700ba0ee8
+SHA256 (rpm/i386/fedora/4/scim-libs-1.4.4-1.fc4.i386.rpm) = d5eae50f1b1ed241557a447aa6610591a86a85f5a4213794b83697b4828a0896
+SIZE (rpm/i386/fedora/4/scim-libs-1.4.4-1.fc4.i386.rpm) = 722213
+MD5 (rpm/i386/fedora/4/scim-1.4.4-1.fc4.src.rpm) = a5b60af9aa09ba4f7cb0e1d706648f07
+SHA256 (rpm/i386/fedora/4/scim-1.4.4-1.fc4.src.rpm) = 19d51a711b49d387d42f98f3340fab54ebfb1b0838276ec814c4da00b9edceb5
+SIZE (rpm/i386/fedora/4/scim-1.4.4-1.fc4.src.rpm) = 2624736
diff --git a/textproc/linux-scim-gtk/distinfo.i386.fc7 b/textproc/linux-scim-gtk/distinfo.i386.fc7
new file mode 100644
index 000000000000..7976d2e9291a
--- /dev/null
+++ b/textproc/linux-scim-gtk/distinfo.i386.fc7
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/7/scim-gtk-1.4.5-18.fc7.i386.rpm) = a2b75a06a5e590c17a940295bc5a4f14
+SHA256 (rpm/i386/fedora/7/scim-gtk-1.4.5-18.fc7.i386.rpm) = f470a2212c7e90cb45b22a73612a062e46b32b9cd7ef72fa870cb80f4a29fa97
+SIZE (rpm/i386/fedora/7/scim-gtk-1.4.5-18.fc7.i386.rpm) = 73138
+MD5 (rpm/i386/fedora/7/scim-1.4.5-18.fc7.src.rpm) = c11057bfaaff7fc6fcc278bdf3bec899
+SHA256 (rpm/i386/fedora/7/scim-1.4.5-18.fc7.src.rpm) = 4dbe60d2962e53c54cb237e82d152604a15b7b17166c8300075991512ef867b1
+SIZE (rpm/i386/fedora/7/scim-1.4.5-18.fc7.src.rpm) = 3210779
diff --git a/textproc/linux-scim-gtk/distinfo.i386.fc8 b/textproc/linux-scim-gtk/distinfo.i386.fc8
new file mode 100644
index 000000000000..f308d9f96970
--- /dev/null
+++ b/textproc/linux-scim-gtk/distinfo.i386.fc8
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/8/scim-gtk-1.4.7-7.fc8.i386.rpm) = 10ac4d236445d8393b9ec2e03266665b
+SHA256 (rpm/i386/fedora/8/scim-gtk-1.4.7-7.fc8.i386.rpm) = e2ee0b209d5b7a7e0bf60d7dfc2a31fbe75d096ab4e892b09aa7133e4e49bc2a
+SIZE (rpm/i386/fedora/8/scim-gtk-1.4.7-7.fc8.i386.rpm) = 77056
+MD5 (rpm/i386/fedora/8/scim-1.4.7-7.fc8.src.rpm) = 983f86fa040f81be8e8aae227cf35cb1
+SHA256 (rpm/i386/fedora/8/scim-1.4.7-7.fc8.src.rpm) = 93faafef3ad42a8349007e7d28988dac23fea212ff55e9f957a07e4a54f12276
+SIZE (rpm/i386/fedora/8/scim-1.4.7-7.fc8.src.rpm) = 3121068
diff --git a/textproc/linux-scim-gtk/pkg-descr b/textproc/linux-scim-gtk/pkg-descr
new file mode 100644
index 000000000000..ff9dfc89a940
--- /dev/null
+++ b/textproc/linux-scim-gtk/pkg-descr
@@ -0,0 +1,5 @@
+Smart Common Input Method platform, in short SCIM, is a development platform
+to make Input Method developers live easier. It has very clear architecture
+and very simple programming interface.
+
+WWW: http://www.scim-im.org
diff --git a/textproc/linux-scim-gtk/pkg-plist b/textproc/linux-scim-gtk/pkg-plist
new file mode 100644
index 000000000000..2d2ab9fd7a04
--- /dev/null
+++ b/textproc/linux-scim-gtk/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD: /tmp/pcvs/ports/textproc/linux-scim-gtk/pkg-plist,v 1.1 2008-11-21 15:45:58 hrs Exp $
+usr/lib/gtk-2.0/immodules/im-scim.so
+@dirrmtry usr/lib/gtk-2.0/immodules
+@exec chroot %D /usr/bin/gtk-query-immodules-2.0-32 > %D/etc/gtk-2.0/%%LINUX_RPM_ARCH%%-redhat-linux-gnu/gtk.immodules
+@unexec chroot %D /usr/bin/gtk-query-immodules-2.0-32 > %D/etc/gtk-2.0/%%LINUX_RPM_ARCH%%-redhat-linux-gnu/gtk.immodules